LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-27-2010, 03:58 AM   #1
gianco
LQ Newbie
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware -current
Posts: 7

Rep: Reputation: 0
Question Qt4 designer SIGSEGV on -current


Hi all,
I'm new to the forum, but not to Slackware, that I've been using since 1999.

I have a Slackware -current with the latest updates (2010, nov 22nd at time of writing) and the following packages:

qt-4.7.0_7abde40-i486-1
AlienBob's KDE 4.5.3

On my system, qt4 designer SIGSEGV on start. Running gdb against designer executables gives

Code:
Reading symbols from /usr/bin/designer...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/designer 
[Thread debugging using libthread_db enabled]
[New Thread 0xb0ad5b70 (LWP 16335)]
[New Thread 0xad8d6b70 (LWP 16336)]

Program received signal SIGSEGV, Segmentation fault.
0xb675af5d in QSettings::allKeys() const () from /usr/lib/qt/lib/libQtCore.so.4
I tried several times to get rid of the problem, deleting TrollTech.conf in $HOME, reinstalling qt, reinstalling kde, with no luck at all.

So, my questions are:
someone can confirm this, or I just broke things somehow?
if it is a general problem, someone was able to get rid of it?
Regards,

G.
 
Old 11-27-2010, 04:18 AM   #2
rayfward
Member
 
Registered: May 2009
Location: Leeds Uk
Distribution: Linux Ubuntu
Posts: 85

Rep: Reputation: 4
I'm not an expert on Qt4 design tools but you could try using the Gnome desktop to see if you get the same error. At least it would narrow down the candidates for the fault.
 
Old 11-27-2010, 05:16 AM   #3
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 498

Rep: Reputation: Disabled
I'm using slackware64-current with the latest changes up to Nov 22, the same qt version but the KDE 4.5.1 official packages from -current, and I can launch /usr/bin/designer without any crashes as a user.
 
Old 11-27-2010, 05:29 AM   #4
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
I run my version of current in Virtualbox and it's up to date with the recent changes. Qt designer works fine on this system so maybe KDE 4.5.3 is affecting things. I run the standard current KDE version 4.5.1.

Edit: Sorry for the duplication with rg3's information. I was typing this as he posted.

Last edited by bgeddy; 11-27-2010 at 05:31 AM. Reason: duplication
 
Old 11-27-2010, 06:13 AM   #5
gianco
LQ Newbie
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware -current
Posts: 7

Original Poster
Rep: Reputation: 0
Smile

Thank you all for your answers.

I guess I'll try to downgrade kde packages to official -current version and see what happens.

Regards,

G.
 
Old 11-27-2010, 07:33 AM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,314

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
FYI, designer launches fine also here with latest 64-current and alien's kde 4.5.3.
 
Old 11-27-2010, 11:58 AM   #7
gianco
LQ Newbie
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware -current
Posts: 7

Original Poster
Rep: Reputation: 0
Well, downgrading kde to official 4.5.1 doesn't resolve the issue, I guess I've
broken something installing some other package (I usually build with my own SlackBuilds).

I'll dig further into it and see what's going on.

Thank you all for your interest.

Regards,

G.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
qt4 in slackware-current olego Slackware 6 02-06-2010 04:53 PM
Opera 10 QT4 build broken on -current (by qt-4.5.3) firebird Slackware 1 11-06-2009 02:16 AM
qt4 designer ampersand on text sharky Programming 2 05-08-2009 08:10 AM
KDE sound system crashing with SIGSEGV, slackware-current, 2.6.17.13 StarsAndBars14 Linux - Desktop 0 03-09-2007 07:40 PM
Compiling qt4 apps for non-qt4 linux, win, mac birdseye Programming 4 10-31-2005 04:45 AM


All times are GMT -5. The time now is 12:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration