LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   QEMU >v1.5.0 Defaults to GTK Display (http://www.linuxquestions.org/questions/slackware-14/qemu-v1-5-0-defaults-to-gtk-display-4175476392/)

Chuck56 09-08-2013 02:47 PM

QEMU >v1.5.0 Defaults to GTK Display
 
Has anybody been successful enabling the new QEMU default GTK display using Slackware?

I've been playing around with QEMU 1.5.3 and 1.6.0 and haven't found the right combination yet to get the GTK display working. SDL display is working normally. The reason for working on the GTK display is based on the QEMU developer threads hinting SDL may be deprecated in future releases.

My host is 64 bit -current and the guests are both 32 bit 14.0 and 64 bit 14.0. The host and guests are full installs. Guest LILO is set to "vga=normal" to avoid using a framebuffer. The dependencies appear to be included in the Slackware provided packages (gtk-2.0 dev and vte dev). I've compiled using "--with-gtkabi=2.0" and even tried "--with-gtkabi-3.0" after installing VTE3 from SlackBuilds. No joy!

Any ideas? TIA.

jprzybylski 09-09-2013 12:20 AM

Just built qemu-1.6 on Slackware 14.0 on my little netbook (poor thing is not made for this) and gtk works fine.

Dumb question - during the configure step, did you pass '--enable-gtk'?

Chuck56 09-09-2013 07:18 AM

Quote:

Originally Posted by jprzybylski (Post 5024401)
...during the configure step, did you pass '--enable-gtk'?

Good question. Yes I tried it with and without that config option. No difference in the display functionality when running GTK. I'm wondering if it's something in the guest that has to be changed?

jprzybylski 09-09-2013 01:18 PM

Quote:

Originally Posted by Chuck56 (Post 5024597)
Good question. Yes I tried it with and without that config option. No difference in the display functionality when running GTK. I'm wondering if it's something in the guest that has to be changed?

Display functionality - as in the gtk window never pops up, just the sdl one? Because running qemu-system-xxx with '-display gtk' might help.

Or if you mean that the gtk window does pop up, but the guests are acting strangely, then I am sadly out of ideas. I've never had a problem with Slackware in a VM.

Chuck56 09-09-2013 02:43 PM

2 Attachment(s)
They work just fine other than the gtk display. I can access the guests with ssh or telnet into the ttyS0 while "-display gtk" is in effect (either blank or white vertical lines). When using "-display sdl" the display works as expected in addition to ssh and telnet.

TommyC7 09-09-2013 11:01 PM

I have actually had the same problem as you Chuck56 with the gtk thing in the newer qemu. My choice was to revert to using -sdl as well.

Chuck56 09-09-2013 11:26 PM

I'm going to wait for GTK feature to mature a bit more. SDL works so I'll stick with it for now. Thanks for the confirmation TommyC7.

aikempshall 10-28-2013 06:19 PM

Having upgraded from qemu 1.2 to 1.6 wasn't quite sure what I was looking at when booting up a WIN98 image. It starts OK with the splash screen then just gives up, resolving to vertical lines and the splash screen squashed vertically and repeated horizontally.

Eventually I came across the "-display sdl" option which resolved this issue.

Done a bit of digging and fell across this thread. My question is what is sdl and how is gtk different?

And, will sdl be taken away some time in the future?

Alex

Chuck56 10-28-2013 08:00 PM

Quote:

Originally Posted by aikempshall (Post 5054041)
...My question is what is sdl and how is gtk different?

And, will sdl be taken away some time in the future?

Alex

SDL is a library for up to 8 subsystems included display drivers:

SDL Library Documentation

The QEMU team already replaced the gtk display library for sdl display library as the default. It's just a matter of time before they retire the sdl display library completely.

Features/GtkDisplayState

It's good to see QEMU under active development. Sometimes it can be hard to keep up with. ;)


All times are GMT -5. The time now is 07:37 AM.