LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-13-2011, 12:40 AM   #1
zoran119
Member
 
Registered: Dec 2007
Posts: 217

Rep: Reputation: 18
qemu says my cpu is too old


hi all,

i'm trying to run windows 7 as a guest in qemu, and am getting the following error:

Code:
kvm: vm entry failed with error 0x80000021

If you're runnning a guest on an Intel machine without
unrestricted mode support, the failure can be most likely
due to the guest entering an invalid state for Intel VT.
For example, the guest maybe running in big real mode
which is not supported on less recent Intel processors.

kvm_run returned -22
i asked in #qemu on freenode, and someone suggested that my cpu is too old (intel q9550), but then i found someone having the same problem with an i7 (http://forums.meulie.net/viewtopic.php?f=43&t=6861).

i cannot find a solution to the problem on the net (or a confirmation that my cpu cannot do the job).

any ideas how to fix this?

edit: windows 7 installs fine, and then qemu gives this error after reboot. it runs fine (but sloooow) if i use -no-kvm.

Last edited by zoran119; 08-13-2011 at 12:41 AM.
 
Old 08-13-2011, 01:07 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,434

Rep: Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867
have a look at this topic, if you are using qemu-kvm on an AMD cpu on slackware 32bit with kernel <2.6.34 (it has be patched/rebuilt).

Last edited by ponce; 08-13-2011 at 01:09 AM.
 
Old 08-13-2011, 01:20 AM   #3
zoran119
Member
 
Registered: Dec 2007
Posts: 217

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by ponce View Post
if you are using qemu-kvm on an AMD cpu on slackware 32bit with kernel <2.6.34 (it has be patched/rebuilt).
i have an intel cpu and running 2.6.38 so i don't think this applies...
 
Old 08-13-2011, 02:57 AM   #4
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 495

Rep: Reputation: 207Reputation: 207Reputation: 207
It's not just your CPU: your motherboard has to support virtualization as well, something that can usually be enabled in BIOS. Do other OSes run as VMs without issue?
 
Old 08-13-2011, 03:06 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,563
Blog Entries: 2

Rep: Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035
The Core2Quad Q9550 supports hardware virtualization for sure. As said above, have a look in your BIOS if it is disabled. If you have a custom kernel it may be disabled there also.
If it is enabled in BIOS and kernel and works with other virtualization environments, like Virtualbox, I would file a bug against qemu.
 
Old 08-13-2011, 03:12 AM   #6
zoran119
Member
 
Registered: Dec 2007
Posts: 217

Original Poster
Rep: Reputation: 18
no problems with other vms. i run slackware, centos, ubuntu and windows xp, no problems at all. haven't tried virtual box...
 
Old 08-13-2011, 10:30 AM   #7
the3dfxdude
Member
 
Registered: May 2007
Posts: 316

Rep: Reputation: 87
You need to do this for KVM:
  • Have a CPU with extensions that support kvm. (I think it is vmx on intel chips)
  • Turn kvm on in the BIOS.
  • Boot slackware and modprobe kvm-intel, so your kernel you use needs to have support for it.
  • Run Qemu with kvm, having built for kvm
 
Old 08-13-2011, 10:33 AM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,563
Blog Entries: 2

Rep: Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035
Quote:
Originally Posted by the3dfxdude View Post
You need to do this for KVM:
  • Have a CPU with extensions that support kvm. (I think it is vmx on intel chips)
  • Turn kvm on in the BIOS.
  • Boot slackware and modprobe kvm-intel, so your kernel you use needs to have support for it.
  • Run Qemu with kvm, having built for kvm
Since he states that this problems only occur with a Windows 7 guest I think that all these requirements are fulfilled. I would rather think that it is a bug in qemu.
 
Old 08-15-2011, 07:23 AM   #9
zoran119
Member
 
Registered: Dec 2007
Posts: 217

Original Poster
Rep: Reputation: 18
works with virtualbox...
 
Old 08-15-2011, 07:27 AM   #10
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,563
Blog Entries: 2

Rep: Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035
Then I would file a bug against qemu.
 
Old 08-15-2011, 08:15 AM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,232

Rep: Reputation: Disabled
Are you running your Windows 7 guest in a VM with 4GB or more of memory allocated to it? If so, try reducing the amount of RAM for the guest to below 4GB.

Eric
 
Old 08-15-2011, 08:52 AM   #12
zoran119
Member
 
Registered: Dec 2007
Posts: 217

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by Alien Bob View Post
Are you running your Windows 7 guest in a VM with 4GB or more of memory allocated to it? Eric
no, i'm not. i have been trying with 2000 and 1000 mb... no luck. the command line is:

Code:
qemu -m 1000 -vnc :15 hd.qcow
 
Old 08-15-2011, 10:26 AM   #13
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 89
qemu-kvm-15.0 was released and the new code does not contain that error any more.
(see http://git.kernel.org/?p=virt/kvm/qe...iff;h=c94391b6)

The new version is in the "pending" queue of SlackBuilds.org awaiting approval.

I have no Windows 7 media here to test if this solves your problem, but it might be worth a try...
At least *that* message you will not see again
 
Old 08-15-2011, 12:54 PM   #14
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,232

Rep: Reputation: Disabled
If you are eager to test and not so eager to first compile qemu-kvm you can get a 0.15.0 package at http://slackware.com/~alien/slackbuilds/qemu-kvm/ .
This is for Slackware 13.37 and you will also need the VDE package against which my qemu-kvm has been compiled: http://slackware.com/~alien/slackbuilds/vde/

Eric
 
Old 08-15-2011, 04:48 PM   #15
zoran119
Member
 
Registered: Dec 2007
Posts: 217

Original Poster
Rep: Reputation: 18
i have installed alienbob's qemu-kvm 0.15.0 binary package... still getting the error...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cpu load high!!!! on qemu :( baxzius Linux - Newbie 5 08-11-2011 08:19 AM
qemu: hardware error: qemu: could not load PowerPC bios 'openbios-ppc' Skaperen Linux - Virtualization and Cloud 8 06-09-2011 07:15 AM
why is qemu and bochs taking cpu 100% baxzius Linux - Virtualization and Cloud 6 07-05-2010 03:11 PM
On qemu-kvm, qemu-ifup script not found on Slackware 13 AndrewGaven Linux - Virtualization and Cloud 14 01-29-2010 03:36 AM
Could Qemu be programed so that it uses not 100pct of the CPU all the time? frenchn00b Programming 1 06-01-2008 11:30 PM


All times are GMT -5. The time now is 04:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration