LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2006, 03:44 AM   #1
sl4ckw4re
Member
 
Registered: Jul 2006
Distribution: Slackware 10.2
Posts: 31

Rep: Reputation: 15
QEMU & KQEMU on slackware


Hi. I've found out that QEMU and KQEMU can boot another OS from within other (in my case I would like to boot WindowsXP from my Slackware system, so I don't have to reboot every time). Does anyone used it on Slackware ? Are there packages for it or I have to compile it from source, and if so could someone post what I need to do to boot my XP from Slack ? I don't know what info is needed for that, but please ask and I'll post output from every command you need. Thx.

*EDIT*
it's not necesarily has to be QEMU, if you've used smth else and it's working and stable please post that too.

Last edited by sl4ckw4re; 07-18-2006 at 03:46 AM.
 
Old 07-18-2006, 04:12 AM   #2
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Rep: Reputation: 30
Same here . Would like to boot XP from Slack.
 
Old 07-18-2006, 04:24 AM   #3
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Alien Bob has the necessary packages and SlackBuilds, see here.
 
Old 07-18-2006, 05:04 AM   #4
sl4ckw4re
Member
 
Registered: Jul 2006
Distribution: Slackware 10.2
Posts: 31

Original Poster
Rep: Reputation: 15
thx, but how about a tutorial or instructions on how to use it. i'm pretty much a .
 
Old 07-18-2006, 06:02 AM   #5
jimX86
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1
Posts: 231
Blog Entries: 1

Rep: Reputation: 34
There's a nice tutorial at the same place.
http://www.slackware.com/~alien/doku...slackware:qemu
 
Old 07-18-2006, 01:33 PM   #6
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Rep: Reputation: 30
Ok, I did get it installed just fine. I have only few issues. First, both my keyboard and mouse are USB, when I add '-usb -usbdevice host:xxxx:yyyy -usbdevice host:zzzz:wwww' I get
Code:
usb_host: only one interface supported
Warning: could not add USB device host:04a5:7008
. Is there any way to make both USB devices work ? Luckly I have a USB to PS/2 adapter for my mouse, but still I want to keep both on the USB ports if possible. And second question would be, can I/do I have to install my drivers just like in a normal Window$ installation ? I have all my drivers on the CD but should I install them ? I installed Window$ XP. Thx.

Btw, @ sl4ckw4re ... hope it worked out well for you too.
 
Old 07-18-2006, 01:39 PM   #7
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
For keyboard and mouse, what happens if you don't specify *anything*? Do they still work?
 
Old 07-18-2006, 02:00 PM   #8
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Rep: Reputation: 30
well, when I tried to install windows having both keyboard and mouse on the USB ports, the install just got stuck at Installing Devices (37 minutes). So I removed the mouse from the USB port, put it on the PS/2 port, and added only host:xxx:yyy for the keyboard and it works. But my mouse is so sensitive on the PS/2 port (it is USB optical mouse). I mean I barely touch it and it goes all the way in the other part of the screen, too damn sensitive. And the keyboard, well everything works but the NUM buttons (you know, the numbers and aritmetichal signs in the right)... didn't got a chance to check the multimedia buttons but I don't think they work and they aren't that important. Do you know about my second question ? Can I install the drivers from the CD just like I would install to a normal Windows system ?
 
Old 07-18-2006, 02:05 PM   #9
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
No, what I wanted you to try is have your mouse and keyboard on USB but not specify anything about them to Qemu. Because I think that Qemu simulates a normal PS2 mouse and keyboard and Windows is not supposed to know they are USB devices.
 
Old 07-18-2006, 02:13 PM   #10
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Rep: Reputation: 30
Yeah, I did that and they're working both now, but not when I tried to install Windows, it got stucked if they wore on the USB ports at install. Now I've just shut down Windows, closed the process moved the mouse back to USB port, started qemu again and they both work and QEMU sees them as PS/2 mouse and keyboard. Anyway, I've encountered another issue at the moment. My network is not working. I've setup my ip's and everything (I have a static IP address) but it's not working. I've tracked my problem at the MAC address. For whatever reason it shows me other MAC than my real one, and my ip is based on my MAC. If my MAC doesn't matches the IP in the server of my ISP then no net. How can I change my MAC to the real one ?
 
Old 07-18-2006, 02:28 PM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,192

Rep: Reputation: Disabled
Remember that QEMU emulates ALL the hardware for the virtual machine: the virtual mouse and keyboard have no connection to the physical devices. An exception is made for a USB mouse if you want that, but this was originally just meant to test the (then) new USB support in QEMU. The default keyboard/mouse in QEMU are emulated PS/2 devices.
You should not have to specify anything on the commandline and it should work. If you want sound or access to physical USB devices (printer, scanner) in the virtual machine, you still have to pass commandline parameters.

Eric
 
Old 07-18-2006, 02:36 PM   #12
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Rep: Reputation: 30
thx Alien Bob, I was hoping for you to see this thread . Could you give more assistance in the other issues please. I have a few questions, if you can and know the answers.
1. Can I install the drivers from my drivers CD for the motherboard/video card/lan/etc (or if not for all, maybe you can the the piece of hardware for which I can install them). I see it only recognizes my video card as 4Mb card - from 128Mb.

2. How can I make my network to work ? I said in my previous post my IP is checked in my ISP's server based on my network card's MAC. I booted in the QEMU Windows install and checked my network card MAC and it's not the same with the real MAC of my card, how can I change it to make it work. I have static IP.

3. How can I check if acceleration is enabled (kqemu) cause it looks pretty slow to me (yes I know it's emulated and all that, but as I've read in your tutorial the system fully installed should run faster then the installation process, but actually it runs the same). I've passted the -kernel-kqemu option when I started qemu and it shows a bit of improvment but I've read that they are 2 diferent accelerations , kemu accelerates user-processes and -kernel-kqemu accelerates the Guest OS's kernel processes.

That would be all ... for now, I may post in the future. I would greatly appreciate if you could help me in this matter. Thx, and looking forward to your replay('s). Untill then, I'll keep .

*EDIT*
Oh, and 4. I have 512DDR, I've set
Code:
none             /dev/shm         tmpfs       size=512m        0   0
and I run qemu with the following command
Code:
none             /dev/shm         tmpfs       size=512m        0   0
. Is that OK ? What should I modify and where, for best performance in the Guest OS, but still keep the Host OS stability under control, I wouldn't want to have to make a force reboot.

Last edited by nykey; 07-18-2006 at 02:39 PM.
 
Old 07-18-2006, 04:27 PM   #13
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
So would qemu allow me to run windows and that windows installation have micorosoft drivers for a scanner?

If not I guess I'm gonna try out this tutorial

http://www.howtoforge.com/ubuntu_vmware_server

one of the gents on the linux general says I should be able to run vmware, but since qemu already tried and true and info/help how to for slackware may be my better option.
 
Old 07-19-2006, 01:16 AM   #14
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
nykey, you need to understand that qemu emulates a PC. This PC has certain characteristics which have absolutely nothing (or nearly) to do with your real PC. Look into the doc of qemu, it describes what PC is emulated. It makes no sense to install drivers which correspond to your real PC, you need to install drivers in qemu which correspond to your virtual PC.

The network part is tricky with qemu, again, read the doc. I think that Alien Bob also has some doc on this. To Old_Fogie, network is the part where VMWare shines in contrast to qemu, but it's only really important if you want to run servers in your virtual machine.

And, in order to check if the kernel module actually accelerates, again, read the doc. There's some key combination to access the qemu console (ALT-2 or CTRL-ALT-2, I don't remember and I'm not at my box now), where you issue a command like 'show kqemu'. It's all in the doc of the kernel module.

So after mentionning the doc, there's also a dedicated forum for qemu where a search usually yields some interesting answers. Google is your friend to find the forum.

Last edited by uselpa; 07-19-2006 at 01:18 AM.
 
Old 07-19-2006, 03:35 AM   #15
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
Quote:
How can I make my network to work ?
Again, think *emulated* as in your Win hardware *will_not* be your real hardware.

In a nutshell, Qemu "fools" Win into that Win is running on real hardware. But Win runs inside a container. Such container is software that's named Qemu. Pretty good trick, eh?

The win mac addr comes from the Qemu *emulated* NIC which means it will be a different mac addr than what your *real* NIC has.

So, two NICs, thus: 1. real NIC = Slackware NIC, 2. emulated NIC = MS_Win NIC

http://groups.google.com/group/alt.o...a23ecad3178d63

Slackware virtualization - subleaf on network

that post at url helps on network.

I've Win 2K SP4 running (rather nicely) in Qemu on top of Slackware.

running Samba on host (Slackware) is key. Key also are all IP addr for Qemu designated items such as like for DNS and the NAT server -- I put these IP addr into Win TCP/IP settings/properties -- also herein, have Win set to "obtain IP addr automatically" (yes, Qemu has it's own built in DHCP server)

almost abra cadabra for me at this point. -- I'm unable to browse the LAN and or LANS in Win and "find" anything, a share, etc.

So, key (at least for me) to now right click on the Win "my computer" icon and choose "map network drive"

right now I forget what typed/entered into that. But i found already answered at the Qemu forums what to enter into that. *Now* my share works, I can LAN network share files between the host and the guest OS's.

Tried Win web browser and *it's working* is on the internet. DL'd firefox for Win and installed it. Now I can simultaneously browse www via both Slackware firefox and Win firefox.

My *real* LAN is at 192.168.1.xxx

which I allowed to confuse me for a while as in how can that work with Qemu 10.0.whatever IP range. But it works -- the Qemu NAT and DNS must do it along with Qemu finds a running Samba server and gets the guest OS hooked up with the host OS for network file sharing.

After the fact (I got it working) I can see that it's *easy* to get the networking going.

--
Alan.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Qemu with kqemu support problem luke-indul Ubuntu 2 05-31-2006 02:35 PM
Got error in compiling kqemu with qemu depam Linux - Software 15 05-03-2006 05:47 PM
Help me please..I need an Installation script to install qemu with kqemu on Mepis depam Linux - Software 1 04-24-2006 06:32 PM
Qemu with KQemu cormack Linux - Software 12 04-05-2006 08:43 PM
DISCUSSION: Slackware/Qemu with internet HOW-TO scuzzman LinuxAnswers Discussion 0 02-25-2006 06:59 PM


All times are GMT -5. The time now is 03:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration