LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-09-2004, 07:01 PM   #1
snowman156
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware 10.0
Posts: 22

Rep: Reputation: 15
Python Errors - Ipodder


I'm having an issue with a python program that I am trying to run on Slackware 10.0 and cannot seem to find a solution for. I'm trying to run Ipodder for Linux and although it is rumored to work on Conectiva, I can't get it to work on Slack, FC3, or Mandrake 10.1. The only package I could find is the .rpm so (in Slack) I first did:

rpm2tgz ipodder-1.1.2-1cl.noarch.rpm

installpkg ipodder-1.1.2-1cl.noarch.tgz

It seemed to install, but everytime I try to run the executable, I get this:

Traceback (most recent call last):
File "iPodderGui.py", line 1, in ?
import wx
ImportError: No module named wx

Thinking I was missing some python library, I installed the following:

wxPython-2.5.3.1-i686-1mbr.tgz
python-xlib-0.12-i486-1ja.tgz
wxGTK-2.4.2-i486-1.tgz

After I did that, I ran ipodder again and get this:

Traceback (most recent call last):
File "iPodderGui.py", line 1, in ?
import wx
File "/usr/lib/python2.3/site-packages/wx-2.5.3-gtk2-unicode/wx/__init__.py", line 42, in ?
from wx._core import *
File "/usr/lib/python2.3/site-packages/wx-2.5.3-gtk2-unicode/wx/_core.py", line 4, in ?
import _core_
ImportError: libwx_gtk2u_xrc-2.5.so.3: cannot open shared object file: No such file or directory

Can anybody point me in the right direction here as far as where to look for a solution? My googling has resulted in very little relating to either Ipodder or my particular error mesg. Thanks in advance
 
Old 12-09-2004, 07:41 PM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Try installing wxBase (you can get it from linuxpackages.net)

Edit: I took a look at wxwidgets.org (wx's homepage) and I saw there's 2.5.3 version which it seems that Ipodder is looking for, try getting that version, the one you installed and it's on linuxpackages is 2.4.2.

Last edited by gbonvehi; 12-09-2004 at 07:46 PM.
 
Old 12-09-2004, 08:37 PM   #3
snowman156
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware 10.0
Posts: 22

Original Poster
Rep: Reputation: 15
I tried the wxbase but got the same error. I uninstalled the wxpython-2.5.3 and installed the wxpython-2.4.2 with the corresponding wxbase and still get the same error.
 
Old 12-09-2004, 09:47 PM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Try matching both packages (or compile them) to 2.5.3. Take a closer look at Ipodder requirements too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
python errors coffeedemon Linux - Newbie 2 05-07-2006 03:18 PM
KDE3.5 Upgrade kdebindings-python dependency errors EclipseAgent Suse/Novell 26 12-27-2005 09:46 AM
make compile errors -- python problems??? p_motch Linux - Newbie 2 07-11-2004 07:37 PM
Bittorrent: python errors davoman Linux - Software 2 04-16-2004 02:45 PM
python errors xconspirisist Linux - Software 1 02-16-2004 06:00 AM


All times are GMT -5. The time now is 04:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration