LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Python Bus Error on current (http://www.linuxquestions.org/questions/slackware-14/python-bus-error-on-current-4175454741/)

yenn 03-19-2013 02:50 PM

Python Bus Error on current
 
Hi,

after latest upgrade (Mon Mar 18 22:03:18 UTC 2013) on current some python programs (wicd, picard) won't start. They fails on "Bus Error" which basically means that program gets SIGBUS signal and quit. I don't know which upgrade broke this, because last upgrade I took was on Fri Mar 1 05:41:39 UTC 2013 and many things (kernel, glibc, ...) got updated since then. Wicd and other things were definitely working before upgrade.

I'm not sure if that matters, but I ran own-build kernel 3.8.3.

Code:

yenn@neuromancer:~$ wicd-client 
Has notifications support True
Bus error

I run python self-test and it failed too
Code:

yenn@neuromancer:~$ python -c "from test import testall"
[...]
ctypes
ctypes._endian
ctypes.macholib
ctypes.macholib.dyld
Bus error

therefore I guess there is something broken either in Python or in system libraries which got upgraded recently.

Anyone experienced this?

willysr 03-19-2013 03:20 PM

I'm using 3.8.3 as well and all upgraded to -Current, but it's working fine here
have you confirmed that you have installed all the updates in -Current and not partial update?

yenn 03-19-2013 03:50 PM

Well, I did partial upgrade - upgraded everything, but didn't installed new packages - because I don't have full slackware install (don't use KDE, XFCE and Emacs for instance) and with slackpkg's 'install-new' I have manually unselect everything from KDE.

Anyway I just run 'slackpkg install-new', skipped KDE, added ddd and xf86-video drivers and now it's working like a charm. I'm not sure what was missing, but thanks!


All times are GMT -5. The time now is 07:43 AM.