LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   python 2.7 anytime? (http://www.linuxquestions.org/questions/slackware-14/python-2-7-anytime-863901/)

metageek 02-20-2011 02:17 PM

python 2.7 anytime?
 
Is python 2.7 going to appear in Slackware anytime soon? I see that -current only has 2.6.6. I really like Calibre (an ebook management and conversion program) and the latest versions need python 2.7 (the SBo slackbuild has stopped at the last version that could be done with python 2.6). I can install 2.7 side by side with an older version, but I was hoping not to have to do that ...

By the way, Calibre would be a really good addition to Slackware too.

larryhaja 02-20-2011 03:22 PM

As far as the python 2.7 dependency in calibre is concerned, it should work just fine with python 2.6. I believe the developer just wants to support 1 version of python.

I just happen to try and build calibre 0.7.46 in an updated Slackware -current VM yesterday (2/19/11). It fails to build even on current despite not having python 2.7. As far as I can see it, sip, PyQt, and kdebindings need to be upgraded in that order for calibre to build (actually kdebindings just need to rebuilt).

Also, I think QScintilla needs to be upgraded.

rg3 02-20-2011 05:17 PM

This is just a wild guess, but I wouldn't bet for Python 2.7 to be in the next stable release. I'm pretty sure we're somewhat close to a new release, and upgrading Python would require a lot of packages to be rebuilt for it. My bet would be in the next release cycle.

metageek 02-21-2011 09:14 AM

Quote:

Originally Posted by larryhaja (Post 4265069)
As far as the python 2.7 dependency in calibre is concerned, it should work just fine with python 2.6. I believe the developer just wants to support 1 version of python.

That's what I thought and was building it using the SBo package that exists for 0.7.37 for up to 0.7.44. However I then noticed that some functions were failing silently. Thus I moved back to 0.7.37 which builds cleanly in Slackware 13.1

Quote:

Originally Posted by larryhaja (Post 4265069)
I just happen to try and build calibre 0.7.46 in an updated Slackware -current VM yesterday (2/19/11). It fails to build even on current despite not having python 2.7. As far as I can see it, sip, PyQt, and kdebindings need to be upgraded in that order for calibre to build (actually kdebindings just need to rebuilt).

Also, I think QScintilla needs to be upgraded.

At least up to Calibre 0.7.44 there is no need for any upgrades, the package in SBo works fine.

I will try to install python 2.7 side by side with the current version in Slackware to build the latest Calibre (it really is that good)

metageek 02-21-2011 09:16 AM

Quote:

Originally Posted by rg3 (Post 4265192)
This is just a wild guess, but I wouldn't bet for Python 2.7 to be in the next stable release. I'm pretty sure we're somewhat close to a new release, and upgrading Python would require a lot of packages to be rebuilt for it. My bet would be in the next release cycle.

Yes, I thought so too... I like the stability of Slackware, but in this case it is a bit behind; they just released python 3.2 ...

rg3 02-21-2011 05:13 PM

Python 3.x is a different branch and language, and there are many more aspects to take into account, like compatibility with 3rd party packages. The most recent Python 2 version, on the other hand, is 2.7. Debian is shipping Python 2.6, so are doing Novell, Red Hat or Ubuntu. Slackware is no different or behind from that point of view.

larryhaja 02-21-2011 06:25 PM

Quote:

Originally Posted by metageek (Post 4265911)
That's what I thought and was building it using the SBo package that exists for 0.7.37 for up to 0.7.44. However I then noticed that some functions were failing silently.

Intersting...can you give me an example of a function that is failing? I'm not aware of this. I submitted a build script to SBo on version 0.7.45, which is the last version that builds on 13.1 and current. If there is an issue then I'd like to retract that build.

metageek 03-05-2011 01:14 PM

Quote:

Originally Posted by larryhaja (Post 4266603)
Intersting...can you give me an example of a function that is failing? I'm not aware of this. I submitted a build script to SBo on version 0.7.45, which is the last version that builds on 13.1 and current. If there is an issue then I'd like to retract that build.

Oops, this was a while ago, I'll have to go back to 0.7.44 to see what was not working.

BTW, why did versions above 0.7.45 fail to build in slackware? What is missing? This is really a good program and it would be great to get updated versions in slackware. (this thread is changing to calibre, we should probably continue in a new thread)

larryhaja 03-05-2011 01:31 PM

Quote:

Originally Posted by metageek (Post 4279979)
BTW, why did versions above 0.7.45 fail to build in slackware? What is missing?

sip >= 4.12, PyQt >= 4.8.2, and Qt >= 4.7.0. Although python 2.7 is now a requirement it still will compile with 2.6. Not sure of any problems using 2.6.


All times are GMT -5. The time now is 01:20 AM.