LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-20-2012, 06:00 AM   #1
elexwave
LQ Newbie
 
Registered: Sep 2012
Distribution: Slackware
Posts: 7

Rep: Reputation: Disabled
Question python 2.7.3 and GNS3


I use slackware 14. I tried to recompile python to enable unicode ucs4. GNS3 is needed to run virtualbox together. but when I run GNS3, there is a message :
"Can not import Qt modules, PyQt is probably not installed ..."
when the same replace the default python of slackware 14. GNS3 can run. this is weird, I only add the options:
-enable-unicode = ucs4
Can anyone help me?

Last edited by elexwave; 11-20-2012 at 06:50 AM.
 
Old 11-20-2012, 07:09 AM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
Did you install PyQT?
 
1 members found this post helpful.
Old 11-20-2012, 05:04 PM   #3
elexwave
LQ Newbie
 
Registered: Sep 2012
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: Disabled
I have installed PyQt. It's default on slackware.
 
Old 11-20-2012, 06:26 PM   #4
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
GNS3 is needed for Virtualbox? Since when? I have it installed on 2 of my vm servers and I don't have GNS3 on there. Unless you are talking about a different GNS3 other than the Cisco gear emulator.
 
1 members found this post helpful.
Old 11-21-2012, 07:48 AM   #5
elexwave
LQ Newbie
 
Registered: Sep 2012
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: Disabled
yes needed, since I want to the other system and cisco router join together. :P
ok, I'll describe what I have done :
I have installed GNS3 and Virtualbox.
I have compiled python with prefix --enable-unicode = ucs4 to fix this problem
Quote:
$ ldd -r VBoxPython2_7.so
linux-gate.so.1 (0xffffe000)
libpython2.7.so.1.0 => /usr/lib/libpython2.7.so.1.0 (0xb7571000)
VBoxXPCOM.so => /opt/VirtualBox/VBoxXPCOM.so (0xb7445000)
VBoxRT.so => /opt/VirtualBox/VBoxRT.so (0xb70f2000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb700b000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb6fed000)
libc.so.6 => /lib/libc.so.6 (0xb6e68000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb6e4e000)
libdl.so.2 => /lib/libdl.so.2 (0xb6e49000)
libutil.so.1 => /lib/libutil.so.1 (0xb6e45000)
libm.so.6 => /lib/libm.so.6 (0xb6e19000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0xb6de5000)
libz.so.1 => /lib/libz.so.1 (0xb6dcf000)
librt.so.1 => /lib/librt.so.1 (0xb6dc6000)
/lib/ld-linux.so.2 (0xb77a1000)
undefined symbol: PyUnicodeUCS4_DecodeUTF16 (./VBoxPython2_7.so)
undefined symbol: PyUnicodeUCS4_AsUTF16String (./VBoxPython2_7.so)
undefined symbol: PyUnicodeUCS4_AsUTF8String (./VBoxPython2_7.so)
undefined symbol: PyUnicodeUCS4_FromObject (./VBoxPython2_7.so)
undefined symbol: PyUnicodeUCS4_GetSize (./VBoxPython2_7.so)
undefined symbol: PyUnicodeUCS4_DecodeUTF8 (./VBoxPython2_7.so)
but GNS3 can't run with message "Can not import Qt modules, PyQt is probably not installed ..."
when I install again default python of slackware 14. GNS3 can run, but I can't fix PyUnicodeUCS4.

no opinion?

Last edited by elexwave; 11-22-2012 at 06:30 AM.
 
Old 11-22-2012, 08:51 AM   #6
elexwave
LQ Newbie
 
Registered: Sep 2012
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: Disabled
yeah, finally i can fix my problem.
- just install virtualbox ose from slackbuilds
- copy xpcom to python libraries directory
- then, we must install xdotool
- awesome, we can run virtualbox with GNS3 on slackware.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GNS3 jmendezmch Linux - Newbie 1 11-02-2012 01:05 PM
Installing GNS3 on CentOS hazdingo Linux - Networking 10 10-02-2010 05:59 AM
GNS3 install on slackware 12.1 shammont Linux - Software 6 04-24-2010 04:12 PM
UPgrading gns3 0.6.1 to 0.7 on centos tzer0 Linux - Newbie 1 04-09-2010 06:51 PM
GNS3 v0.6.1 install on slack 12.2 eylli Slackware 1 02-27-2010 12:17 PM


All times are GMT -5. The time now is 11:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration