LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-02-2010, 08:52 PM   #1
alpha_hack
Member
 
Registered: Jul 2007
Location: Sofia, Bulgaria
Distribution: Slackware 13.1x86_64
Posts: 75

Rep: Reputation: 15
pulseaudio slackware 13.1x64


Hey

I've recently switched to Slackware 13.1x64.
I can't get pulseaudio to work. Is it available for 64 bit machines or I have to build it with the 32 bit compiler ( I've added 32 support and I can compile/run 32 bit programs)

Is there any chance a packet could be released for 13.1x64 ?


Thanks in advance,
Me
 
Old 09-02-2010, 09:38 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,454
Blog Entries: 3

Rep: Reputation: 182Reputation: 182
and get the build scripts. extract it.
then get the latest pulseaudio http://0pointer.de/lennart/projects/...-0.9.21.tar.gz
and place it in your pulse audio folder you created when you extracted it.
for 64 bit you edit the pulseaudio.SlackBuild change the build script to
Quote:
PRGNAM=pulseaudio
VERSION=0.9.10 <------ change to 0.9.21
ARCH=${ARCH:-i486} <----change to x86_64
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
no need for multi lib
make sure theses are installed
Quote:
Pulseaudio requires libatomic_ops, libsamplerate, and libsndfile.
It will also make use of jack-audio-connection-kit. All of these
dependencies are available at SlackBuilds.org.
libatomic_ops is in slackbuild 13.1
libsamplerate is in slacbuild 13.0

Note pulse audie 0.9.10 will not build with the gcc 4.4.4 that is why you need the new one 0.9.21
If you have a problem email me I will send you the prebuilt packages.

Last edited by Drakeo; 09-02-2010 at 10:34 PM.
 
1 members found this post helpful.
Old 09-03-2010, 01:19 AM   #3
Mark Pettit
Member
 
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.1 64 Multi-Lib
Posts: 421

Rep: Reputation: 123Reputation: 123
Please don't take this as any form of criticism - I just find it quite amusing that there are hundreds of articles on how to remove PulseAudio from Ubuntu, and here we find people trying to get it into Slackware. Jokes aside, I do think the intentions (ie goal) of PulseAudio is great and I hope you come right :-)
 
Old 09-06-2010, 06:58 PM   #4
alpha_hack
Member
 
Registered: Jul 2007
Location: Sofia, Bulgaria
Distribution: Slackware 13.1x86_64
Posts: 75

Original Poster
Rep: Reputation: 15
Hey,

@Drakeo: Thank you very much! I've tried that a couple of times but it didn't work. After your post I found out that for some reason libsndfile was in /usr/lib... and that confused the auto configuration.
After installing libsndfile to the right paths and etc this slackbuild worked just fine.

If you're planning on having the scripts from Slackbuild.org make sure that your libdir is set to /usr/lib64. With me it putted the libraries to /usr/lib and that's why I couldn't recompile gnome-media (contains gnome volume control and etc...)

If you're planning to recompile GSB gnome-media - download the scripts from http://ftp.osuosl.org/pub/gsb/gsb64-...p/gnome-media/ .

If while compiling you get this error:
Code:
checking build system type... configure: error: /bin/sh build-aux/config.sub --linux failed
configure: WARNING: cache variable ac_cv_build contains a newline
Open up gnome-media.SlackBuild, find&replace this:
Code:
Find:
# Configure.
CFLAGS="$TUNE_CFLAGS $EXTRA_CFLAGS" CXXFLAGS="$TUNE_CFLAGS $EXTRA_CFLAGS" \
  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
  --mandir=/usr/man $CONFIGURE_FLAGS \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --build=$ARCH-$DISTRO-linux \
  --target=$ARCH-$DISTRO-linux \
  --disable-static \
  --enable-shared \
  --disable-schemas-install \
  --disable-pulseaudio \
  --enable-silent-rules \
  --enable-gstmix \
  --enable-gstprops \
  || exit 1

Replace with:
# Configure.
CFLAGS="$TUNE_CFLAGS $EXTRA_CFLAGS" CXXFLAGS="$TUNE_CFLAGS $EXTRA_CFLAGS" \
  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
  --mandir=/usr/man $CONFIGURE_FLAGS \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --build=$ARCH-$DISTRO-linux \
  --target=$ARCH-$DISTRO-linux \
  --disable-static \
  --enable-shared \
  --disable-schemas-install \
  --disable-pulseaudio \
  --enable-silent-rules \
  --enable-gstmix \
  --enable-gstprops \
#  || exit 1
If that doesn't fix it for you... try just running /tmp/gnome-media-*/.configure. If that goes through without errors then try building it from the SlackBuild. I don't know why or how that fixes it ... it just worked for me.... Don't wanna know...

If I have some time I'll post this into the LQ Wiki db.

Again - thanks and good luck to others
 
Old 09-07-2010, 11:37 PM   #5
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,454
Blog Entries: 3

Rep: Reputation: 182Reputation: 182
Quote:
PRGNAM=pulseaudio
VERSION=0.9.10 <------ change to 0.9.21
ARCH=${ARCH:-i486} <----change to x86_64
BUILD=${BUILD:-1}
go look at the scripts that is why theses changes are a must.
For libsndfile this handles it
Quote:
PRGNAM=libsndfile
VERSION=1.0.20
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
this is why we use the slack scripts for 13.1 and some of 13.0 they use this small script to set up arch and /usr/lib64
Quote:
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
I added it to the 13.0 scripts after changing the version. then submitted it to Slackbuilds. Robby asked if I wanted to maintain it. I have no real love for pulseaudio.

Last edited by Drakeo; 09-07-2010 at 11:51 PM.
 
Old 09-09-2010, 01:58 PM   #6
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Quote:
Originally Posted by alpha_hack View Post
Hey

I've recently switched to Slackware 13.1x64.
I can't get pulseaudio to work. Is it available for 64 bit machines or I have to build it with the 32 bit compiler ( I've added 32 support and I can compile/run 32 bit programs)

Is there any chance a packet could be released for 13.1x64 ?


Thanks in advance,
Me
You may be interested in some of the things I encountered in my attempt to play with pulseaudio back in March.

http://www.linuxquestions.org/questi...urrent-792080/

Basically, follow the build order from SlackBuilds.org (as others have suggested). You don't need to install GSB or another gnome based Slackware install to use pulse. However, you will need to do that if you want to build the nice GUI pulseaudio control applications.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pulseaudio and jack davebritton Linux - Software 1 09-07-2010 02:45 PM
Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio William (Dthdealer) Linux - Software 5 06-13-2010 07:30 AM
Anyone using pulseaudio? Daedra Slackware 14 04-15-2010 01:10 PM
[SOLVED] Mic works, but doesn't record on Slackware 13 + Pulseaudio woes Ahmed Slackware 22 09-12-2009 12:16 PM
Pulseaudio RAFAL Linux - Software 7 08-23-2008 03:37 PM


All times are GMT -5. The time now is 10:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration