LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-09-2002, 09:49 AM   #1
Sifvion
Member
 
Registered: Jan 2002
Location: Singapore
Distribution: Slackware
Posts: 250

Rep: Reputation: 30
Proftpd Password Auth


I got my Proftpd running , i did a ftp using browser but i cant seem to login in! Is there any files i should change? I thought it will use the password (/etc/passwd) which i use to login to my box? If it doesnt do that which files do i need to configure or create? And I notice there is a folder call ftp in my /home dir do i need to set anything for that dir /home/ftp?


Need to set up the ftp server because I want to learn 2nd I want to show my friend that slackware have not problem running ftp server.

Thanks in Advance

by the I had search the forum before i ask. If i missed out something i am sorry
 
Old 09-09-2002, 12:15 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Well if you have anonymous login enabled, that /home/ftp is the default directory for that. If you have a user with a shell account, when they login, it will default to their own home directory.
 
Old 09-09-2002, 12:32 PM   #3
Sifvion
Member
 
Registered: Jan 2002
Location: Singapore
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 30
I configure nothing in /etc/proftpd.conf everything is default.
When i try to login as a user which have a shell account it keep promting me for password in the browser.

When i look in /var/log/proftpd.log

USER deep (Login failed): Incorrect password
either that or
Invalid shell

Which is impossible because i use this user to login everytime
 
Old 09-09-2002, 01:31 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Have you tried to login anonymously ? Its usually default with anonymous login when first setup. You could try to disable anonymous login by editing your /etc/ftpusers file, then try to login with an actual shell account.
 
Old 09-09-2002, 10:36 PM   #5
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
In regard to the "invalid shell" message. Please check the /etc/passwd entry for the user and insure that a shell statement is provided after the last colon. It is usually set to /bin/bash. There are some programs that default the shell as blank when adding a new user.

Also, only if you compiled from source and installed you may need to use --disable-pam on the ./configure command.
 
Old 09-10-2002, 10:39 AM   #6
Sifvion
Member
 
Registered: Jan 2002
Location: Singapore
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 30
okie I looked at the /etc/passwd and i saw

deep:x:4556:0:Sifvion:/home/deep:

There is no :/bin/bash so what i did is add that behind. I will try it out and post the result laterr.

Thanks for replying
 
Old 09-10-2002, 11:11 AM   #7
Sifvion
Member
 
Registered: Jan 2002
Location: Singapore
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 30
Yes Excalibur is right i add the line /bin/bash behind it work flawlessly.

Last Question where can i create any login msg for the user to see when they access my ftp server?
 
Old 09-10-2002, 11:37 AM   #8
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
usually with proftpd, you need to create a welcome.msg file with your default message. it explains this process in the /etc/proftpd.conf file.
 
Old 09-11-2002, 10:01 AM   #9
Sifvion
Member
 
Registered: Jan 2002
Location: Singapore
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 30
Yes i see that but where do i put the files after i create?
 
Old 09-11-2002, 10:29 AM   #10
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Mine are in /home/ftp directory.
 
Old 09-12-2002, 08:53 AM   #11
Sifvion
Member
 
Registered: Jan 2002
Location: Singapore
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 30
Okie thanks Excalibur i will try that when i get home.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd auth julc Linux - Software 2 09-12-2005 09:00 AM
proftpd with mysql auth pumazi Linux - Software 0 07-03-2005 01:30 PM
proftpd LDAP auth failing tisource Linux - Networking 1 03-30-2005 05:32 PM
[PROFTPD] LDAP vs basic auth. Creak Linux - Security 1 09-21-2004 07:52 PM
Would like to get CourierImap, Sasl and ProFTPd to auth from MySql pembo13 Linux - Networking 0 03-29-2004 10:26 PM


All times are GMT -5. The time now is 05:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration