LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-18-2007, 07:24 AM   #1
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Rep: Reputation: 36
proftpd not working correctly


hello everyone
for sometime now i had, or well, i tohught i had set up correctly proftpd as ftp server.
but i was trying today to make an rc.firewall script. and now proftpd doesn'r 'play' correctly even when i flush iptables!

i stop the firewall and verifiy its stopped:
iptables -L returns that all chains have policy accept.

and my proftpd.conf is rather standard.. i have however changed the ftp port to 11121 (QUESTION: should i put the ftp-data port in rc.firewall at port=11120, should i leave it at 20 necessarily? any ideas??)here it is

Code:
# This is a basic ProFTPD configuration file.
# It establishes a single server and a single anonymous login.
# It assumes that you have a user/group "nobody" and "ftp" 
# for normal/anonymous operation.

ServerName			"ProFTPD Default Installation"
ServerType			standalone
#ServerType			inetd
DefaultServer			on

# Port 21 is the standard FTP port.
Port				11121
#Port				21

#MasqueradeAddress		synthnassizer.no-ip.org
#PassivePorts			62000 64000

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask				022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances			30

TimeoutLogin			30
TimeoutIdle			120
TimeoutNoTransfer		120
TimeoutStalled			300

# Set the user and group that the server normally runs at.
User				nobody
Group				nogroup

# This next option is required for NIS or NIS+ to work properly:
#PersistentPasswd off

SystemLog			/var/log/proftpd.log
TransferLog			/var/log/xferlog

MaxLoginAttempts        	3

# Normally, we want files to be overwriteable.
<Directory /*>
  AllowOverwrite		on
</Directory>

# A basic anonymous FTP server configuration.
# To enable this, remove the user ftp from /etc/ftpusers.
<Anonymous ~ftp>
  RequireValidShell		off
  User				ftp
  Group				ftp
  # We want clients to be able to login with "anonymous" as well as "ftp"
  UserAlias			anonymous ftp

  # Limit the maximum number of anonymous logins
  MaxClients			10

  # We want 'welcome.msg' displayed at login, and '.message' displayed
  # in each newly chdired directory.
  DisplayLogin			welcome.msg
  DisplayFirstChdir		.message

  # Limit WRITE everywhere in the anonymous chroot
  <Limit WRITE>
    DenyAll
  </Limit>

  # An upload directory that allows storing files but not retrieving
  # or creating directories.
#  <Directory incoming/*>
#    <Limit READ>
#      DenyAll
#    </Limit>
#
#    <Limit STOR>
#      AllowAll
#    </Limit>
#  </Directory>

</Anonymous>
now the problem is that when i try to log on to this server from another pc using the console linux command to log on to this server, i notice the following:

1.the 'connected to <ip address> appears almost instantly but ihave to wait for about 10 secs till the field to input username appears - this can't be normal.
2. after typing the wassword and log on, i can not do 'ls'... it says
Quote:
root@pelagus:~# ftp 147.102.19.22 11121
Connected to 147.102.19.22. //after this i wait for approx 10 secs

220 ProFTPD 1.3.0a Server (ProFTPD Default Installation) [::ffff:147.102.19.22]
Name (147.102.19.22:nass): nass
331 Password required for nass.
Password:
230 User nass logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls -l
500 Illegal PORT command
ftp: bind: Address already in use
ftp>
any ideas?
thank you for your help
nass

Last edited by nass; 04-18-2007 at 07:31 AM.
 
Old 04-18-2007, 07:55 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,898

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Use passive mode. Read this to see how you can enable passive in proftpd.conf

Regards
 
Old 04-18-2007, 08:13 AM   #3
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Original Poster
Rep: Reputation: 36
nope... that didn't do the trick..
besides i already had the firewall down... so i shouldnt need masquearading... still i tried it though... same problem..
whats killing me is that from firefox... on the same pc that the console can not log on to this server... it (the firefox) CAN!!!
is that crazy or what?
nass

te server has a static public ip.. and i have checked that its firewall is down. i have set its port to 11121.
the client is behind a home network... but i don't think i need to fwd any ports from the router there to the pc.. since the client initiates that connection... right? if im wrong which ports should i fwd...11121 or the high passive port range 62000-64000?

Last edited by nass; 04-18-2007 at 08:19 AM.
 
Old 04-18-2007, 09:05 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,898

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Since you can connect from the same box using firefox then your server most likely uses passive mode. You can test it by running
Code:
passive
immediately after login and then run
Code:
ls -l
to see if you can list the ftp contents
 
Old 04-18-2007, 09:10 AM   #5
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Original Poster
Rep: Reputation: 36
actually i am a step closer to identifying where the fault originates from

i run ftp -d to get debug output from the ftp client
and it seems the client returns a PORT(192.168.0.5,<smth>,<smth>) command.
this is the internal (in the home network) ip address of the linux pc with the ftp client... but y would this address be broadcast to the server? it doesn't make sense...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Make not working correctly barleykorn Linux - Newbie 3 11-17-2006 01:52 PM
ACPI not working correctly? intox Slackware 4 01-23-2006 01:49 PM
still trying to get kernel 2.6.9 working correctly nebukazar Slackware 5 11-10-2004 03:18 PM
pacman not working correctly! Aman9090 Arch 2 03-26-2004 05:32 AM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 06:56 PM


All times are GMT -5. The time now is 10:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration