LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-22-2005, 09:13 PM   #1
jiawj
Member
 
Registered: Jul 2004
Location: Beijing, China
Distribution: Slackware,Redhat
Posts: 121

Rep: Reputation: 15
Angry proftpd connecting too slow


Hello, everyone

I build ftp service via proftpd,and it worked.
but ...

I connect the ftp server, displayed

Quote:
Control connection successfully established.
then I had to wait too long for logon the server

I think the reason that so slow is ftp server reverse my IP to my hostname,
then I put the line append /etc/hosts

Quote:
192.168.123.234 darkstar
but can't get rid of the trouble.

who can tell me how to forbid the dns reverse for proftpd, thanks.
 
Old 02-22-2005, 09:44 PM   #2
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Well, proftpd config file is at
Code:
/etc/proftpd.conf
But I don't see any reverse lookup there. I have the same problem with 2 different Slackware machine. Anyhow, I do not use ftp anymore. Just sftp
 
Old 02-22-2005, 10:50 PM   #3
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 916

Rep: Reputation: 87
This probably isn't the issue here, but just in case...

When I compiled my 2.6.10 kernel, I marked 2 experimental options about my ethernet card driver (tulip). Later I forgot about that and until I remembered it, I was wondering why it was taking so long (~30 secs) to get a login prompt in ssh, ftp etc.. My http download speeds were not affected but ssh, sftp were extremely "laggy".
 
Old 02-22-2005, 11:57 PM   #4
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
No, that wasn't the issue with me at all. Lag only happens with ftp and ftp alone. ssh, sftp, http all other network related stuff is normal.
 
Old 02-23-2005, 01:04 AM   #5
jp_
LQ Newbie
 
Registered: Feb 2005
Location: East Coast, USA
Distribution: Slackware
Posts: 27

Rep: Reputation: 15
proftpd is nice... but vsftpd is WOW!

The delay after logging in could be helped with passive ftp. At least that sounds like what your problem is.
 
Old 02-23-2005, 03:43 AM   #6
jiawj
Member
 
Registered: Jul 2004
Location: Beijing, China
Distribution: Slackware,Redhat
Posts: 121

Original Poster
Rep: Reputation: 15
following lines come from proftpd faq:
Quote:
6. "Fatal: unable to determine IP address of "hostname:
The hosting machine has a poorly configured hostname setup to the point where the resolver library cannot determine the IP from the name. Solutions include, fixing the DNS for the domain, fixing the hostname, fixing the /etc/hosts file. Which one works for you will largely depend on your OS and exactly what is wrong.
so , I think the problem that ftp logon slow concerned IP and HOSTNAME reverse lookup
 
Old 02-24-2005, 11:23 AM   #7
jawkins
LQ Newbie
 
Registered: Jan 2005
Location: London
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
Re: proftpd connecting too slow

Quote:
Originally posted by jiawj
who can tell me how to forbid the dns reverse for proftpd, thanks.
UseReverseDNS off

Jim
 
Old 02-24-2005, 09:34 PM   #8
jiawj
Member
 
Registered: Jul 2004
Location: Beijing, China
Distribution: Slackware,Redhat
Posts: 121

Original Poster
Rep: Reputation: 15
Quote:
13. Slow logins

This is probably caused by a firewall or DNS timeout. By default ProFTPD will try to do both DNS and ident lookups against the incoming connection. If these are blocked or excessively delayed a slower than normal login will result. To turn off DNS and ident use:

UseReverseDNS off
IdentLookups off
I find above message from faq

thanks very much
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd very slow...plz help! granny Linux - Networking 22 02-02-2008 03:18 AM
Connecting to local ProFTPD takes a long time Dee-ehn Linux - Networking 3 12-07-2004 12:58 AM
Connecting to Proftpd albino87 Linux - Networking 3 12-03-2004 12:19 PM
windows connecting to proftpd dot_txt Linux - Networking 4 09-03-2004 12:10 PM
proftpd slow connection aracna Linux - Software 1 01-14-2004 07:38 AM


All times are GMT -5. The time now is 10:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration