LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-04-2005, 07:38 AM   #1
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Rep: Reputation: 30
ProFTP login


hi there,

i'm looking into using G4U and i'm starting to get everything ready and i need a FTP server going, i'm useing slackware 10.0 and the default install of ProFTP. i've got it all starting but now i can't seam to log into it, i'm not sure if i need to define a folder to store files in or not and if i need to setup a password and username for this folder, can someone help me out? with a how-to guide or just some basic intruction.
 
Old 05-04-2005, 07:51 AM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
This site has some good and easy to understand hot-to's.

http://www.linuxquestions.org/questi...ticle&artid=17
 
Old 05-04-2005, 08:19 AM   #3
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
i think this guy in the forum came up with the soluction to my problem but he didn't explain how he fixed it.

http://forums.proftpd.org/phpBB2/viewtopic.php?t=260&

he said, 'Again you had right....O....I forget to give rights user (proftpd) wich connect to database.....Sorrry again !!!'

how do i give the user rights to access the database?
 
Old 05-04-2005, 08:41 AM   #4
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
I know this isn't necessarily an answer to your question, but have you looked at VSFTPd? I've used both on production servers, and VSFTPd is *much* faster, and easier to setup / use.

http://vsftpd.beasts.org/
 
Old 05-04-2005, 09:01 AM   #5
datadriven
Member
 
Registered: Jun 2003
Location: Holly Hill, Florida
Distribution: Slackware 10.1
Posts: 317

Rep: Reputation: 30
Vsftp is installed in slack by default. Just comment that line out of /etc/inetd.com instead of proftp. There's no need to download and build it.
 
Old 05-04-2005, 09:44 AM   #6
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
hi there i'm a bit of a webmin fan, does Vsftp have a webmin module?
 
Old 05-04-2005, 10:03 AM   #7
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
I'm sure there is, vsftpd is very widely used. Even if it doesn't configuration of it is extremely simple.
 
Old 05-04-2005, 10:34 AM   #8
davidsrsb
Member
 
Registered: Oct 2003
Location: Kuala Lumpur, Malaysia
Distribution: Slackware 13.37 current
Posts: 770

Rep: Reputation: 33
I have proftp running on 10 and 10.1
I have a user ftp under home for anon login and other user directories for named login. Follow the instructions in the proftpd.conf to enable anon login and modify it if you want a chroot jail for named logins
 
Old 05-04-2005, 11:06 PM   #9
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
okay there, i've taken some advice here and go the vsftpd webmin module, edited the /etc/inietd.conf file and i now have vsftpd started and running, now my problem is when trying to access it via my XP box using IE ftp://192.168.0.20 it seams to automaticallu log me in? i was looking for maybe a username/password box?

alos when i log in via the command line with ftp localhost i can log in as root, but nothing esle

root@LearnS:/# ftp localhost
Connected to localhost.
220 Welcome to blah FTP service.
Name (localhost:root): root
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

where as when i try my pma user,

root@LearnS:/# ftp localhost
Connected to localhost.
220 Welcome to blah FTP service.
Name (localhost:root): pma
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.
ftp>
can someone help me out
 
Old 05-04-2005, 11:25 PM   #10
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
Sounds like you have anonymous enabled, and no authentication.
Here is my vsftpd.conf; it only allows users with a valid account on the server to login.

Code:
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=077
anon_upload_enable=NO
anon_mkdir_write_enable=NO
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
idle_session_timeout=600
data_connection_timeout=120
nopriv_user=ftp
async_abor_enable=YES
ftpd_banner=Slackbox FTP

ssl_enable=YES
rsa_cert_file=/root/certs/vsftpd.pem
ssl_sslv3=YES
ssl_sslv2=YES
ssl_tlsv1=YES
force_local_logins_ssl=YES
force_local_data_ssl=YES
log_ftp_protocol=YES

pasv_max_port=2002
pasv_min_port=2000
You can safely ignore the ssl part and below if you don't want to use encryption.
 
Old 05-05-2005, 12:30 AM   #11
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
here are the exacute commands i did.

1)
root@LearnS:/# locate vsftpd.conf
/etc/vsftpd.conf
/etc/vsftpd.conf.webmin.bak
/usr/doc/vsftpd-2.0.1/EXAMPLE/INTERNET_SITE_NOINETD/vsftpd.conf
/usr/doc/vsftpd-2.0.1/EXAMPLE/VIRTUAL_USERS/vsftpd.conf
/usr/doc/vsftpd-2.0.1/EXAMPLE/INTERNET_SITE/vsftpd.conf
/usr/man/man5/vsftpd.conf.5.gz

2)
root@LearnS:/# rm /etc/vsftpd.conf

3)
root@LearnS:/# pico /etc/vsftpd.conf

4) (place this information into the file)

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=077
anon_upload_enable=NO
anon_mkdir_write_enable=NO
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
idle_session_timeout=600
data_connection_timeout=120
nopriv_user=ftp
async_abor_enable=YES
ftpd_banner=Slackbox FTP

5)

log into webmin and restarted the server

6)
visited ftp://192.168.0.20/ and still i automaticlly seams to log into root
 
Old 05-05-2005, 07:21 AM   #12
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
How are you accessing the FTP? Web browser? FTP client? Are you connecting as anonymous?
 
Old 05-05-2005, 09:06 AM   #13
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
1) How are you accessing the FTP?
i'm trying on several different processes using 'bash' and a web browser

2) Web browser?
internet exproler & firefox

3) FTP client?
nope ...

4) Are you connecting as anonymous?
no, i'm trying to access it by loging in using a local users.
 
Old 05-05-2005, 09:08 AM   #14
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
here is what it looks like when i log in as root using the bash command line

root@LearnS:/# ftp localhost
Connected to localhost.
220 Slackbox FTP
Name (localhost:root): root
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

here is what it looks like when i log in as a user using the bash command line.

root@LearnS:/# ftp localhost
Connected to localhost.
220 Slackbox FTP
Name (localhost:root): matthewsp
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.
ftp>

is there some way that i can choose users with FTP access or enable certain local users or something simple like that i'm missing.

as far as i understand all i need to do is add a new users with the 'adduser' command?
 
Old 05-05-2005, 10:45 AM   #15
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
Are you using the vsftpd included with Slackware or did you compile your own? (I've never used the efault one, though I would assume Pat didn't mess with it)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftp, Users not able to login....no matter what! Pizentios Linux - Software 2 11-12-2004 12:15 PM
Allow ProFTP login but prevent local login? sorrodos Linux - Networking 2 06-23-2004 02:56 PM
ProFTP login issue. fireman949 Linux - Software 0 02-17-2004 08:53 PM
ProFTP Login Error johnrudnick Linux - Networking 1 12-16-2002 05:49 PM
ProFTP login problems Syncrm Linux - General 1 05-17-2002 02:35 PM


All times are GMT -5. The time now is 09:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration