LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-06-2010, 02:22 PM   #1
Erik_FL
Member
 
Registered: Sep 2005
Location: Boynton Beach, FL
Distribution: Slackware
Posts: 797

Rep: Reputation: 247Reputation: 247Reputation: 247
Problems with Slackware 13.1 KDE Desktop Effects on ATI Radeon HD 4850


I'm having a lot of problems with Slackware 13.1 32-bit and the KDE desktop effects.

My graphics card is listed as follows.

02:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]

The ATI driver installed is "ati-driver-installer-10-5-x86.x86_64.run". I had to build the Slackware specific package in order to get it to install.

The driver works with XFCE4 compositing and does appear to speed up the display considerably. However, when I try to enable KDE desktop effects I get various errors, all saying that some or all of the desktop effects cannot be enabled.

I verified that I am using the same settings in "xorg.conf" that worked for Slackware version 13.0.

I am also having problems with KDE (apparently) crashing and returning me to the logon prompt.

Any suggestions will be appreciated. This seems to be an ongoing problem with Slackware and ATI drivers, since I've run into installation and reliability problems in the last three releases.

I did manage to get Slackware 13.0 working well, with only occasional crashes but it took many months of experimenting. I'd rather not go through that process again.

On a positive note, the Slackware specific build of this ATI driver installed without any patches, though the generic package would not install.
 
Old 06-06-2010, 08:09 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
If you go in and try to enable desktop effects now, what's the specific error you get?

For what it's worth, I've had issues getting the latest versions of KDE4 to enable compositing when using recent versions of fglrx on both Slackware and Ubuntu. Since opengl compositing works just fine with compiz, though, I've always considered this to a bug in KDE4 (and, typically, just stick with compiz when I want to use compositing with fglrx).

Adam
 
Old 06-07-2010, 08:58 AM   #3
Erik_FL
Member
 
Registered: Sep 2005
Location: Boynton Beach, FL
Distribution: Slackware
Posts: 797

Original Poster
Rep: Reputation: 247Reputation: 247Reputation: 247
Question

Quote:
Originally Posted by adamk75 View Post
If you go in and try to enable desktop effects now, what's the specific error you get?

For what it's worth, I've had issues getting the latest versions of KDE4 to enable compositing when using recent versions of fglrx on both Slackware and Ubuntu. Since opengl compositing works just fine with compiz, though, I've always considered this to a bug in KDE4 (and, typically, just stick with compiz when I want to use compositing with fglrx).

Adam
I seem to get different results every time that I try.

Sometimes (infrequently) everything works OK and all the desktop effects work until I either log out or reboot. After logging out or rebooting, the settings dialog indicates that compositing has been disabled. If I click the button to enable compositing, it appears to work but compositing still does not work.

If I actually un-check the box for desktop effects and then re-check the box I get an error popup saying that desktop effects could not be enabled. That is either a single pop up in the middle of the desktop or sometimes a notification at the right of the panel bar listing all the specific desktop effects that could not be enabled.

xorg.conf

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/75dpi"
	FontPath     "/usr/share/fonts/100dpi"
	FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
	Load  "extmod"
	Load  "dri2"
	Load  "dbe"
	Load  "dri"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc101"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "AccelMethod"        	# [<str>]
        #Option     "offscreensize"      	# [<str>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "ignoreconnector"    	# [<str>]
        #Option     "forcereduced"       	# [<bool>]
        #Option     "forcedpi"           	# <i>
        #Option     "useconfiguredmonitor" 	# [<bool>]
        #Option     "HPD"                	# <str>
        #Option     "NoRandr"            	# [<bool>]
        #Option     "RROutputOrder"      	# [<str>]
        #Option     "DRI"                	# [<bool>]
        #Option     "TVMode"             	# [<str>]
        #Option     "ScaleType"          	# [<str>]
        #Option     "UseAtomBIOS"        	# [<bool>]
        #Option     "AtomBIOS"           	# [<str>]
        #Option     "UnverifiedFeatures" 	# [<bool>]
        #Option     "Audio"              	# [<bool>]
        #Option     "HDMI"               	# [<str>]
        #Option     "COHERENT"           	# [<str>]
	Identifier  "Card0"
	Driver      "radeonhd"
	VendorName  "Unknown Vendor"
	BoardName   "Unknown Board"
	BusID       "PCI:2:0:0"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:2:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
I noticed that my device is listed twice in "xorg.conf". That is the same as the working "xorg.conf" from 13.0. However, one thing that I want to try is removing the "radeonhd" device definition. I'm wondering if two drivers are being initialized for the same device. If I understand correctly, the "fglrx" driver is the proprietary ATI driver and the "radeonhd" is the generic driver included as part of X-Windows. I will post the results after I test with the extra device definition removed.
 
Old 06-07-2010, 10:27 AM   #4
Gavin Harper
Member
 
Registered: Feb 2010
Location: Finland
Distribution: Slackware
Posts: 169

Rep: Reputation: 24
I have the HD3200 and all effects work right off the bat.

Try without the ATI driver first.
 
Old 06-07-2010, 10:59 AM   #5
doomey
LQ Newbie
 
Registered: Nov 2009
Location: on orbit around the sun and around the center of the galaxy
Distribution: slackware64
Posts: 24

Rep: Reputation: 2
did you do
Code:
 aticonfig --initial
after installing the driver and then reboot? it seems you have an xorg.conf configured for the ati/radeon/radeonhd drivers, not for fglrx. fglrx creates its own xorg.conf file which needs no additions for the 3D acceleration to work correctly.
 
Old 06-07-2010, 11:04 AM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
His xorg.conf file is fine. In the ServerLayout section he's using the aticonfig-Screen[0]-0 Screen which, in turn, uses the aticonfig-Device[0]-0 which is using the fglrx driver. There is nothing wrong with having other Device sections, as long as they aren't being used by the ServerLayout section.

Having said all that, if the OP's primary goal is to use KDE desktop effects, I would recommend the open source 'radeon' driver over fglrx.

Adam
 
Old 06-07-2010, 01:54 PM   #7
Erik_FL
Member
 
Registered: Sep 2005
Location: Boynton Beach, FL
Distribution: Slackware
Posts: 797

Original Poster
Rep: Reputation: 247Reputation: 247Reputation: 247
I'll give the open source driver another look. It has apparently improved a lot since I last tried it.

More important to me even than the desktop effects is to make VirtualBox work with 3D graphics to run Windows guest operating systems. The VirtualBox software has not reached that point yet, though 2D graphics does now mostly work with KDE on the host Linux OS. I do development on a Windows XP guest OS running on a Vista host OS. I would like Linux as an alternative host OS.
 
Old 06-07-2010, 11:05 PM   #8
Erik_FL
Member
 
Registered: Sep 2005
Location: Boynton Beach, FL
Distribution: Slackware
Posts: 797

Original Poster
Rep: Reputation: 247Reputation: 247Reputation: 247
I was able to work around the problem by changing a setting.

In the Desktop Effects System Settings, Advanced tab I checkmarked the box for "Disable functionality checks". So far that seems to have solved the problem.
 
Old 06-11-2010, 11:30 AM   #9
erickFis
Member
 
Registered: Jun 2003
Location: Brasil
Distribution: Slackware 13.1_64 Gold Edition
Posts: 205

Rep: Reputation: 32
Cool

Quote:
Originally Posted by Erik_FL View Post
I was able to work around the problem by changing a setting.

In the Desktop Effects System Settings, Advanced tab I checkmarked the box for "Disable functionality checks". So far that seems to have solved the problem.
Thank you for sharing this Erik!

"Disable functionality checks" worked for me too!

compose effects again yay!
 
Old 11-15-2010, 08:20 PM   #10
Erik_FL
Member
 
Registered: Sep 2005
Location: Boynton Beach, FL
Distribution: Slackware
Posts: 797

Original Poster
Rep: Reputation: 247Reputation: 247Reputation: 247
As of today I was able to get desktop effects to work after updating to "current".

Please refer to this for solving problems with a missing "liblzma.so.o".
http://www.linuxquestions.org/questi...ml#post4159771

I also could only get my desktop effects to work from root. I copied my "kwinrc" from root to my user's directory and then desktop effects worked. I'm not sure exactly what was wrong in "kwinrc" for my normal user account.

Last edited by Erik_FL; 11-16-2010 at 10:21 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] refresh rate too high on debian lenny w/ kde 3.5 on ati radeon hd 4850 mf93 Linux - Software 5 02-07-2010 03:04 PM
Dell Studio 1555 + ATI Radeon 4570 + openSUSE 11.1 64-bit + Compiz Desktop Effects mahantya Linux - Laptop and Netbook 0 10-21-2009 07:26 PM
Problem with Desktop Effects (KDE 4.3) | Deiban/Gentoo | ATI Radeon HD 3870 benji906 Linux - Newbie 4 08-26-2009 12:34 PM
LXer: ATI Radeon HD 4850 512MB LXer Syndicated Linux News 0 06-27-2008 01:40 AM
Desktop effects could not be enabled - ATi Radeon Xpress 1100 - Compiz ithinkthereforeiam Linux - Newbie 13 04-26-2008 09:52 PM


All times are GMT -5. The time now is 02:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration