LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-12-2005, 07:32 AM   #1
Andruha
LQ Newbie
 
Registered: Sep 2004
Location: Odessa, Ukraine
Distribution: WindowsXP, Windows2003, Slackware 10
Posts: 18

Rep: Reputation: 0
Problems with quotes and double quotes


I'm using Slackware 10.0 with KDE 3.2.3 on a Compaq Presario 17XL360 notebook. The problem is that it is impossible to use quote (') and dblquote (") characters while typing in any kind of application in KDE, including terminal window. So when I type, in Kate for instance,

printf("hello\n");

all I get

printf(hello\n);

While working in textmode (w/o KDE) quotes and dblquotes may be typed in without any problems.

I still have the possibility to type "-character in Kate if it is followed by space.

In Kdevelop, CForge and any other KDE application that I try, there is no other way to get it typed except for putting it by copy/paste.
Unpredictable behavior!

Backgound:

in my xorg.conf's keyboard setup:

XkbRules = xorg
XkbModel = pc104
XkbLayout = ru
XkbVariant = ru_RU.KOI8-R

When I type in russian and press the button with (") I get russian letter as it should be.

May someone tell me what am I doing wrong, please?
 
Old 02-12-2005, 12:20 PM   #2
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
I had the same problem when I added my Russian layout. The problem was in US layout. I just set it as EN_iso9995-3 and all works just fine. Look: "''"''''""""''
 
1 members found this post helpful.
Old 02-15-2005, 06:24 AM   #3
Andruha
LQ Newbie
 
Registered: Sep 2004
Location: Odessa, Ukraine
Distribution: WindowsXP, Windows2003, Slackware 10
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks a lot!
Being both russian speaking people and talking here in english about how to write in english layout has an original effect on me :-)
 
Old 02-15-2005, 07:23 AM   #4
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Rep: Reputation: 31
Many native english-speakers have in recent years begin to mis-use the ' character, so not surprising that you called it a quote.

' is an apostrophe.
" is a quote mark.
 
Old 02-15-2005, 10:44 AM   #5
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
WilliamS, thanks. My English became a bit clearer
 
Old 01-02-2010, 05:36 PM   #6
Flatty
LQ Newbie
 
Registered: Jan 2010
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by Andruha View Post
I'm using Slackware 10.0 with KDE 3.2.3 on a Compaq Presario 17XL360 notebook. The problem is that it is impossible to use quote (') and dblquote (") characters while typing in any kind of application in KDE, including terminal window. So when I type, in Kate for instance,

printf("hello\n");

all I get

printf(hello\n);

While working in textmode (w/o KDE) quotes and dblquotes may be typed in without any problems.

I still have the possibility to type "-character in Kate if it is followed by space.

In Kdevelop, CForge and any other KDE application that I try, there is no other way to get it typed except for putting it by copy/paste.
Unpredictable behavior!

Backgound:

in my xorg.conf's keyboard setup:

XkbRules = xorg
XkbModel = pc104
XkbLayout = ru
XkbVariant = ru_RU.KOI8-R

When I type in russian and press the button with (") I get russian letter as it should be.

May someone tell me what am I doing wrong, please?
Andruha, I don't know the first thing about computers or Linux, but I noitced your name. Is this your first or last name? The reason I ask, is my family is originally from Odessa, and I share the same alst name as you. I am curious if we are somehow related (or if this is a common name out there). CAn you send me an email at dimitri.andruha@gmail.com so that we can continue this conversation there?

Thank you
Dima
 
Old 01-02-2010, 05:44 PM   #7
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Quote:
Originally Posted by Flatty View Post
The reason I ask, is my family is originally from Odessa, and I share the same alst name as you.
Do you come from a family of gravediggers?

PS. If Andruha has the same email today as he did in 2005 you could email him through LinuxQuestions: http://www.linuxquestions.org/questi...ember&u=141178

Last edited by sahko; 01-02-2010 at 05:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using single quotes vs double quotes in PHP strings vharishankar Programming 6 07-11-2005 12:41 PM
In BASH shell, what is the difference in usage between single and double quotes? davidas Linux - Newbie 2 04-05-2004 04:00 AM
US Intl Keybd; Double quotes not showing in some apps Heinz Linux - General 6 01-10-2004 04:48 PM
Quotes qcoder LQ Suggestions & Feedback 2 10-16-2003 11:09 PM
Quotes Rhayader LQ Suggestions & Feedback 3 04-22-2002 11:30 AM


All times are GMT -5. The time now is 10:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration