LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-19-2003, 09:43 AM   #1
LinuxOG
LQ Newbie
 
Registered: Aug 2003
Posts: 22

Rep: Reputation: 15
Exclamation problems with nvidia installer!!


Hi,

i want to install the nvidia driver ( version 1.0-4496).
but the installer say me that i have a wrong kernel or so....
Then the installer want to download the right kernel .
5 seconds later warnings and he say me that he canīt install the driver!!!

"installation abortet"


What need or can i do ???
thx for reply...

LinuxOG



my second system: P3 800MHz 265 RAM 10 GIG AND
SLACKWARE 9
 
Old 08-19-2003, 10:14 AM   #2
infurn
LQ Newbie
 
Registered: Aug 2003
Location: Ontario, Canada
Distribution: Slackware 9.0-current
Posts: 24

Rep: Reputation: 15
I got mine working by building the driver:

1) Select NO when asked if you want to download a driver for your kernel

2) then it will ask you if you want to build a new one, say YES and it should work
 
Old 08-19-2003, 11:35 AM   #3
LinuxOG
LQ Newbie
 
Registered: Aug 2003
Posts: 22

Original Poster
Rep: Reputation: 15
Hi,

the installer ask me nothing after I click "NO"
He gave me some warnings and the installation was aborted!!!


thx for help...

i thing that i need another kernel or so




LinuxOG

Last edited by LinuxOG; 08-19-2003 at 11:37 AM.
 
Old 08-19-2003, 12:48 PM   #4
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Rep: Reputation: 30
dude, try read this time sounds like you just clicked ahead
 
Old 08-19-2003, 02:53 PM   #5
duister
LQ Newbie
 
Registered: Jul 2003
Location: Belgium
Distribution: slackware 9.0
Posts: 21

Rep: Reputation: 15
Quote:
Originally posted by LinuxOG
Hi,

the installer ask me nothing after I click "NO"
He gave me some warnings and the installation was aborted!!!


thx for help...

i thing that i need another kernel or so




LinuxOG
The warnings... did they include a message about differences between the kernel headers and the kernel?
 
Old 08-21-2003, 07:05 AM   #6
LinuxOG
LQ Newbie
 
Registered: Aug 2003
Posts: 22

Original Poster
Rep: Reputation: 15
yes!!

LinuxOG
 
Old 08-21-2003, 07:35 AM   #7
duister
LQ Newbie
 
Registered: Jul 2003
Location: Belgium
Distribution: slackware 9.0
Posts: 21

Rep: Reputation: 15
Quote:
Originally posted by LinuxOG
yes!!

LinuxOG
then you have to recompile your kernel. This may sound difficult, when you're new to linux. just read the instructions in the slackware forum. compile kernel for newbies.

i had the same problem. i recompiled my kernel, and then it all went in a jiffy.

If you don't wanna recompile your kernel.. or you can't figure out howto do it, then reinstall slackware.. and don't change anything in the kernel source. or settings. and install the nvidia drivers. that should work as well.

good luck

Last edited by duister; 08-21-2003 at 07:38 AM.
 
Old 08-21-2003, 07:39 AM   #8
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
sorry,i cant help you.but http://www.nvnews.net/vbulletin/foru...?s=&forumid=14 is a really good forum for these things.(atleast,it helped to solve my nvidia problem)
 
Old 08-21-2003, 04:52 PM   #9
Minderbinder
Member
 
Registered: Aug 2003
Location: Boston, MA
Distribution: Slackware-current
Posts: 142

Rep: Reputation: 15
Try "sh ./NVIDIA-Linux-x86-1.0-4496-pkg2.run--kernel-include-path=/usr/include"
 
Old 08-22-2003, 05:35 PM   #10
mastereq
LQ Newbie
 
Registered: Aug 2003
Location: Poland
Distribution: Slackware
Posts: 8

Rep: Reputation: 0
right but

Right but Minderbinder don't say that then you must go to /etc/X11/XF86Config and change driver name from "nv" to "nvidia"

Re5pect
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia installer fails Slinky Mandriva 1 03-12-2005 06:24 PM
problems with nvidia installer on Mandrake 10.1 RedRedKrovy Mandriva 23 01-03-2005 08:53 PM
nvidia installer fails to create nvidia module rooman Linux - Software 3 10-04-2004 03:39 AM
Nvidia installer gentoo problems Joe_Bogarde Linux - Hardware 4 09-30-2003 08:54 PM
nvidia-installer problems geezy Linux - Hardware 11 07-22-2003 12:02 AM


All times are GMT -5. The time now is 07:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration