LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-03-2011, 09:40 AM   #1
splintercdo
Member
 
Registered: Feb 2011
Location: Riga, Latvia
Distribution: AVLinux 6.0
Posts: 124

Rep: Reputation: 9
Problems with auto mount


Could anyone suggest me what should I do?

The problem is:
When I attach usb device or insert CD or DVD disc, I get warning(see attachment)

with this text
Code:
Unable to mount "KAM":

Rejected send message, 1 matched rules; type="method_call", sender=":1.44" (uid=1000 pid=25577 comm="exo-mount) interface="org.freedesktop.Hal.Device.Volume" member="Mount" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=1770 comm="/usr/sbin/hald))
I can mount any device successfully as a root

So the problem must be I don't have enough rights

I added myself to cdrom group with: usermod -a -G cdrom "username"

and looked in /etc/group
There is a line: cdrom:x:19:"username"

so it seems everything should work, but it doesn't, what would be your advices?
Attached Images
File Type: png snapshot1.png (26.9 KB, 11 views)
 
Old 04-03-2011, 09:54 AM   #2
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 87
If you use:

# adduser

when adding users and follow the default option for the additional groups, you should not get permission problems.

Anyway they are the following groups:

audio cdrom floppy plugdev video power netdev

Last edited by ChrisAbela; 04-03-2011 at 09:55 AM.
 
Old 04-03-2011, 11:38 AM   #3
splintercdo
Member
 
Registered: Feb 2011
Location: Riga, Latvia
Distribution: AVLinux 6.0
Posts: 124

Original Poster
Rep: Reputation: 9
yep, actually I did things correctly

I just tested groups with $ id

that is way I didn't saw other groups like plugdev, power etc.

I added user to all groups you wrote and now disk mounts corrctly

P.S.
And now when I knew what I was doing, I also solved issue with disc recording software by adding user to disk group
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto mount USB drive to specified mount point after reboot smallbook Linux - Server 7 07-21-2010 04:40 AM
Problems with auto mount external hdd-drives. LuxLuv Linux - Server 4 03-18-2010 03:46 AM
Auto-mount windows share on boot - manual OK, auto not ok! erskie Linux - Newbie 2 02-12-2008 06:42 PM
DVD (auto)mount problem, gnome-mount, hal, Fedora C 5 lazarion Linux - Hardware 5 01-10-2007 04:45 AM
autofs enabled in kernel but auto.mount and auto.master are NOT in /etc! Alybyzrp Linux - General 0 11-11-2003 12:26 PM


All times are GMT -5. The time now is 02:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration