LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problems with auto mount (http://www.linuxquestions.org/questions/slackware-14/problems-with-auto-mount-872700/)

splintercdo 04-03-2011 09:40 AM

Problems with auto mount
 
1 Attachment(s)
Could anyone suggest me what should I do?

The problem is:
When I attach usb device or insert CD or DVD disc, I get warning(see attachment)

with this text
Code:

Unable to mount "KAM":

Rejected send message, 1 matched rules; type="method_call", sender=":1.44" (uid=1000 pid=25577 comm="exo-mount) interface="org.freedesktop.Hal.Device.Volume" member="Mount" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=1770 comm="/usr/sbin/hald))

I can mount any device successfully as a root

So the problem must be I don't have enough rights

I added myself to cdrom group with: usermod -a -G cdrom "username"

and looked in /etc/group
There is a line: cdrom:x:19:"username"

so it seems everything should work, but it doesn't, what would be your advices?

ChrisAbela 04-03-2011 09:54 AM

If you use:

# adduser

when adding users and follow the default option for the additional groups, you should not get permission problems.

Anyway they are the following groups:

audio cdrom floppy plugdev video power netdev

splintercdo 04-03-2011 11:38 AM

yep, actually I did things correctly

I just tested groups with $ id

that is way I didn't saw other groups like plugdev, power etc.

I added user to all groups you wrote and now disk mounts corrctly ;)

P.S.
And now when I knew what I was doing, I also solved issue with disc recording software by adding user to disk group


All times are GMT -5. The time now is 09:07 PM.