LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-21-2014, 05:24 PM   #1
qzxcvbnm
LQ Newbie
 
Registered: Jul 2014
Distribution: Slackware
Posts: 5

Rep: Reputation: Disabled
Problems with audio recording in Audacity 2.0.5. Slackware64 14.1; Intel HD Audio.


I'm trying to record audio using Audacity 2.0.5 installed from SlackBuilds. My system is 64-bit Slackware 14.1 and a sound card is Intel HD Audio. I didn't change my sound system to OSS. (Default sound system in Slackware 14.1 is ALSA, isn't it?) First, I set Internal Microphone slider in KMix to the maximum level. It is strange, that everything, I've been saying into the microphone was immediately played. Then I opened Audacity and started recording. Audacity didn't record anything.

Help me solve this problem! Thanks in advance!

// Sorry for my broken English. Could you tell me, please, where are mistakes?
 
Old 07-21-2014, 05:29 PM   #2
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware [64]X{.0|.1|.2|-current} ::X>=12<=14, FreeBSD_10{.0|.1}
Posts: 2,159

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by qzxcvbnm View Post
I'm trying to record audio using Audacity 2.0.5 installed from SlackBuilds. My system is 64-bit Slackware 14.1 and a sound card is Intel HD Audio. I didn't change my sound system to OSS. (Default sound system in Slackware 14.1 is ALSA, isn't it?) First, I set Internal Microphone slider in KMix to the maximum level. It is strange, that everything, I've been saying into the microphone was immediately played. Then I opened Audacity and started recording. Audacity didn't record anything.

Help me solve this problem! Thanks in advance!

// Sorry for my broken English. Could you tell me, please, where are mistakes?
Welcome to LQ!

In Audacity you must Edit >> Preferences >> ... select the recording device (Mic).
 
Old 07-21-2014, 05:36 PM   #3
qzxcvbnm
LQ Newbie
 
Registered: Jul 2014
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by astrogeek View Post
Welcome to LQ!

In Audacity you must Edit >> Preferences >> ... select the recording device (Mic).
Thank you for your reply! I have three options for "Recording": "default", "sysdefault" and "HDA Intel PCH: ALC269VB Analog (hw:0,0)". I selected third option. But there's still no recording. Then I tried first and second option and there's also no recording. All that I'm saying into the microphone is immediately played (even without running programs).
 
Old 07-21-2014, 06:10 PM   #4
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 88

Rep: Reputation: 37
Dumb question: in alsamixer, is the line in unmuted?
 
Old 07-22-2014, 04:36 AM   #5
qzxcvbnm
LQ Newbie
 
Registered: Jul 2014
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by garpu View Post
Dumb question: in alsamixer, is the line in unmuted?
I don't have such option at all:
Attached Images
File Type: png kdedesktop2.png (63.0 KB, 20 views)
 
Old 07-23-2014, 11:57 AM   #6
qzxcvbnm
LQ Newbie
 
Registered: Jul 2014
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
And one more thing - in Ubuntu 14.04 there wasn't such thing.
 
Old 07-23-2014, 12:40 PM   #7
qzxcvbnm
LQ Newbie
 
Registered: Jul 2014
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
Exclamation

If somebody needs a working solution: add "Capture" channel in KMix and set it's level to the maximum.
Thanks to http://www.unix.com/slackware/249453...-hd-audio.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio problems - can't hear it but Audacity can record it genogebot Linux - Newbie 12 07-21-2010 05:44 PM
LXer: Audacity - Audio editing & recording in openSUSE LXer Syndicated Linux News 0 02-11-2009 03:51 AM
LXer: Audacity Tutorial part 1 -- Recording audio tracks LXer Syndicated Linux News 0 05-12-2008 07:30 AM
recording problems on nforce2 audio using alsa... hollywoodb Linux - Hardware 1 12-02-2003 01:03 PM
WinTV audio recording problems bluemoose Linux - Hardware 2 10-30-2003 07:25 AM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration