LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-31-2006, 01:39 AM   #1
OC_eobard
Member
 
Registered: May 2004
Distribution: Slackware 10.2, Ubuntu 6.10
Posts: 94

Rep: Reputation: 15
problems using USB headphones/mic in Slack


I put a USB headset/mic combo on my system today. Prior to this I was using the soundcard built into my mobo. Windows handled everything fine and I have some success in Slackware (10.2) so I know I don't have a bad headset or other hardware failure. But I'm stuck trying to configure Slackware to default to the USB audio across the board. I configured XMMS with "options -> preferences -> audio output ALSA -> configure -> audio device -> HW:1,0" (the default was HW:0,0 for the previous onboard sound).

"cat /proc/asound/modules" gives me an output of:
"0 snd-intel8x0
1 snd-usb-audio"

I can't figure out how to get the sound to work for any of the other multimedia applications. Noatun, xine, etc. So..... what do I do to globally configure slackware to default to the USB setup?
 
Old 08-31-2006, 07:16 PM   #2
OC_eobard
Member
 
Registered: May 2004
Distribution: Slackware 10.2, Ubuntu 6.10
Posts: 94

Original Poster
Rep: Reputation: 15
18 reads and no replys? Somebody's gotta have a bump that'll nudge me in the right direction...
 
Old 09-05-2006, 05:34 PM   #3
patrickdepingui
Member
 
Registered: Mar 2003
Distribution: Slackware
Posts: 53

Rep: Reputation: 15
I think you should look into the alsa configuration in the ~/.asoundrc file. There you can specify the default devices...
 
Old 09-05-2006, 05:45 PM   #4
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Quote:
Originally Posted by OC_eobard
18 reads and no replys? Somebody's gotta have a bump that'll nudge me in the right direction...
Well, I believe that no everyone owns an USB headset. I wouldn't buy it anyway, I know those for only give trouble (in any OS).
 
Old 09-05-2006, 07:04 PM   #5
OC_eobard
Member
 
Registered: May 2004
Distribution: Slackware 10.2, Ubuntu 6.10
Posts: 94

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by patrickdepingui
I think you should look into the alsa configuration in the ~/.asoundrc file. There you can specify the default devices...
Thanks for the response but according to Konqueror I have no "asoundrc" file.
 
Old 09-05-2006, 07:15 PM   #6
crisostomo_enrico
Member
 
Registered: Dec 2005
Location: Madrid
Distribution: Solaris 10, Solaris Express Community Edition
Posts: 547

Rep: Reputation: 35
konqueror default behaviour is NOT showing you "hidden" files, i.e. files whose name starts with ".". you can for example
- use a terminal and ls -a
- type ~/. in konqueror address bar, it'll show you hidden files in a drop down list
 
Old 09-05-2006, 07:17 PM   #7
crisostomo_enrico
Member
 
Registered: Dec 2005
Location: Madrid
Distribution: Solaris 10, Solaris Express Community Edition
Posts: 547

Rep: Reputation: 35
BTW, I do not have that file either.
 
Old 09-05-2006, 07:34 PM   #8
OC_eobard
Member
 
Registered: May 2004
Distribution: Slackware 10.2, Ubuntu 6.10
Posts: 94

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by crisostomo_enrico
konqueror default behaviour is NOT showing you "hidden" files, i.e. files whose name starts with ".". you can for example
- use a terminal and ls -a
- type ~/. in konqueror address bar, it'll show you hidden files in a drop down list
I know it doesn't show them unless you change the setting, but I thought the search would find hidden files.
 
Old 09-05-2006, 08:43 PM   #9
crisostomo_enrico
Member
 
Registered: Dec 2005
Location: Madrid
Distribution: Solaris 10, Solaris Express Community Edition
Posts: 547

Rep: Reputation: 35
Yes.

I told you that because you wrote "asoundrc" and thought you were missing the ".".

Bye.
 
Old 09-06-2006, 02:46 AM   #10
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Slackware has no .asoundrc file by default, you need to create one. You will probably want to look online for a sample file to use, since I believe they are fairly complicated (though I have never personally used one).

I too have a USB headset, and I have only ever used per-program settings like you have been doing in XMMS. I don't know for sure that the .asoundrc will allow an across the board device change, but it's probably the best shot.

You could always just disable the primary sound card to, if your goal here is to use only the USB headset.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB headphones & xmms zeratul_mdq Linux - Software 2 02-10-2006 04:22 PM
USB Headphones SentralOrigin Linux - Hardware 3 10-27-2005 02:48 AM
USB headphones / Speakers ShuttleAU Linux - Hardware 1 04-18-2005 02:48 AM
USB headphones on Linux? Azazzello Linux - Hardware 0 12-23-2004 05:35 PM
No sound to headphones - Slack 10, Santa Cruz soundcard booyabazooka Linux - Hardware 1 06-27-2004 04:10 AM


All times are GMT -5. The time now is 12:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration