LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problems using kate (http://www.linuxquestions.org/questions/slackware-14/problems-using-kate-4175455845/)

Didier Spaier 03-27-2013 07:35 PM

Problems using kate
 
I recently began using kate (under fluxbox in Slackware 14.0).

I did that because its syntax highlighter is way better than geany's for shell scripts and have some handy features, though it be slow to start and spit a lot of garbage on my xterm (thanks /dev/null to take care of that :-)

But I founded some problems using it:
(1) It has problems to deal with situations when the same file is opened more than once
(2) It happens to pretend that it has saved a file, but actually didn't. That is *very* annoying. That made me spend *hours* to (not) find bugs... that actually didn't exist.

Is it that kate hates me or (I would prefer that) a PEBKAC case? May be I don't use it properly?

frankbell 03-27-2013 10:26 PM

I've have opened files in Kate that were open in Kompozer and had the two applications work together just fine. Changes saved in Kate displayed in Kompozer and vice versa.

I just tried to load the same file in two instances of kate. It didn't like it. I opened two instances of Kate and loaded the same file. I then made and saved changes in Instance One; when Kate Instance two prompted me that the file had been changed and I clicked to reload, Instance Two closed and Instance One took focus.

I've also never had a problem saving a file, at least not one that failed to throw an error message, usually permissions.

For testing, I'd suggest starting kate from the command line and trying some things. Maybe it will show some error messages in the terminal that could shed some light on this.

Didier Spaier 03-29-2013 05:20 PM

Thanks frankbell for your answer. I'll make some more testing and will come back here if/when I have an actual evidence of a dysfunction.

frankbell 03-29-2013 09:34 PM

Good luck.

PrinceCruise 03-30-2013 09:45 AM

FWIW, I've been using Kate for C programming since some time and I never encountered both the mentioned issues, both in normal and VIM mode.

Regards.

matusz 04-11-2013 07:46 AM

Sorry for bumping but the topic title got me intrigued...


All times are GMT -5. The time now is 01:20 AM.