LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   problems on boot (brightness going to 0, wireless disabled) with Lenovo IdeaPad Y410p (http://www.linuxquestions.org/questions/slackware-14/problems-on-boot-brightness-going-to-0-wireless-disabled-with-lenovo-ideapad-y410p-4175481009/)

cgorac 10-16-2013 04:00 AM

problems on boot (brightness going to 0, wireless disabled) with Lenovo IdeaPad Y410p
 
Just got this machine, and am trying to setup Slackware on it. I've first completely disabled UEFI (and secure boot) in machine BIOS, then repartitioned the whole disk, and then installed slackware64-current using ISO from here: ftp://ftp.slackware.no/slackware/slackware-current-iso/. However, now I'm facing some problems on machine boot:

1. At some point during the boot, the screen goes blank. I can use Fn key, plus Brightness-Plus button to increase brightness, and then everything is back to normal; however, I'd like to avoid this. I think the problems appears at the moment when video drivers is switching to higher resolution during the boot (first message visible on screen after this happens is "fbcon: inteldrmfb (fb0) is primary device"); I'd like to avoid this too, and I can by adding "nomodeset" to the LILO command line (the screen doesn't go blank in this case), but is this the only way to do it? This machine has combo of Intel HD Graphics 4600 and NVIDIA GeForce GT 750M display adapters, arranged in NVIDIA Optimus setup. I will have to play later with Bumblebee in order to enable NVIDIA card, and for now I think only Intel card is seen by Linux. So my question here is: is there another way to disable switching to frame buffer on boot? And on the other side: would it be possible, when switch to frame buffer occurs, to keep brightness from going down to 0?

2. Wireless card is disabled on boot. Wireless on this laptop is Intel Centrino Wireless-N 2230. I have proper /etc/rc.d/rc.inet1.conf and /etc/wpa_supplicant.conf setup for wireless network to go up during the boot. However, when boot comes to activating wireless, first "SIOCSIFFLAGS: Operation not possible due to RF-kill" message appears, and then "rfkill: WLAN soft blocked". When boot sequence completed, and I log in into console as root, and then run "rfkill list", I have "ideaplad_wlan" and "phy0" devices listed as "Wireless LAN", and for both of them it shows "Soft blocked: Yes". If I then do "rfkill unblock all", and then "/etc/rc.d/rc.inet1 restart", WLAN is up and properly set up. However, on next boot, wireless card is again disabled by rfkill. So my question here is: how to unblock wireless card before /etc/rc.d/rc.inet1 executed during boot? Obviously, I can do this by putting "rfkill unblock all" line before /etc/rc.d/rc.inet1 called in /etc/rc.d/rc.M, but is there more "proper" way to do this?

Thanks.

Didier Spaier 10-16-2013 07:05 AM

1. Maybe you could try to blacklist the intel driver (lsmod will tell you its name), set "vga = normal". Then no handover should occur during startup, but when you start X the intel driver *should* be loaded though. Not sure that works with intel, but it does with the nouveau driver for nVidia cards.

cgorac 10-16-2013 07:27 AM

Quote:

Originally Posted by Didier Spaier (Post 5046792)
1. Maybe you could try to blacklist the intel driver (lsmod will tell you its name), set "vga = normal". Then no handover should occur during startup, but when you start X the intel driver *should* be loaded though. Not sure that works with intel, but it does with the nouveau driver for nVidia cards.

Thanks, that works exactly as you described: startx would load i915 driver, and both X and then the desktop environment would start fine.

However, in the meantime I read more about KMS, and I came to like the idea :-) So if there are any further suggestions on how to keep i915 driver loaded during boot, but manage to avoid screen going blank, that would be great.

cgorac 10-16-2013 07:45 AM

Quote:

Originally Posted by cgorac (Post 5046805)
So if there are any further suggestions on how to keep i915 driver loaded during boot, but manage to avoid screen going blank, that would be great.

I've just encountered a suggestion on another forum: to append "acpi_backlight=vendor" to the lilo command line, and that fully works - KMS done during boot, and brightness level is kept during the switch.

Now onto the rfkill issue...

cgorac 10-16-2013 07:52 AM

Quote:

Originally Posted by cgorac (Post 5046814)
I've just encountered a suggestion on another forum: to append "acpi_backlight=vendor" to the lilo command line, and that fully works - KMS done during boot, and brightness level is kept during the switch.

Oops, one more thing to add here: after adding "acpi_backlight=vendor", brightness controls on laptop (Fn key + corresponding buttons on keyboard) don't work any more under Linux.


All times are GMT -5. The time now is 03:11 PM.