LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-27-2006, 11:14 AM   #1
mcapelati
LQ Newbie
 
Registered: Dec 2005
Location: São Paulo, Brazil
Distribution: Slackware 10.2
Posts: 28

Rep: Reputation: 15
Thumbs down Problems installing & loading nVIDIA FX5500 modules


Hi there,


I was having problems with an "ATI Radeon 9600" card, trying to install and configure drivers for Linux.
Some people recommended me to try using a nVidia Card: they told me that nVIDIA drivers for Linux where more reliable...
So, yesterday I change my Radeon-9600 for a nVIDIA-FX-5500.

Got the last installer for nVIDIA website (NVIDIA-Linux-x86-1.0-8178-pkg1.run), and tried to install it.

Simple running (sh...) gave me some errors:

Quote:
ERROR: Unable to load the kernel module 'nvidia.ko'. This is most likely because the kernel module was built
using the wrong kernel source files. Please make sure you have installed the kernel source files for
your kernel and that they are properly configured; on Red Hat Linux systems, for example, be sure you
have the 'kernel-source' RPM installed. If you know the correct kernel source files are installed, you
may specify the kernel source path with the '--kernel-source-path' command line option.


My kernel is 2.6.15.1 (Slackware 10.2), and source files are all there, on right place: /lib/modules/2.6.15.1/, (because I has to install and compile this kernel manually). Even when I try to use --kernel-source-path, the same error happens.

Seems that module is beeing compiled, because ls -la /lib/modules/2.6.15.1/kernel/drivers/video shows:

Quote:
drwxr-xr-x 2 root root 80 2006-01-27 13:27 ./
drwxr-xr-x 12 root root 288 2006-01-27 03:43 ../
-rw-rw-r-- 1 root root 4641080 2006-01-27 13:27 nvidia.ko
But this modules is not loading anyway !
modprobe nvidia gives me:

Quote:
FATAL: Error inserting nvidia (/lib/modules/2.6.15.1/kernel/drivers/video/nvidia.ko): No such device
Seems to me that module couldn´t find the device...

But lspci | grep nVidia shows:

Quote:
00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:05.0 Multimedia audio controller: nVidia Corporation nForce Audio Processing Unit (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire (IEEE 1394) Controller (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
03:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)
As you can see, my MoBo has nVidia nForce chipset. It is an ASUS-AN8X-E Deluxe. But even if I try to load nvidia_agp module, this does not resolve the problem:

# modprobe nvidia_agp
# lsmod

Quote:
Module Size Used by
nvidia_agp 5724 1
agpgart 26568 1 nvidia_agp

By the way, last lines of nvidia-installer.log are:

Quote:
ACPI: PCI interrupt for device 0000:00:04.0 disabled
agpgart: Detected NVIDIA nForce2 chipset
agpgart: AGP aperture is 256M @ 0xc0000000
NVRM: The NVIDIA probe routine was not called for 1 device(s).
NVRM: This can occur when a driver such as rivafb, nvidiafb or
NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
NVRM: support), then try loading the NVIDIA kernel module again.
NVRM: No NVIDIA graphics adapter probed!
NVRM: The NVIDIA probe routine was not called for 1 device(s).
NVRM: This can occur when a driver such as rivafb, nvidiafb or
NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
NVRM: support), then try loading the NVIDIA kernel module again.
NVRM: No NVIDIA graphics adapter probed!

Last lines of dmesg shows same thing:

Quote:
NVRM: This can occur when a driver such as rivafb, nvidiafb or
NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
NVRM: support), then try loading the NVIDIA kernel module again.
NVRM: No NVIDIA graphics adapter probed!

PS: Even if i try to compile nVIDIA drivers manually, the same error happens.
PS: X is working, but with no 3D graphics accelleration at all...
 
Old 01-27-2006, 11:52 AM   #2
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Rep: Reputation: 63
Hi,
I had this problem too. This is what I did:
1) make sure you have the kernel source installed.
2) change the system level to 3 (no X): telinit 3.
3) remove the module nvidia or try to reboot and this time boot in level 3. (rmmod nvidia. check with lsmod | grep -i nvidia)
4) as root, in console, run the nvidia installer with the q switch: "./NVIDIA-Linux-x86-1.0-8178-pkg1.run -q". this time choose to re-compile the module when asked.

this worked for me, I hope this work for you too.
 
Old 01-27-2006, 08:21 PM   #3
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
well, i'd suggest you take it one step at a time... the first thing you wanna do is resolve the kernel source issue:
Quote:
Originally Posted by mcapelati
My kernel is 2.6.15.1 (Slackware 10.2), and source files are all there, on right place: /lib/modules/2.6.15.1/, (because I has to install and compile this kernel manually).
your kernel source should actually be in /usr/src/linux-2.6.15.1 and not in the /lib/modules directory... also, if the nvidia-installer uses the linux symlink for whatever reason, then make sure it's pointing to the proper directory:
Code:
cd /usr/src
ln -sf linux-2.6.15.1 linux
also, the source should be in the state it was after having done the compilation process (plus a "make clean"), don't just "tar xvjf" the tarball from kernel.org into the directory...

Quote:
ERROR: Unable to load the kernel module 'nvidia.ko'. This is most likely because the kernel module was built
using the wrong kernel source files. Please make sure you have installed the kernel source files for
your kernel and that they are properly configured; on Red Hat Linux systems, for example, be sure you
have the 'kernel-source' RPM installed. If you know the correct kernel source files are installed, you
may specify the kernel source path with the '--kernel-source-path' command line option.
and yes, you should make sure that all this nvidia stuff is being done in runlevel 3, of course...

Last edited by win32sux; 01-27-2006 at 08:26 PM.
 
Old 01-28-2006, 11:25 AM   #4
mcapelati
LQ Newbie
 
Registered: Dec 2005
Location: São Paulo, Brazil
Distribution: Slackware 10.2
Posts: 28

Original Poster
Rep: Reputation: 15
Hey Guys,

I could solve this problem just unsetting all "Frame Buffer" on kernel (and recompiling it, of course), like this:

Quote:
─── Graphics support ────
< > Support for frame buffer devices
[ ] Enable Video Mode Handling Helpers
[ ] Enable Tile Blitting Support

── Console display driver support ──

--- VGA text console [ ] Video mode selection support
< > MDA text console (dual-headed) (EXPERIMENTAL)
< > Framebuffer Console support
[ ] Framebuffer Console Rotation
After I did that, nvidia module could be loaded without problems !
And testing some OpenGL ScreenSaver was nice and really fast !!!

But... this gave me another problem: I couldnt boot using that small letters and penguin logo anymore (well, at least, I think that "Framebuffer" is used for...)
 
Old 01-28-2006, 01:40 PM   #5
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
IMHO, you shouldn't have unset framebuffer. It wasn't required. The problem with source could be if your gcc is newer than previous gcc with which you compiled previous kernel. Updated nvidia drivers week ago and had similar errors - solved by downgrading gcc.
 
Old 01-28-2006, 05:57 PM   #6
mcapelati
LQ Newbie
 
Registered: Dec 2005
Location: São Paulo, Brazil
Distribution: Slackware 10.2
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien_Hominid
IMHO, you shouldn't have unset framebuffer. It wasn't required. The problem with source could be if your gcc is newer than previous gcc with which you compiled previous kernel. Updated nvidia drivers week ago and had similar errors - solved by downgrading gcc.
I would like to agree with you brother, but this instruction was given to me by anybody on NVIDIA Support...

And, if you take a look on "nvidia-installer.log" (first post), it is written that i must reconfigure kernel without fb support !
 
Old 01-28-2006, 06:07 PM   #7
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by mcapelati
I would like to agree with you brother, but this instruction was given to me by anybody on NVIDIA Support...

And, if you take a look on "nvidia-installer.log" (first post), it is written that i must reconfigure kernel without fb support !
the thing is there was no need to recompile the kernel - you didn't need to remove framebuffer *support* from it...

to disable the framebuffer you just edit your lilo.conf, or whatever... this is what is meant by "reconfigure" the kernel - you change the configuration the kernel is loaded with...

Last edited by win32sux; 01-28-2006 at 06:13 PM.
 
Old 01-29-2006, 01:35 AM   #8
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
From my .config file:
Quote:
CONFIG_FB=y
CONFIG_FRAMEBUFFER_CONSOLE=y
lilo.conf
Quote:
vga = normal
Working perfectly, however as you said without logo and small letters.
 
Old 01-29-2006, 03:12 AM   #9
BrianW
Member
 
Registered: Jul 2003
Location: Montana
Distribution: Slackware
Posts: 245

Rep: Reputation: Disabled
Hello, I maybe had the same issue with my ATI Radeon Mobility X300 card using the fglrx drivers and the 2.6.* kernel. When I enabled the framebuffer (non-module) and then configured my card (ATI Radeon Display Support) in the framebuffer as built in instead of a module, it would cause a lockup after starting X requiring a hard restart to make my computer responsive again, only when using radeon or fglrx driver in xorg.conf instead the vesa driver. Try selecting the driver as a module (or not at all, I haven't bothered to try that yet), and then select VGA Vesa Graphics Support as built in and VGA 16 Color graphics support as a module under framebuffer. You could set them both as built in if you wanted, that should work.
Good luck.

Last edited by BrianW; 01-29-2006 at 03:13 AM.
 
Old 01-29-2006, 04:15 AM   #10
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by Alien_Hominid
From my .config file:

CONFIG_FB=y
CONFIG_FRAMEBUFFER_CONSOLE=y

lilo.conf

vga = normal

Working perfectly, however as you said without logo and small letters.
yup, ditto... a "vga = normal" in lilo.conf is all it takes to disable the framebuffer...
 
Old 01-29-2006, 10:54 AM   #11
mcapelati
LQ Newbie
 
Registered: Dec 2005
Location: São Paulo, Brazil
Distribution: Slackware 10.2
Posts: 28

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by win32sux
yup, ditto... a "vga = normal" in lilo.conf is all it takes to disable the framebuffer...
Is it all to disable "frame buffer" ? Ok, I´ll try let it compiled in Kernel, but just changing lilo.conf.

By the way: what the hell is "frame buffer" used for ? Just to show penguin logo and small letters on boot ? If yes, I think I could survive without them... But should be better the have it, specially the small letters, because theres more info on screen !

Anybody could tell me where to find any information about frame buffer and those things ? Any "HOW-TO", for example.
 
Old 01-29-2006, 11:49 AM   #12
mcapelati
LQ Newbie
 
Registered: Dec 2005
Location: São Paulo, Brazil
Distribution: Slackware 10.2
Posts: 28

Original Poster
Rep: Reputation: 15
Thumbs up Now everything works ! nVidia module + framebuffer !!!

Strange things happens on the computer world

Well, I finally recompile my kernel with framebuffer support (taking off penguin logo):

Quote:
CONFIG_FB=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
# CONFIG_FB_MACMODES is not set
CONFIG_FB_MODE_HELPERS=y
# CONFIG_FB_TILEBLITTING is not set
# CONFIG_FB_CIRRUS is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_ARC is not set
# CONFIG_FB_ASILIANT is not set
# CONFIG_FB_IMSTT is not set
CONFIG_FB_VGA16=y
CONFIG_FB_VESA=y
CONFIG_VIDEO_SELECT=y
# CONFIG_FB_HGA is not set
# CONFIG_FB_S1D13XXX is not set
# CONFIG_FB_NVIDIA is not set
# CONFIG_FB_RIVA is not set
# CONFIG_FB_I810 is not set
# CONFIG_FB_INTEL is not set
# CONFIG_FB_MATROX is not set
# CONFIG_FB_RADEON_OLD is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_SAVAGE is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_KYRO is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_CYBLA is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_GEODE is not set
# CONFIG_FB_VIRTUAL is not set

#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
# CONFIG_MDA_CONSOLE is not set
CONFIG_DUMMY_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y
# CONFIG_FRAMEBUFFER_CONSOLE_ROTATION is not set
CONFIG_FONTS=y
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y
# CONFIG_FONT_6x11 is not set
# CONFIG_FONT_7x14 is not set
# CONFIG_FONT_PEARL_8x8 is not set
# CONFIG_FONT_ACORN_8x8 is not set
# CONFIG_FONT_MINI_4x6 is not set
# CONFIG_FONT_SUN8x16 is not set
# CONFIG_FONT_SUN12x22 is not set
# CONFIG_FONT_10x18 is not set

#
# Logo configuration
#
# CONFIG_LOGO is not set
# CONFIG_BACKLIGHT_LCD_SUPPORT is not set

AND, let the lilo.conf like this:

Quote:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x32k
vga = 773
Reboot: small letters (good !), and no penguin logo (thats ok...)

Recompile and reinstall nVidia driver....and: NO PROBLEM !!!

Load created module "nvidia"....and: NO PROBLEM !!!

Enter X....and: NO PROBLEM !!! (with that nVidia splash screen)

Running OpenGL screen saver.......and: NO PROBLEM !!! (still running fast: 83.33 on Atunnel - just that Atlantis that still run slowly, at 2.10 FPS, but...OK, I really don´t like it )

Well, seems that almost evrything is nice now.

Thanks for all that help me.

Hope this post could help others on configuring their nVidia cards !
 
Old 01-29-2006, 05:13 PM   #13
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
to read about what a framebuffer is:

http://en.wikipedia.org/wiki/Framebuffer

http://en.wikipedia.org/wiki/Linux_framebuffer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TV-out on Nvidia FX5500 - CRT works fine but nothing on TV Ephracis Linux - Hardware 2 11-17-2005 02:43 PM
Nvidia fx5500 mandrake 10.1 problem:Nvidia in /etc/modprobe.preload doesn't work eikeland Linux - Hardware 5 01-17-2005 02:09 PM
nVidia geForce FX5500 OC mykrob Linux - Hardware 0 08-23-2004 02:57 PM
kernel failing loading unnessary modules && issues upgrading to kde 3.2.2 promark Slackware 2 06-09-2004 04:03 PM
Problems with loading modules in new kernel beejayzed Linux - Newbie 5 02-07-2004 03:29 PM


All times are GMT -5. The time now is 06:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration