LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-11-2004, 06:06 PM   #1
the_y_man
LQ Newbie
 
Registered: Jan 2003
Posts: 13

Rep: Reputation: 0
problems at start up, dhcp...


Anyways, i'm trying to setup a router/firewall/server out of an old P100 48MB RAM 800 Mb hard drive. (no X). I have slackware 9.1 installed and upgraded/built to kernel 2.6.4 (i have experience with gentoo but none with slackware).

I initially setup up my slackware + kernel compile on vmware on my faster machine (2ghz), when i switched the slackware 9.1 ready hd to the P100, all went ok....excpet for this

i've already tried netconfig and setting to recieve from dhcp...but it's not working...

during boot time i get this error:

Code:
INIT: Entering runlevel 3 
Going multiuser . . .

dhcpcd[61]: broadcasting DHCP_REQUEST for 192.168.40.131

dhcpcd[61]: timed out waiting for DHCP_ ACK response

dhcpcd[61]: boradcasting DHCP_DISCOVER

dhcpcd[61]: timed out waiting for a valid DHCP server response

i did not setup my slackware machine to request address 192.168.40.131......how do i get eth0 or eth1 to get IP from dhcp?

I know for sure that my dhcp server (win2k ICS) is working..



ps: i have a experience with gentoo but none with slackware...this is my first shot at this distro
 
Old 03-11-2004, 06:46 PM   #2
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
You can manually edit the file /etc/rc.d/rc.inet1.conf. Here is a portion of mine:
Code:
# Config informaiton for eth0
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config informaiton for eth1
IPADDR[1]="172.16.1.1"
NETMASK[1]="255.255.255.0"
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""
....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcp doesn't want to start afterburner Linux - Newbie 7 02-26-2008 03:55 AM
DHCP don't start waelaltaqi Linux - Networking 7 11-18-2005 04:09 PM
DHCP problems - multiple DHCP servers sat86 Linux - Networking 4 10-02-2005 05:43 AM
DHCP won't start Dr. Doerke Linux - Wireless Networking 4 08-15-2005 08:57 PM
XP Pro Build 2600/sp1 v.1105 DHCP Client to Redhat 8.0 DHCP Server - Problems atomant Linux - Networking 5 06-28-2003 11:24 AM


All times are GMT -5. The time now is 05:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration