LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-21-2013, 03:40 PM   #1
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Rep: Reputation: 0
Problem with youtube, LQ, facebook,etc in -current


Hi all

After switching from 14.0 to current a month ago, Iī m having problems like: no access to facebook or G+, canīt play any youtube videos or similar pages. Even canīt send this new thread from LQ (had to switch to winXP) or similar pages. This happens with firefox, seamonkey or chrome and with KDE or XFCE

Using the 3.2.29 kernel from 14.0 the problem is gone. But it ainīt current

My system
Code:
bash-4.2# uname -a
Linux cesarion 3.8.13 #2 SMP Sun May 12 17:23:24 CDT 2013 x86_64 Intel(R) Pentium(R) 4 CPU 3.06GHz GenuineIntel GNU/Linux
My hardware
Code:
bash-4.2# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
00:1d.0 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications Inc. AR2417 Wireless Network Adapter [AR5007G 802.11bg] (rev 01)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
any help is welcome
 
Old 05-21-2013, 04:00 PM   #2
torimus
Member
 
Registered: Apr 2013
Distribution: Slackware
Posts: 81

Rep: Reputation: Disabled
Quote:
no access to facebook or G+, canīt play any youtube videos or similar pages
How exactly does manifest this issue ?
 
Old 05-21-2013, 04:50 PM   #3
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
If I enter facebook.com in firefox it will quit after a moment searching. With youtube I can enter the main page and see the miniture of the videos but when I press play the counter stays at zero. The icon for loading video wonīt show. In linuxquestions.org canīt do a search through the forums or post a thread. In G+ canīt enter the menus and the notifier stays blank

Forget to mention Iīm using latest AlienBob flashplugin. I īve tryied slackbuilds package also.

Last edited by cesarion76; 05-21-2013 at 06:28 PM.
 
Old 05-21-2013, 07:50 PM   #4
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,754

Rep: Reputation: 169Reputation: 169
Quote:
Originally Posted by cesarion76 View Post
Hi all

After switching from 14.0 to current a month ago, Iī m having problems like: no access to facebook or G+, canīt play any youtube videos or similar pages. Even canīt send this new thread from LQ (had to switch to winXP) or similar pages. This happens with firefox, seamonkey or chrome and with KDE or XFCE

Using the 3.2.29 kernel from 14.0 the problem is gone.
Do you have any network access at all with the new kernel? Or is it just these pages which can't be seen?
 
Old 05-21-2013, 07:59 PM   #5
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
Hi rkelsen,

yes I have access to the net. It īs just those pages that I canīt see.

The rc.modules symlink was pointing to the 3.2.29 kernel but I change it to point to the correct 3.8.13 kernel modules. That didinīt solve it.

Also, now that you mention the network access, I have sbopkg installed and canīt sync to the repos.
 
Old 05-21-2013, 08:08 PM   #6
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,046

Rep: Reputation: 170Reputation: 170
Quote:
Originally Posted by cesarion76 View Post
...This happens with firefox, seamonkey or chrome and with KDE or XFCE
I'm thinking along the lines of rkelsen that there's something funky going on with the network.

Can you access the sites in Konqueror?

What does /etc/hosts look like? Do you use squid or privoxy or some other proxy?

There seems to be differing opinions on whether disabling ipv6 (if you believe you don't need it) has any effect on this type of issue, but some swear by it....

You can disable ipv6 specifically in Firefox, and if that appears to correct your issue, then you can disable ipv6 system-wide. This thread may tell you how:

http://www.linuxquestions.org/questi...e-ipv6-937447/

cheers,
 
Old 05-21-2013, 08:19 PM   #7
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,252

Rep: Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631
It could be a DNS issue. Post the output of /etc/resolv.conf and see what happens when you ping google.com, for example, compared to google.com's IP address -- if it is a nameserver issue then pinging the IP will return instantly, while pinging the domain name will take time (or fail to complete). Google's public DNS server is 8.8.8.8 in case the DNS server you are currently using is not working (though if the problem is not getting a nameserver at all, then you should probably check your ISP's and/or router's settings to make sure the nameserver specified by DHCP is getting passed on properly). If you want to try Google's DNS server then you can put the following at the top of /etc/resolv.conf:
Code:
nameserver 8.8.8.8
That will get overwritten when you reboot (or if you restart the networking scripts or bring down/up the interface), and specifying DHCP_KEEPRESOLV[0]="yes" in /etc/rc.d/rc.inet1.conf does not work (it does pass the right option to dhcpcd but it has no effect...). If you need to keep resolv.conf from getting overwritten (to make the modification permanent) then the following (as root) will work:
Code:
# chattr +i /etc/resolv.conf
If at any time you do need to edit the file then you will need to reverse that with
Code:
# chattr -i /etc/resolv.conf
 
Old 05-21-2013, 10:09 PM   #8
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
With konqueror is the same thing. Disabled ipv6 in firefox, still the same.

/etc/hosts
Code:
# For loopbacking.
127.0.0.1               localhost
127.0.0.1               cesarion.bianca.org cesarion
/etc/resolv.conf

Code:
# Generated by NetworkManager
nameserver 10.0.0.2
nameserver 192.168.1.1
Code:
$ ping google.com
PING google.com (181.15.96.84) 56(84) bytes of data.
64 bytes from host84.181-15-96.telecom.net.ar (181.15.96.84): icmp_req=1 ttl=58 time=14.8 ms
64 bytes from host84.181-15-96.telecom.net.ar (181.15.96.84): icmp_req=2 ttl=58 time=15.3 ms
64 bytes from host84.181-15-96.telecom.net.ar (181.15.96.84): icmp_req=3 ttl=58 time=16.2 ms
64 bytes from host84.181-15-96.telecom.net.ar (181.15.96.84): icmp_req=4 ttl=58 time=15.1 ms
...
64 bytes from host84.181-15-96.telecom.net.ar (181.15.96.84): icmp_req=24 ttl=58 time=15.5 ms
64 bytes from host84.181-15-96.telecom.net.ar (181.15.96.84): icmp_req=25 ttl=58 time=14.6 ms
^C
--- google.com ping statistics ---
25 packets transmitted, 25 received, 0% packet loss, time 24030ms
rtt min/avg/max/mdev = 14.380/15.104/16.218/0.471 ms
 
Old 05-22-2013, 04:28 AM   #9
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,046

Rep: Reputation: 170Reputation: 170
Quote:
Originally Posted by cesarion76 View Post
/etc/resolv.conf

Code:
# Generated by NetworkManager
nameserver 10.0.0.2
nameserver 192.168.1.1
I'm not familiar with your network topology, but I'm assuming that 192.168.1.1 is the router. What is 10.0.0.2 ? Just to eliminate /etc/resolv.conf as a culprit, could you try T3slider's suggestion to substitute google's nameserver for the ones generated by NM?

cheers,
 
Old 05-22-2013, 05:20 PM   #10
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
10.0.0.2 is my adsl modem.
 
Old 05-23-2013, 04:44 AM   #11
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,046

Rep: Reputation: 170Reputation: 170
hmmm...what's your machine's ip?

$ /sbin/ifconfig

Assuming it's in the 192.168.1.xxx subnet makes the 10.0.0.2 a bit curious since NM wouldn't be aware of the 10.0.0.xxx subnet, however I digress a touch and I'm venturing out of my league, anticipating a blindside bodycheck any moment now. (edit: nm woulld know via dhcp.)

as root, edit /etc/resolv.conf thusly:

Code:
# Generated by NetworkManager
# nameserver 10.0.0.2
nameserver 8.8.8.8
nameserver 192.168.1.1
Also, clear any caches in your browser, then give it a shot. If no difference, it reduces the chance that resolv.conf is the issue.

cheers,

Last edited by mrclisdue; 05-23-2013 at 08:06 AM. Reason: realization, caffeine kicked in
 
Old 05-23-2013, 09:46 AM   #12
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,236

Rep: Reputation: 176Reputation: 176
There is a discussion on disabling ipv6 in this thread,

http://www.linuxquestions.org/questi...us-4175441796/

in post #8, i referenced this link, https://help.ubuntu.com/community/We...ngSlowIPv6IPv4

Instead of blacklisting I use a simple text file named, ipv6.conf and placed it in the /etc/modprobe.d directory. That has worked very well. The file says,

options ipv6 disable=1

You may have to reboot for it to take effect.

Thanks to board member acummings for pointing me in the right direction.

Last edited by cwizardone; 05-23-2013 at 10:14 AM.
 
Old 05-23-2013, 01:45 PM   #13
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
ifconfig returns this

Code:
bash-4.2# ifconfig 
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:13:8f:a3:37:1c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.100  netmask 255.255.255.0  broadcast 192.168.1.255
        ether f4:ec:38:fd:24:49  txqueuelen 1000  (Ethernet)
        RX packets 2786  bytes 2196553 (2.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2874  bytes 545126 (532.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
edited
Code:
/etc/resolv.conf
also disable ipv6 and still the same.

Let me point out that if using the 3.2.29 kernel in -current I can connect no
problem at all. Can it be a problem with the 3.8.13 kernel or a configuration
error in my side?
 
Old 05-23-2013, 06:34 PM   #14
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
What happens if you just try to ping the websites in question? Do you get anything back? Do they resolve? What do you get when you:
Code:
nslookup domainyoucantreach
 
Old 05-24-2013, 03:50 PM   #15
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by manwichmakesameal View Post
What happens if you just try to ping the websites in question? Do you get anything back? Do they resolve? What do you get when you:
Code:
nslookup domainyoucantreach
I get this:

Code:
bash-4.2$ nslookup facebook.com
Server:         10.0.0.2
Address:        10.0.0.2#53

Non-authoritative answer:
Name:   facebook.com
Address: 173.252.110.27
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to deny access to https youtube,facebook rj_gtx Linux - Networking 17 09-03-2013 04:42 AM
Most YouTube videos and Facebook games won't play. LinuxLiker Linux - Software 13 04-19-2012 08:54 AM
LXer: Search YouTube videos on Ubuntu with the YouTube Lens LXer Syndicated Linux News 0 12-30-2011 08:40 PM
Slackware current goes to KDE login screen when I Esc from full-screen youtube videos Robert.Thompson Slackware 2 04-11-2011 04:43 PM
[SOLVED] Google Chrome (Latest) - No sync, No HTML5 Youtube (Slackware64-current) Gavin Harper Slackware 17 12-15-2010 01:41 AM


All times are GMT -5. The time now is 07:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration