LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem with VLC 1.1.1 on Slackware 13.1 (with both 32 and 64 bits) (http://www.linuxquestions.org/questions/slackware-14/problem-with-vlc-1-1-1-on-slackware-13-1-with-both-32-and-64-bits-825464/)

Lufbery 08-10-2010 10:08 PM

Problem with VLC 1.1.1 on Slackware 13.1 (with both 32 and 64 bits)
 
This is a strange problem that I did not have on Slackware 13.0 with VLC-1.0.2, but has shown up with 13.1 and VLC 1.1.1. (All of the VLC packages I'm talking about come from Alien BOB!)

First problem, when I try to play a DVD by going to File -> Open Disk -> DVD -> Play, I get this error:

Code:

Playback failure:
DVDRead could not open the disc "/dev/hda".
Your input can't be opened:
VLC is unable to open the MRL 'dvd:///dev/hda'. Check the log for details.

Which makes sense because of the LibATA switch-over. Right? The DVD shouldn't be /dev/hda anymore.

(There is no log, BTW, I hadn't set one up in the preferences).

I can still choose to open a directory and simply click on the DVD in the open directory dialog box (/media/<DVD name>). Then everything plays without a problem.

Is this an easy fix?

Lufbery 08-10-2010 10:17 PM

Okay, it was an easy fix. When opening a disk, I needed to specify /dev/dvd and then it played the movie without problems. The same goes for /dev/cdrom for audio CDs.

Lufbery 08-10-2010 11:30 PM

Ack! Okay, how do I make /dev/dvd and /dev/cdrom the default locations?

Daedra 08-11-2010 01:58 AM

Just curious but did you try deleting your vlc config files in your /home directory? Upon restart it should pick up /dev/dvd for you.

Lufbery 08-11-2010 06:58 AM

Daedra,

That's a great idea! I'll give that a shot when I get home this evening. Thanks!

Lufbery 08-11-2010 09:50 PM

So, VLC does not have local configuration settings in the my home directory. However, there is a place to set the default optical device in the settings. I set it to /dev/dvd and everything seems to be working -- even for audio CDs.

andrew.46 08-12-2010 07:49 AM

Hi Lufbery,

Quote:

Originally Posted by Lufbery (Post 4063645)
So, VLC does not have local configuration settings in the my home directory.

Perhaps in $HOME/.config/vlc/vlcrc?

Andrew


All times are GMT -5. The time now is 03:08 AM.