LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-26-2007, 08:40 AM   #1
Barq
Member
 
Registered: Aug 2004
Location: EGYPT
Distribution: FEDORA 10
Posts: 114

Rep: Reputation: 15
problem with sound though alsa detect card


Hello
i am work on slackware 12 , there is no sound when i play sound file , i work on alsa 1.0.15, and it detect my sound card ,then i manipulate with alsamixer to configure my sound but futile.
 
Old 12-26-2007, 09:33 AM   #2
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Please post the error(s) that you got after not being able to play the audio files.
 
Old 12-26-2007, 09:40 AM   #3
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Rep: Reputation: 40
Just to be clear, using alsamixer, you um-muted the Master control? (1st column?). The bottom of that column should dispay 00 and not MM
 
Old 12-26-2007, 09:49 AM   #4
Barq
Member
 
Registered: Aug 2004
Location: EGYPT
Distribution: FEDORA 10
Posts: 114

Original Poster
Rep: Reputation: 15
there is no any error message, and master control is 00
when i open aRts control tool it indicate as there are sound,but there is no sound
 
Old 12-26-2007, 11:15 AM   #5
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Did you try as user or as root?
 
Old 12-26-2007, 12:30 PM   #6
Barq
Member
 
Registered: Aug 2004
Location: EGYPT
Distribution: FEDORA 10
Posts: 114

Original Poster
Rep: Reputation: 15
i logging as root
 
Old 12-26-2007, 01:18 PM   #7
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 316

Rep: Reputation: 30
If you are using ksCD to play music files then you have to enable digital play back.

With KsCD open but not playing a file, click on extra then configure KsCD then check (with a cross) Use Direct Digital Playback.

You should then be able to play music files.
 
Old 12-26-2007, 01:44 PM   #8
Barq
Member
 
Registered: Aug 2004
Location: EGYPT
Distribution: FEDORA 10
Posts: 114

Original Poster
Rep: Reputation: 15
i run mp3 file form hard disk , and as i say aRts control tool indicator move
 
Old 12-27-2007, 01:09 AM   #9
Barq
Member
 
Registered: Aug 2004
Location: EGYPT
Distribution: FEDORA 10
Posts: 114

Original Poster
Rep: Reputation: 15
anybody help me
 
Old 12-27-2007, 07:25 AM   #10
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Which program do you use to play music?
 
Old 12-27-2007, 07:49 AM   #11
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,270
Blog Entries: 3

Rep: Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445
Hi,
Quote:
Originally Posted by Barq View Post
anybody help me
You configured the alsa and unmuted the proper settings along with setting each level then you need to do a 'alsactl store'. This will save your settings. Reboot the system to confirm that the alsa will be configured properly.

Quote:
excerpt from 'man alsactl';

~# man alsactl
DESCRIPTION
alsactl is used to control advanced settings for the ALSA soundcard
drivers. It supports multiple soundcards. If your card has features
that you can't seem to control from a mixer application, you have come
to the right place.

COMMANDS
store saves the current driver state for the selected soundcard to the
configuration file.

restore loads driver state for the selected soundcard from the configu-
ration file.

names generates list of available device names for applications. The
card number or id is ignored for this command. The list is always gen-
erated for all available cards.

If no soundcards are specified, setup for all cards will be saved or
loaded.
You should 'man alsactl' to get the full definition.
 
Old 12-28-2007, 09:33 AM   #12
nsp
Member
 
Registered: Jul 2006
Location: China
Distribution: Slackware
Posts: 68

Rep: Reputation: 15
If you have tried what onebuck said and it still fails to work, maybe you can launch the mixer program of KDE (I forgot it's name) and have a look of if the sound card was muted by this program.

Sorry for my English.

Last edited by nsp; 12-28-2007 at 10:24 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa sound wizard won't detect onboard sound darinbolson Puppy 2 02-28-2007 03:13 PM
ALSA won't detect card in Gentoo 10xOXR Linux - Newbie 3 06-20-2005 10:05 AM
ALSA wont detect sound card after Slackware 10 upgrade coffeedemon Slackware 3 11-15-2004 07:29 PM
Alsa woes - Fails to detect sound card huntz Slackware 7 05-21-2004 08:13 PM
Problem sound-card and Alsa kired Linux - Hardware 2 05-04-2003 05:49 PM


All times are GMT -5. The time now is 02:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration