LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-02-2013, 07:55 PM   #1
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Rep: Reputation: Disabled
Problem with Slackware installation!


Hello folks.
I recently install slackware on my hd.
Is my first instal, so probably i am doing something wrong.
I boot the slackware 14 from my pendriver.
# Huge.s.
# Map keyboard - ok.
# root
Pendriver - /dev/sdb
HD - /dev/sda
# cfdisk /dev/sda1 - 1 swap (82), 2 Linux (83)bootable - write on disk
# Setup
# Format 1 Swap
# Format 2 Linux
# Instal from a harddriver
# /dev/sdb1
# /slackware
# Full
# All config was norma except lilo.
Lilo
# Install lilo automaticaly
# Install on MBR
# Trying to instal Lilo - Error. Try FIX MBR OR IGNORE PARTITION TABLE.
# Continue to configure the default values.
# Exit
# Ctrl + Alt + Delete

After remove the pendriver and try to boot from Hd, the pc kepps restarting.
Important: After the BEEP and MB Bios Screen, the vídeo shutdown.

Can some one help?
 
Old 02-02-2013, 08:18 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,465

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
There appears to be a problem with your LILO installation. Try booting from your install media and then rerunning 'liloconfig' to write the lilo boot loader to the MBR on /dev/sda1.
You can get more information on LILO here. http://docs.slackware.com/slackbook:booting#lilo
 
Old 02-02-2013, 08:24 PM   #3
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,959

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Did you succeed in installing LiLo. From the sequence you give

Quote:
# Install lilo automaticaly
# Install on MBR
# Trying to instal Lilo - Error. Try FIX MBR OR IGNORE PARTITION TABLE.
# Continue to configure the default values.
it looks as if the answer is no.

For a first shot at fixing this, I would suggest booting to the pendrive, running the setup routine again, then cursoring down to the "Configure Your New System" (I think that's the wording) and rerunning it, this time choosing the "expert" or "manual" Lilo install.

Do not skip a step, especially the one about adding a Linux partition to Lilo. The "expert install" throws you back to the menu about a third of the way through, so that one can conclude (as I have done) that it is complete, when it is not. As a footnote, I normally install to the MBR and it works without issue.

I have never had the automatic Lilo install work for me.
 
Old 02-03-2013, 08:01 AM   #4
lordwolf
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 44

Rep: Reputation: 15
Quote:
Originally Posted by AryMaynart View Post
# cfdisk /dev/sda1 - 1 swap (82), 2 Linux (83)bootable - write on disk
Lilo
# Install lilo automaticaly
# Install on MBR
# Trying to instal Lilo - Error. Try FIX MBR OR IGNORE PARTITION TABLE.
If what you wrote is correct and if I understand correctly on what you did (I haven't used cfdisk before - only fdisk), did you just ran cfdisk on a partition instead of the disk (cfdisk /dev/sda1 instead of /dev/sda)? That could be the problem with your MBR.
 
Old 02-03-2013, 09:11 AM   #5
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
Quote:
Originally Posted by AryMaynart View Post
# Instal from a harddriver
# /dev/sdb1
# /slackware
# Full
I had an interesting problem when made a fresh installation from a USB drive. I had used usbimg2disk.sh to put the Slackware installer on it as well as the packages I intended to install.

Everything went well until I went to LILO the MBR. I kept getting messages about DOS partitions (which I definitely did'nt have) and the system eventually told me that the only way I could boot was from an external drive. It turned out that the DOS partition on the USB was confusing liloconfig.

The solution was to reboot from the USB drive, chroot /dev/sda2 and edit the lilo.conf file manually. After running lilo again, everything was fine.

Hope this helps.
 
1 members found this post helpful.
Old 02-03-2013, 09:17 AM   #6
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by psionl0 View Post
I had an interesting problem when made a fresh installation from a USB drive. I had used usbimg2disk.sh to put the Slackware installer on it as well as the packages I intended to install.

Everything went well until I went to LILO the MBR. I kept getting messages about DOS partitions (which I definitely did'nt have) and the system eventually told me that the only way I could boot was from an external drive. It turned out that the DOS partition on the USB was confusing liloconfig.

The solution was to reboot from the USB drive, chroot /dev/sda2 and edit the lilo.conf file manually. After running lilo again, everything was fine.

Hope this helps.
Could you post here the steps? Im to new on this. I think my problem is the same has yours. Is allways returning msdos part. I thougt that was normal because of pendrivers fat32 partition.
The others solutions above dosent help.
 
Old 02-03-2013, 04:30 PM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,465

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
Quote:
The solution was to reboot from the USB drive, chroot /dev/sda2 and edit the lilo.conf file manually. After running lilo again, everything was fine.
Quote:
Could you post here the steps?
http://docs.slackware.com/howtos:sla...oot_from_media
 
Old 02-03-2013, 09:11 PM   #8
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
Quote:
Originally Posted by AryMaynart View Post
Could you post here the steps? Im to new on this. I think my problem is the same has yours. Is allways returning msdos part. I thougt that was normal because of pendrivers fat32 partition.
The others solutions above dosent help.
Boot in from your installation disk/drive and login as root as you did originally. Then issue the following commands:

# mkdir /mymnt
# mount /dev/sda2 /mymnt
# chroot /mymnt
# vi /etc/lilo.conf (if you are unfamiliar with vi you can use nano /etc/lilo.conf instead)
# lilo

You should then be able to remove your installation media and boot normally.

Assuming you have installed Slackware 64-bit, the relevant section of the lilo.conf file (towards the end of the file) should read as follows:
Code:
# # Linux bootable partition config begins
# image = /boot/vmlinuz-generic-3.2.29
# initrd = /boot/initrd.3.2.29.gz
#   root = /dev/sda2
#   label = Linux
#   read-only
# # Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz-huge-3.2.29
  root = /dev/sda2
  label = Linux_HUGE
  read-only
# Linux bootable partition config ends
The information about the generic version must remain commented out until you have created an initrd (after successfully booting into the huge kernel).

Make sure you have deleted all other partition config references - especially those relating to windows partitions from lilo.conf.

Last edited by psionl0; 02-03-2013 at 09:14 PM.
 
1 members found this post helpful.
Old 02-05-2013, 07:49 PM   #9
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
It Works, but i am having new problems!

Quote:
Originally Posted by psionl0 View Post
Boot in from your installation disk/drive and login as root as you did originally. Then issue the following commands:

# mkdir /mymnt
# mount /dev/sda2 /mymnt
# chroot /mymnt
# vi /etc/lilo.conf (if you are unfamiliar with vi you can use nano /etc/lilo.conf instead)
# lilo

You should then be able to remove your installation media and boot normally.

Assuming you have installed Slackware 64-bit, the relevant section of the lilo.conf file (towards the end of the file) should read as follows:
Code:
# # Linux bootable partition config begins
# image = /boot/vmlinuz-generic-3.2.29
# initrd = /boot/initrd.3.2.29.gz
#   root = /dev/sda2
#   label = Linux
#   read-only
# # Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz-huge-3.2.29
  root = /dev/sda2
  label = Linux_HUGE
  read-only
# Linux bootable partition config ends
The information about the generic version must remain commented out until you have created an initrd (after successfully booting into the huge kernel).

Make sure you have deleted all other partition config references - especially those relating to windows partitions from lilo.conf.
Hello again!
Tanks mate.
Your solution works. Slack was installed and booted!
The problem was the lilo.conf.
I used expert mode at setup, then edited the lilo.conf manualy correcting the errors.
Startx works fine. Bu i'm having other problems.
The linux HD is an IDE.
After trying the slackware, i tryed to shut down and connect my 3 other HDs (sata) NTFS where i put music, videos, etc..., then i have a stop error when huge.s is loading.
Here is the photo i made. I hope it helps to see the error.

http://arymaynart.xpg.com.br/IMG_20130205_231338.jpg

I realize that the wireless network is not working. The Wireles manager dont find conections. Semms the driver is not loading. How can i fix that too!
 
Old 02-05-2013, 09:20 PM   #10
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
It appears that Linux is suddenly not seeing sda2 or sda3. That suggests that the way you connected the HDs is in error in which case I am out of my depth here. Maybe another Slacker knows the correct solution but some of the things I would try are as follows:

Can you still boot normally if you disconnect the other drives? If not then you might have corrupted sda.

Can you boot from the original installation media with the other HDs connected? If so you could possibly do something like ls /dev/sd* to see what partitions are there. Each one has to be mount-ed before you can view the files.

Can you boot from the original installation media if you disconnect the other drives? (I hope so).

If nobody comes up with a better answer then try the 3 things I suggested and let me know the results.
 
Old 02-06-2013, 01:58 PM   #11
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Answers for your questions!

Quote:
Originally Posted by psionl0 View Post
It appears that Linux is suddenly not seeing sda2 or sda3. That suggests that the way you connected the HDs is in error in which case I am out of my depth here. Maybe another Slacker knows the correct solution but some of the things I would try are as follows:

Can you still boot normally if you disconnect the other drives? If not then you might have corrupted sda.
R. Yes. I can boot with the other drivers disconected.

Can you boot from the original installation media with the other HDs connected? If so you could possibly do something like ls /dev/sd* to see what partitions are there. Each one has to be mount-ed before you can view the files.
R. Yes. With the others drivers conected, i tryed to boot from my pendriver and works fine. Includding the setup, and, yes, i could see my other drivers and their partitions.

Can you boot from the original installation media if you disconnect the other drives? (I hope so).
R. Shure. That is no problem.

If nobody comes up with a better answer then try the 3 things I suggested and let me know the results.
What do I do?

Last edited by AryMaynart; 02-06-2013 at 02:01 PM.
 
Old 02-07-2013, 11:10 AM   #12
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
Quote:
Originally Posted by AryMaynart View Post
Quote:
Originally Posted by psionl0 View Post
Can you boot from the original installation media with the other HDs connected? If so you could possibly do something like ls /dev/sd* to see what partitions are there. Each one has to be mount-ed before you can view the files.
R. Yes. With the others drivers conected, i tryed to boot from my pendriver and works fine. Includding the setup, and, yes, i could see my other drivers and their partitions.
That's good - the problem isn't terminal. I don't have any actual solutions - just half baked ideas. The last time I physically handled a hard drive in a computer (and that was a long time ago) there was something about master/slave configurations. Make sure your switch settings are correct for each HD.

One thing you could do is run fdisk -l and see how many partitions are bootable. If sdb1 is bootable and you only want sda1 to be bootable then run fdisk /dev/sdb and toggle the bootable partition.

Assuming you have that right, it might be possible that when you added the other HDs, the lettering changed (sda became sdb or sdc or something). You could easily check that out by running ls /dev/sd* and for each partition you see, mount it on its own root partition. eg if you see /dev/sdb1 then issue the commands, mkdir /sdb1 and mount /dev/sdb1 /sdb1 etc. You can then see which partition you installed the Slackware on. If it turns out that your Slackware files are now on /sdc1 then the solution is to run chroot /sdc1, edit /etc/lilo.conf, change all references from sda to sdc then run lilo again.

You will also need to edit /etc/fstab and change the root partition name there as well. (You can also assign each HD partition to somewhere in the directory-tree so that they will be mounted on bootup).

Last edited by psionl0; 02-07-2013 at 08:41 PM.
 
1 members found this post helpful.
Old 02-08-2013, 06:15 AM   #13
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by psionl0 View Post
That's good - the problem isn't terminal. I don't have any actual solutions - just half baked ideas. The last time I physically handled a hard drive in a computer (and that was a long time ago) there was something about master/slave configurations. Make sure your switch settings are correct for each HD.

One thing you could do is run fdisk -l and see how many partitions are bootable. If sdb1 is bootable and you only want sda1 to be bootable then run fdisk /dev/sdb and toggle the bootable partition.

Assuming you have that right, it might be possible that when you added the other HDs, the lettering changed (sda became sdb or sdc or something). You could easily check that out by running ls /dev/sd* and for each partition you see, mount it on its own root partition. eg if you see /dev/sdb1 then issue the commands, mkdir /sdb1 and mount /dev/sdb1 /sdb1 etc. You can then see which partition you installed the Slackware on. If it turns out that your Slackware files are now on /sdc1 then the solution is to run chroot /sdc1, edit /etc/lilo.conf, change all references from sda to sdc then run lilo again.

You will also need to edit /etc/fstab and change the root partition name there as well. (You can also assign each HD partition to somewhere in the directory-tree so that they will be mounted on bootup).
I already edited the lilo.conf and change the boot disk reference. With the others disks conected, the bootable disk with slackware changed, but i dont edited the /etc/fstab. Maybe the problem is there.
I will try fix the fstab today at nigth and will post the result here.
 
Old 02-08-2013, 04:19 PM   #14
AryMaynart
LQ Newbie
 
Registered: Feb 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Angry Still with problem!

Quote:
Originally Posted by AryMaynart View Post
I already edited the lilo.conf and change the boot disk reference. With the others disks conected, the bootable disk with slackware changed, but i dont edited the /etc/fstab. Maybe the problem is there.
I will try fix the fstab today at nigth and will post the result here.
Well,
Doesen't work.
Its every thing ok with the fstab and lilo.conf.
Let me put here more information.

My Config.
MB: M2N68-AM PLUS
Proc: Phenom X3 720 BE
MEM: 4 GB Kingston
HD1: Samsung IDE 40 GB - Linux # /etc/sdd
HD2: Samsung SATA 80 GB - Windows 8 /etc/sdc
HD3: Samsung SATA 500 GB - No Sistem /etc/sda
HD4: Samsung SATA 500 GB - No Sistem /etc/sdb
Pendrv: Kingston 4 GB - Slackware Setup /etc/sde

Just to clear:
The slackware is installed on IDE 40 GB /etc/sdd.
I instaled slackware with the other drivers disconected.
If I connect the drivers, slack returns a stop error just like you see on the image.
If I do not connect the drivers, slack boots fine.

C'mon guys!!! I know there is somebare else here that knows how to fix!!
 
Old 02-08-2013, 04:48 PM   #15
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
Quote:
Originally Posted by AryMaynart View Post
Well,
Doesen't work.
Its every thing ok with the fstab and lilo.conf.
Let me put here more information.

My Config.
MB: M2N68-AM PLUS
Proc: Phenom X3 720 BE
MEM: 4 GB Kingston
HD1: Samsung IDE 40 GB - Linux # /etc/sdd
HD2: Samsung SATA 80 GB - Windows 8 /etc/sdc
HD3: Samsung SATA 500 GB - No Sistem /etc/sda
HD4: Samsung SATA 500 GB - No Sistem /etc/sdb
Pendrv: Kingston 4 GB - Slackware Setup /etc/sde

Just to clear:
The slackware is installed on IDE 40 GB /etc/sdd.
I instaled slackware with the other drivers disconected.
If I connect the drivers, slack returns a stop error just like you see on the image.
If I do not connect the drivers, slack boots fine.

C'mon guys!!! I know there is somebare else here that knows how to fix!!
Did you run lilo after editing lilo.conf? (That's an easy omission to make).

Just to double check everything, you should have done
mount /dev/sdd1 /sdd1
chroot /sdd1
vi /etc/lilo.conf
vi /etc/fstab
lilo


The relevant section of your lilo.conf should now read as
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0 video=800x600"
boot = /dev/sdd
. . .
# Linux bootable partition config begins
image = /boot/vmlinuz-huge-3.2.29
  root = /dev/sdd2
  label = Linux_HUGE
  read-only
# Linux bootable partition config ends
And your fstab (assuming your first partition is the swap partition) should be:
Code:
/dev/sdd1        swap             swap        defaults         0   0
/dev/sdd2        /                ext4        defaults         1   1
/dev/sd (other mount points)

Last edited by psionl0; 02-08-2013 at 04:51 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware installation problem ksgill General 11 02-01-2007 06:37 PM
Slackware installation problem Rayning Slackware - Installation 5 11-24-2006 10:44 AM
Installation problem with Slackware 10 Repeater Slackware 1 08-01-2004 08:35 AM
Slackware 9.1 installation problem FinalSolution Linux - Hardware 1 04-29-2004 06:25 PM


All times are GMT -5. The time now is 06:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration