LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-11-2005, 02:29 AM   #16
Quinta
LQ Newbie
 
Registered: Feb 2005
Location: Henley-on-Thames, England
Distribution: Slackware
Posts: 11

Rep: Reputation: 0

OK Lintux

1. Linux means NEVER re-installing to fix a little problem - this isn't MSLand :-)

2. Please, please nicely, post the mouse section of /etc/X11/xorg.conf The solution to your problem almost certainly lies in sorting out that file.

You said earlier that you could not do so - why? We only need the uncommented lines, ie those that don't begin with a # Typing those out will take you far less time than re-installing :-)

3 What IS the output of

Code:
ls -l /dev/mouse
 
Old 02-11-2005, 03:12 AM   #17
eduardomsilva
Member
 
Registered: Feb 2005
Location: Portugal
Distribution: Slackware
Posts: 45

Rep: Reputation: 15
Hello.

To have your original configuration, and start your x without problems, you should run the "xorgsetup" command... it should work, otherwise, you should run "xorgconfig" and choose correctly all your computer components.

About the mouse, you should edit the "/etc/X11/xorg.conf", and change the part relative to the mouse:
"
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
EndSection
"

This is my configuration... from my laptop. It works really well (usb and touchpad), maybe for you you need to exchange the "Protocol" -> "ImPS2" and the "Device" -> "/dev/mouse"... but try the several combinations!

I think you just need to try (and combine) this options, and it will work...

See you.

/Edu
 
Old 02-11-2005, 08:05 AM   #18
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Quote:
Originally posted by Lintux
how do I make it use the Vesa conf?
Change to the directory /etc/X11, and do an ls. You'll notice that one of the files left there by the install is xorg.conf-vesa. All you have to do is copy that file to xorg.conf, though it's probably a good idea to make a backup of your existing file beforehand.


The long answer:
Code:
#cd /etc/X11
#mv xorg.conf xorg.conf-backup
#cp xorg.conf-vesa xorg.conf
And you're ready to startx. Though, you'll probably notice that in VESA mode, the graphics driver will not support a resolution higher than 1024x768.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
su problem in slack 10.1 lazyboy0001 Slackware 17 04-08-2005 09:53 PM
Slack problem... TCasp77 Linux - Networking 1 02-27-2004 06:13 PM
Slack problem Coldhg Slackware 6 10-27-2003 02:51 PM
SBLive problem in Slack 8.1 Flat_Tire_ Slackware 12 03-07-2003 10:22 PM
Slack 8.1 problem DigitalKhaos Linux - Newbie 3 02-09-2003 01:58 AM


All times are GMT -5. The time now is 04:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration