LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   problem with sendmail over ppp - message queue stuck (http://www.linuxquestions.org/questions/slackware-14/problem-with-sendmail-over-ppp-message-queue-stuck-464344/)

julot 07-15-2006 02:24 PM

problem with sendmail over ppp - message queue stuck
 
Hi

I'd like to start using mutt, with sendmail and fetchmail. I've already configured and tested fetchmail. Besides, I connect to Internet using pppd, so my connection isn't permanent.

I thought it would be enough to start sendmail at boot time, so I did it, rebooted, wrote a message and then got connected to Internet. My message didn't got sent.

After that I shut down pppd and sendmail, modified the sendmail startup script and reduced the queue time (changed the -q param to -q2m), and tried again, starting sendmail first (as if it was done at boot time), and then connecting to internet, and waiting (to cover all doubts) 5 min. Nothing yet.

After googling a bit, I found that I should issue a "sendmail -q" when the ppp link goes up, so I putted that command in /etc/ppp/ip-up, added to ip-up exec permission and tried again. And nothing. In the mail log appears something like
Code:

Jul 15 13:24:15 abu sendmail[3507]: gethostbyaddr(201.217.196.253) failed: 2
sendmail (and besides, fetchmail) only works properly when I start it after getting connected (so I'm restarting sendmail in ip-up), but that is an unnecessary hack.

I've found the "sendmail -q" advice in several places, and I think the relevant question there is: how should I start sendmail at boot time to make it work properly?

blackfin_srini 07-17-2006 05:44 AM

How to start a new thread????


All times are GMT -5. The time now is 01:15 PM.