LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem with okular (or ghostscript ?) (http://www.linuxquestions.org/questions/slackware-14/problem-with-okular-or-ghostscript-4175457464/)

Toutatis 04-09-2013 05:14 AM

Problem with okular (or ghostscript ?)
 
When opening ps files with okular (from slackware64-current, kde-4.10.2), I get blank pages and messages of this type:
------------------------------------------------------------
okular(32278)/okular (Spectre) GSRendererThread::run: Generated image does not match wanted size: [0x0] vs requested [926x1308]
QImage::scaled: Image is a null image
undefined -21
undefined -21
okular(32278)/okular (Spectre) GSRendererThread::run: Generated image does not match wanted size: [0x0] vs requested [53x75]
QImage::scaled: Image is a null image
undefined -21
undefined -21
okular(32278)/okular (Spectre) GSRendererThread::run: Generated image does not match wanted size: [0x0] vs requested [926x1308]
QImage::scaled: Image is a null image
undefined -21
undefined -21
------------------------------------------------------------

But the ps files open correctly with gv or gsview.

Any idea ?

marbangens 04-09-2013 05:28 PM

Are the images displayed with gv with you're files?
I can open these ps files from the link with no problem
and I have the same version.
http://schneider.ncifcrf.gov/postscript.html
can you do that to?

Toutatis 04-10-2013 01:43 AM

I can open 'testprinter.ps' with gv, but with okular I get only a blank page and a lot of messages like this

----------------------------------------------------
okular(2683)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(2683)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(2683)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(2683)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
undefined -21
okular(2683)/okular (Spectre) GSRendererThread::run: Generated image does not match wanted size: [0x0] vs requested [943x943]
QImage::scaled: Image is a null image
undefined -21
okular(2683)/okular (Spectre) GSRendererThread::run: Generated image does not match wanted size: [0x0] vs requested [943x943]
QImage::scaled: Image is a null image
undefined -21
okular(2683)/okular (Spectre) GSRendererThread::run: Generated image does not match wanted size: [0x0] vs requested [943x943]
QImage::scaled: Image is a null image
undefined -21
okular(2683)/okular (Spectre) GSRendererThread::run: Generated image does not match wanted size: [0x0] vs requested [943x943]
QImage::scaled: Image is a null image
----------------------------------------------------

I have tried to reinstall okular, ghostscript, poppler, libspectre with no result.
evince shows the same as okular.
But gv, gsview, mgv (an old postcript viewer) work well.

ponce 04-10-2013 03:19 AM

testprinter.ps works fine here with okular, the only guess I can do is that you're probably not using a full install.

to fix this, run
Code:

slackpkg install slackware64

Toutatis 04-10-2013 05:36 AM

Thank you for your answers. All my packages are updated.

I downgraded 'ghostscript-9.07-x86_64-1' to 'ghostscript-9.05-x86_64-3' and now it works....

tronayne 04-10-2013 07:38 AM

Just because, I downloaded testprinter.ps and opened it with Okular:
Code:

okular testprinter.ps
QGtkStyle was unable to detect the current GTK+ theme.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QGtkStyle was unable to detect the current GTK+ theme.
kbuildsycoca4 running...
kbuildsycoca4(5301) KConfigGroup::readXdgListEntry: List entry MimeType in ".hidden/kommander.desktop" is not compliant with XDG standard (missing trailing semicolon).
okular(5292)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(5292)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(5292)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(5292)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(5292)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(5292)/kdeui (kdelibs) KXMLGUIClient::~KXMLGUIClient: 0xe60020 deleted without having been removed from the factory first. This will leak standalone popupmenus and could lead to crashes.

The file displayed all right, but the above stuff doesn't look all that good, eh? I'm using Xfce although KDE is fully installed; will wonders never cease (this is Slackware 64-bit stable).

Ghostview: no errors, works just fine, with these:
Code:

[
/var/log/packages/gv-3.7.3-x86_64-2
/var/log/packages/gvfs-1.12.3-x86_64-2

Ghostscript is at 9.06, no problems.

Toutatis 05-22-2013 04:58 AM

The problem is now solved with new ghostscript-9.07-x86_64-2 in slackware64-current.


All times are GMT -5. The time now is 08:40 PM.