LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-18-2005, 06:07 AM   #1
browser
Member
 
Registered: Aug 2004
Location: Australia,NSW
Distribution: KANOTIX,Mepis3.3,Fedora4,PC-BSD
Posts: 261

Rep: Reputation: 30
Problem with Nvidia & X11


Hi there ,I seem to have a problem ,first I downloaded the nvidia driver as explained in SBings Slackware FAQ and when I went to install it it said it needed to precompile my kernel which I let it do and it installed it , but I get no nvidia logo on boot or login so I went into my x11 xorg.conf file and found I dont have hardly any of the options or sections as mentioned in FAQ 4 me to alter or add ,this is preety much all I have "Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the font modules
Load "type1"
Load "freetype"
Load "speedo"

# This loads the GLX module
Load "glx"

EndSection
AnyWay what do you recommend I can do or add to get my Nvidia card to work with Slackware10 & why is mine so different to what is explained in SBings Slackware FAQ,I am using the default kernel that came with slack the 2.4 kernel, can I add the words- Driver "Nvidia" to a section? and would it work ,Im worried about messing it up .
 
Old 04-18-2005, 06:18 AM   #2
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
Driver "Nvidia" - Bingo

Section "Device"
BoardName "GeForce FX 5950 Ultra"
BusID "3:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
EndSection
 
Old 04-18-2005, 06:21 AM   #3
synapse
Member
 
Registered: Jan 2004
Location: On Planet Earth.
Distribution: Slackware 12
Posts: 244

Rep: Reputation: 30
Hi

I posted my xorg config a while back with all the possible configs that the booklet told about at that time

cheers
 
Old 04-18-2005, 06:21 AM   #4
cb951303
Member
 
Registered: Jan 2004
Distribution: Slackware 11 + Dropline Gnome 2.16
Posts: 194

Rep: Reputation: 30
Hi,
in your xorg.conf change

Driver "some_drivers"

with

Driver "nvidia"

in the module section you should have:

Load "glx"

you should also remove:

Load "dri"
Load "GLcore"


and then you will have nvidia logo in the begining of x

PS:"precompiling a kernel by installer" is impossible, "precompile" means "kernel modules compiled by nvidia".
when I first installed nvidia drivers, the installer couldn't find a "precompiled kernel module" which means that nvidia didn't compiled the modules for slackware and for the kernel version that I was using.So the installer compiled the kernel modules from source.

I think this is the same thing for u too, right?

Last edited by cb951303; 04-18-2005 at 06:22 AM.
 
Old 04-18-2005, 06:30 AM   #5
browser
Member
 
Registered: Aug 2004
Location: Australia,NSW
Distribution: KANOTIX,Mepis3.3,Fedora4,PC-BSD
Posts: 261

Original Poster
Rep: Reputation: 30
this is sort of what I am pointing at, the list I gave above is all I seem to have in my X11 xorg.conf in regards to my display driver etc ,theres no section what soever that says Driver "some_drivers" as you might see and I dont know why ,
 
Old 04-18-2005, 06:35 AM   #6
cb951303
Member
 
Registered: Jan 2004
Distribution: Slackware 11 + Dropline Gnome 2.16
Posts: 194

Rep: Reputation: 30
okay,

I think the problem is that u have different "xorg.conf" files for different users.
Just try to find the real one(that is used to start x server)
(just do a search in root for this file and see how many xorg.conf u have on your hdd)

If this isn't the case, u need to reconfigure xserver in root.

the configurator was "xorgconfig" I think(I'm really not sure).

Last edited by cb951303; 04-18-2005 at 06:37 AM.
 
Old 04-18-2005, 06:35 AM   #7
browser
Member
 
Registered: Aug 2004
Location: Australia,NSW
Distribution: KANOTIX,Mepis3.3,Fedora4,PC-BSD
Posts: 261

Original Poster
Rep: Reputation: 30
sorry I just found this part right near bottom of page ,is this the part where I need to make some of the changes -- Any number of graphics device sections may be present

Section "Device"
Identifier "VESA Framebuffer"
Driver "vesa"
#VideoRam 4096
# Insert Clocks lines here if appropriate
EndSection
# Any number of graphics device sections may be present

Section "Device"
Identifier "VESA Framebuffer"
Driver "vesa"
#VideoRam 4096
# Insert Clocks lines here if appropriate
EndSection
# *****************************************
 
Old 04-18-2005, 06:40 AM   #8
cb951303
Member
 
Registered: Jan 2004
Distribution: Slackware 11 + Dropline Gnome 2.16
Posts: 194

Rep: Reputation: 30
yes this is the part.

did u ever run "xorgconfig" because it's a good idea to reconfigure x server if u have just installed slackware.
the xorg.conf file that came with slack is a little bit different than xorgconfig's version.

Last edited by cb951303; 04-18-2005 at 06:41 AM.
 
Old 04-18-2005, 06:47 AM   #9
browser
Member
 
Registered: Aug 2004
Location: Australia,NSW
Distribution: KANOTIX,Mepis3.3,Fedora4,PC-BSD
Posts: 261

Original Poster
Rep: Reputation: 30
I cant run it because I had to reinstall slack a few times before as i could not get it to accept any of the Nvidia drivers on list and then I could not get it to login again which is why I downloaded the Nvidia driver I couldnt also get it to load the vesa driver again either ,I think its mainly to do with lack of linux knowledge on this part of linux. so I dont want to chance it until I know what Im doing etc with those files.I mean I am worried about logging out again if I try it again ?

Last edited by browser; 04-18-2005 at 06:55 AM.
 
Old 04-18-2005, 07:17 AM   #10
browser
Member
 
Registered: Aug 2004
Location: Australia,NSW
Distribution: KANOTIX,Mepis3.3,Fedora4,PC-BSD
Posts: 261

Original Poster
Rep: Reputation: 30
I added the changes reccommended - changed Driver "vesa" to Driver "nvidia" and the got these errors on terminal when I typed these commands I got from SBings FAQs to load nvidia driver again root@JASONS-BRAAAIN:~# lsmod | grep nvidia
root@JASONS-BRAAAIN:~# /sbin/modprobe nvidia
Warning: loading /lib/modules/2.4.26/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module nvidia loaded, with warnings
root@JASONS-BRAAAIN:~#
I dont know why it would taint the kernel but I am now worried about rebooting even though it now seems to be loaded?
 
Old 04-18-2005, 07:20 AM   #11
cb951303
Member
 
Registered: Jan 2004
Distribution: Slackware 11 + Dropline Gnome 2.16
Posts: 194

Rep: Reputation: 30
I really don't understand what's going wrong.U should really try again
Okay, follow these steps.

1-) If it's possible reinstall slackware and take 3. step

2-) If it's not do in root console:

nvidia-installer --uninstall
updatedb
locate xorg.conf

and then remove all the xorg.conf files with rm "/path/to/xorg.conf"

3-)Boot to console and login as root

4-)Run "xorgconfig" ,

-choose Nvidia Geforce for card
-don't forget to manually configure your monitor's refresh rates.(just google to find your monitors refresh rates).
-while configuring desktop resolutions,make sure that u have maximum 1024x768 in all color modes.

It will ask if you want to save "/etc/X11/xorg.conf" ,don't forget to say "YES"

5-)run nvidia-drivers by typing:

sh nvidia-drivers-xxxxxxx

-make sure that the installer can't find "a precompiled kernel module" and that it will compile it from scratch.
-Look for the "succesfully installed" sign

6-)in /etc/X11/xorg.conf change

Driver "nv" //or vesa

with

Driver "nvidia"

in the module section you should have:

Load "glx"

you should also remove these lines:

Load "dri"
Load "GLcore"

7-)Reboot your computer and login as root then type

startx

8-)Now, u can use some non-root user to use x server
 
Old 04-18-2005, 08:15 AM   #12
browser
Member
 
Registered: Aug 2004
Location: Australia,NSW
Distribution: KANOTIX,Mepis3.3,Fedora4,PC-BSD
Posts: 261

Original Poster
Rep: Reputation: 30
G'Day cb951303, Thanks for everything I am going try and print or copy your tutorial and give the first part ago & if that does not work I will try step 2 by reinstalling, I was also wrong about xorgconfig as I rebooted after I got the message about my kernel being tainted and got a immovable blank screen when typing startx so I rebooted again and got the same so I tried xorgconfig and tried some different options with my choices this time and was able to log back in with a better display than before , so i am at least happy about that, the video card I have is a GV-Nx66T128VP 6600 gt graghics accelarator , on a amd64 3200 . so I dont know if this has anything to do with anything even though I looked in the nvidia forum & noticed others had trouble with drivers for nvidia 6600 graghics cards .AnyWay
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA module problem - Slackware 10.1 & kernel 2.6.** Vizy Slackware 7 05-20-2005 09:58 AM
NVidia GeForce FX and vesafb does not restore from X11. Sijaiko Slackware 3 10-06-2004 07:18 AM
Nvidia driver & Mandrake 9 problem hiran Linux - Hardware 4 04-03-2004 09:12 PM
nVidia GeForce & LCD display problem Cazar Red Hat 5 01-30-2004 04:49 PM
X11 Nvidia crash sh0 Slackware 5 11-18-2003 04:16 AM


All times are GMT -5. The time now is 11:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration