LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-05-2008, 12:33 PM   #1
jpsatlinuxquestions
LQ Newbie
 
Registered: Dec 2007
Posts: 18

Rep: Reputation: 0
problem with nfsd and rpc.portmap


I have a problem with nfsd and rpc.portmap from a fresh install of Slack 12.1. The rpc.portmap segfaults when I try to mount a volume from another machine. I comment my procedure:

I begin to kill all the rpc daemons still running:

[pipeline:jp/]$ killall rpc.statd
[pipeline:jp/]$ killall rpc.rquotad
[pipeline:jp/]$ killall rpc.mountd
[pipeline:jp/]$ killall rpc.portmap
rpc.portmap: no process killed

I start nfsd:

[pipeline:jp/]$ /etc/rc.d/rc.nfsd start
Starting RPC portmapper: /sbin/rpc.portmap
Starting RPC NSM (Network Status Monitor): /sbin/rpc.statd
Starting NFS server daemons:
/usr/sbin/exportfs -r
/usr/sbin/rpc.rquotad
/usr/sbin/rpc.nfsd 8
/usr/sbin/rpc.mountd

The following line appears in /var/log/messages:

Aug 5 18:19:21 pipeline rpc.statd[3139]: Version 1.1.2 Starting

I see the daemons are running:

[pipeline:jp/]$ ps aux | grep -i rpc
root 1149 0.0 0.0 0 0 ? S< 17:54 0:00 [rpciod/0]
bin 3134 0.0 0.0 1804 484 ? Ss 18:19 0:00 /sbin/rpc.portmap
nobody 3139 0.0 0.0 1872 704 ? Ss 18:19 0:00 /sbin/rpc.statd
root 3144 0.0 0.0 2060 240 ? Ss 18:19 0:00 /usr/sbin/rpc.rquotad
root 3147 0.0 0.0 1976 288 ? Ss 18:19 0:00 /usr/sbin/rpc.mountd
root 3156 0.0 0.0 2236 788 pts/1 R+ 18:20 0:00 grep -i rpc

From another machine I try to mount a nfs volume.

I see in /var/log/messages the request and the segfault:

Aug 5 18:21:00 pipeline mountd[3147]: authenticated mount request from 192.168.1.3:936 for /mnt/commun/tmp (/mnt/commun/tmp)
Aug 5 18:21:00 pipeline kernel: rpc.portmap[3134]: segfault at 00000c3e eip 8000591c esp bff53724 error 4

and:

[pipeline:jp/]$ ps aux | grep -i rpc
root 1149 0.0 0.0 0 0 ? S< 17:54 0:00 [rpciod/0]
nobody 3086 0.0 0.0 1872 708 ? Ss 18:14 0:00 /sbin/rpc.statd
root 3091 0.0 0.0 2060 236 ? Ss 18:14 0:00 /usr/sbin/rpc.rquotad
root 3094 0.0 0.0 1976 752 ? Ss 18:14 0:00 /usr/sbin/rpc.mountd
root 3101 0.0 0.0 2236 788 pts/1 R+ 18:14 0:00 grep -i rpc

Any idea ?
 
Old 08-05-2008, 03:53 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,392
Blog Entries: 3

Rep: Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481
Hi,

You do have your '/etc/exports' and '/etc/hosts' files setup properly?
 
Old 08-05-2008, 04:20 PM   #3
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Just a suggestion but rather than all that process killing and starting services why don't you just try making an entry in /etc/exports for a directory to be exported. Make sure /etc/rc.d/rc.{nfsd,rpc} are both executable (looks like they are but just to be certain) and restart the machine.

OK you may just need to restart the services or perhaps just run exportfs -r to re-export your directories in /etc/exportfs. Rebooting will at least clear ou any oddness and restart everything.

On the server machine (the on exporting the directory) try /usr/sbin/exportfs to check the directory is being exported. Then you could try running "/usr/sbin/showmount -e ip_of_your_server" - on your client replacing the ip number where required to see that the client can see the exports. Then try mounting the export on a client box.

I'm not sure if this will make a difference but at least your server will be in a known state before trying the remote mount.

Last edited by bgeddy; 08-05-2008 at 04:23 PM.
 
Old 08-05-2008, 04:28 PM   #4
jpsatlinuxquestions
LQ Newbie
 
Registered: Dec 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
You do have your '/etc/exports' and '/etc/hosts' files setup properly?
I think so. The server is 192.168.1.1 and the client is 192.168.1.3.

On the server:
/etc/hosts:

127.0.0.1 localhost
192.168.1.1 pipeline.fr pipeline

/etc/exports:

/mnt/commun/tmp/ 192.168.1.3(rw,no_subtree_check)

/etc/hosts.deny is empty.

From the client, I mount the partition with:

mount -t nfs 192.168.1.1:/mnt/commun/tmp /mnt/pipeline/

The strange thing is that all was working in Slack 12 and I simply copy the files /etc/exports /etc/hosts /etc/hosts.deny from a backup...
 
Old 08-06-2008, 03:17 AM   #5
jpsatlinuxquestions
LQ Newbie
 
Registered: Dec 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bgeddy View Post
Just a suggestion but rather than all that process killing and starting services why don't you just try making an entry in /etc/exports for a directory to be exported. Make sure /etc/rc.d/rc.{nfsd,rpc} are both executable (looks like they are but just to be certain) and restart the machine.

OK you may just need to restart the services or perhaps just run exportfs -r to re-export your directories in /etc/exportfs. Rebooting will at least clear ou any oddness and restart everything.

On the server machine (the on exporting the directory) try /usr/sbin/exportfs to check the directory is being exported. Then you could try running "/usr/sbin/showmount -e ip_of_your_server" - on your client replacing the ip number where required to see that the client can see the exports. Then try mounting the export on a client box.

I'm not sure if this will make a difference but at least your server will be in a known state before trying the remote mount.
Sure. I just wanted to be sure I start from zero, that's why I kill all the deamons by hands.

Actually the /etc/exports contains:

/mnt/commun/tmp/ 192.168.1.3(rw,no_subtree_check)

The nfs server is just started at boot by /etc/rc.d/rc.nfsd

And the directory is exported:

[pipeline:~/]$ /usr/sbin/exportfs
/mnt/commun/tmp
192.168.1.3

But from the client:
[superman:~/]$ /usr/sbin/showmount -e 192.168.1.1
[superman:~/]$

It seems that the client can't see the server ! I have to prospect on this side I think...

Thanks for the tip.
 
Old 08-06-2008, 07:44 AM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,392
Blog Entries: 3

Rep: Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481
Hi,

Try 'exportfs -ra' to update the table.
 
Old 08-06-2008, 01:20 PM   #7
jpsatlinuxquestions
LQ Newbie
 
Registered: Dec 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,

Try 'exportfs -ra' to update the table.
pipeline is 192.168.1.1: server.
superman is 192.168.1.3: client.

Just to verify everything is ok:

[pipeline:jp/]$ /etc/rc.d/rc.nfsd stop
[pipeline:jp/]$ killall rpc.statd
[pipeline:jp/]$ killall rpc.rquotad
rpc.rquotad: no process killed
[pipeline:jp/]$ killall rpc.mountd
rpc.mountd: no process killed
[pipeline:jp/]$ killall rpc.portmap
rpc.portmap: no process killed

I begin to start nfs.:

[pipeline:jp/]$ /etc/rc.d/rc.nfsd start
Starting RPC portmapper: /sbin/rpc.portmap
Starting RPC NSM (Network Status Monitor): /sbin/rpc.statd
Starting NFS server daemons:
/usr/sbin/exportfs -r
/usr/sbin/rpc.rquotad
/usr/sbin/rpc.nfsd 8
/usr/sbin/rpc.mountd
[pipeline:jp/]$ /usr/sbin/exportfs
/mnt/commun/tmp
192.168.1.3
[pipeline:jp/]$

All seem ok on the server. Now from the client:

[superman:jp/]$ /usr/sbin/showmount -e 192.168.1.1
Export list for 192.168.1.1:
/mnt/commun/tmp 192.168.1.3
[superman:jp/]$

So the client sees the partition to mount. Try to mount the partition:

[superman:jp/]$ mount -v -t nfs 192.168.1.1:/mnt/commun/tmp /mnt/pipeline
mount.nfs: timeout set for Wed Aug 6 19:09:22 2008
mount.nfs: text-based options: 'addr=192.168.1.1'
mount.nfs: internal error
[superman:jp/]$

And then:

[superman:jp/]$ /usr/sbin/showmount -e 192.168.1.1
[superman:jp/]$

The client does not see anymore the server. But the server continues to
export:

[pipeline:jp/]$ /usr/sbin/exportfs
/mnt/commun/tmp
192.168.1.3
[pipeline:jp/]$

There is really something I don't understand here...
 
Old 08-06-2008, 02:17 PM   #8
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Odd - I'd try reinstalling nfs-utils and possibly portmap packages from known good media to rule any any problems with the installed packages.

http://slackware.osuosl.org/slackwar...1.2-i486-1.tgz

and

http://slackware.osuosl.org/slackwar...6.0-i486-1.tgz

are links you may use if you suspect your install discs may be damaged or in some way faulty.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFSd fails to start due to RPC? TexasDex Linux - Software 10 03-23-2010 03:02 AM
Having issues with nfs/rpc/portmap... hollywoodb Linux - Networking 2 04-28-2007 09:08 PM
How can I configure iptables to allow portmap (rpc services) dirtgod Linux - General 1 12-16-2006 04:51 AM
Portmap and RPC in RHL8 Gabriel2010 Linux - Newbie 3 08-19-2004 02:06 PM
NFS Portmap: RPC: Program not registered fibbi Linux - Software 2 08-12-2004 01:40 AM


All times are GMT -5. The time now is 09:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration