-   Slackware (
-   -   Problem with Midori on Slackwarearm-14.0 (

brianL 01-28-2013 04:07 PM

Problem with Midori on Slackwarearm-14.0
I've installed Midori (ponce's package) on my Rasberry Pi. When I clicked on the menu entry (in xfce), Midori opened briefly then disappeared. So I tried it from the terminal, and got this:

bash-4.2$ midori
The configuration couldn't be loaded: No such file or directory
Segmentation fault

It opened briefly before the "Segmentation fault" line appeared.

ponce 01-29-2013 12:36 AM

maybe I know why: I have to rebuild the webkitgtk package with --disable-jit

EDIT: I'm building with no distcc or anything so it will need something like 36 hours. ;)

brianL 01-29-2013 03:04 AM

Thanks, ponce, there's no rush. I thought you'd be cross-compiling?

ponce 01-29-2013 03:22 AM

I'm trying to be as vanilla as possible (other people will probably build their stuff this way) and so I do straight builds on the target.

brianL 01-29-2013 03:26 AM

Ah, I see. You must be a very patient man. :hattip: :)

brianL 01-30-2013 05:51 AM

Half on and half off topic :)
Just installed all your LXDE stuff on my Pi. Very nice. Yet another :hattip: .

ponce 01-30-2013 02:54 PM

I can confirm that with this webkitgtk package midori don't crash ;)

brianL 01-30-2013 04:44 PM

Thanks, I upgrade to that next time I have Slack on my Pi. Messing about with Arch at the moment. It's OK but I prefer Slack.

brianL 01-31-2013 04:17 AM

First of all, the new webkitgtk and midori working OK. Thanks again.
Second. The link in your post above didn't work, so I went to your repository. Clicking on the link gave this ( LOL):

ponce 01-31-2013 04:19 AM

yes, because I forgot I used 2 as build number for this new package :D

All times are GMT -5. The time now is 09:15 PM.