LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-20-2009, 11:41 AM   #1
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 89
Problem with kqemu in slackware64-current since 2.6.29.5 kernel


Hi to all,

Since I upgraded my kernel do 2.6.29.5 in Slackware64 I cannot get the (newly compiled) kqemu module to load. It gives:
Quote:
FATAL: Error inserting kqemu (/lib/modules/2.6.29.5-custom64/misc/kqemu.ko): Invalid module format
I use the Slackbuild script slackbuilds.org. It worked fine with 2.6.29.4 and still works on 2.6.29.5 on slackware-current (32-bits) on another machine.

Any idea where to look for an answer? Googling just told me to check the header files, but all is there.
 
Old 06-20-2009, 11:46 AM   #2
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Just out of curiosity, what format are all the normal modules in? I know the installer a while back had them all in *.ko.gz. I haven't updated yet, so I don't know.
 
Old 06-20-2009, 12:01 PM   #3
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
You can try /sbin/modinfo on the module and check the vermagic version reported. Apparently this has to match the kernel when trying to load the module.
 
Old 06-20-2009, 05:27 PM   #4
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Original Poster
Rep: Reputation: 89
@bgeddy: Thanks, you showed me the light

I had compiled this custom kernel on June 18th, between the two updates of the kernel-headers package.
I just compiled a new kernel, recompiled kqemu and everything is fine again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware64 -current made public! bsdunix Slackware 289 06-19-2009 01:15 AM
Slackware64-Current / slackpkg slackass Slackware 31 06-06-2009 11:51 PM
[SOLVED] what's that directory (slackware64-current) sycamorex Slackware 3 05-30-2009 10:03 AM
Slackware64 -current and KDE mlangdn Slackware 7 05-29-2009 09:57 AM
Kernel-kqemu installed, /dev/kqemu not found Pikidalto Linux - Software 0 05-10-2008 07:34 AM


All times are GMT -5. The time now is 11:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration