LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem with Konsole profile settings after upgrading to KDE 4.10 (http://www.linuxquestions.org/questions/slackware-14/problem-with-konsole-profile-settings-after-upgrading-to-kde-4-10-a-4175450466/)

nando321 02-16-2013 03:46 PM

Problem with Konsole profile settings after upgrading to KDE 4.10
 
Hey there, I've been looking around the internet about this problem and I've found nothing that may point out to a solution. The thing is that since I upgraded this afternoon the KDE version to 4.10 in Slackware 14 I haven't been able to start konsole as a normal user, it always starts as root with this output:
Quote:

bash-4.2$
Instead of e.g.: username@hostname
I hope someone has had this problem before and that could manage to fix it.
AND I hope to get some answer here since one of the last times I asked for help in this forum nobody could give an answer, at least a "there's nothing that may be done".
Anyway no offense meant, indeed. Thanks.

Alien Bob 02-16-2013 05:04 PM

It does not start as root. The prompt's ending character "$" indicates a user prompt. For root that will be a "#".

What you experience is that konsole starts a normal shell, not a login shell. You would see a "username@hostname:" prompt only in a login shell.

Easily adjusted though: Go to "Settings > Manage Profiles > Edit Profile > General" and then replace "bash" with "bash -l" in the "Command" entry field.

Eric

nando321 02-16-2013 06:48 PM

I like that, straight to the point and the solution. The "/bin/bash -l" did the job. Thanks and now it is marked as solved.

_toudi_ 02-21-2013 10:10 AM

same goes for any other shell you want to make it a login shell
e.g. if it's tcsh your Command should be: /bin/tcsh -l

Alien Bob 02-21-2013 11:59 AM

Quote:

Originally Posted by _toudi_ (Post 4896771)
same goes for any other shell you want to make it a login shell
e.g. if it's tcsh your Command should be: /bin/tcsh -l

... but that was not the question here. Irrelevant post.

Eric

_toudi_ 02-22-2013 03:16 AM

to the contrary my dear AlienBOB :)
many people will have this Konsole problem and find nando321's post but if they use other shells than bash they won't know what to do! thanks to my post they will know what to do no matter what shell they use :)

Mike_M 02-22-2013 11:51 AM

I would hazard a guess that if a user has changed shells from the default of bash then they are likely aware of which shell they use. Additionally, not all shells support the '-l' option, making your advice not quite as universal as you believe.

_toudi_ 02-25-2013 03:57 AM

and again I have to disagree :) because the people who have this Konsole problem are using either tcsh (csh) bash (sh) and the solution works for them if they used zsh for example they wouldn't have this problem and come looking for help here :)
maybe most of ppl who use tcsh are able to figure out the solution by themselves but it's possible that not all of them :) if you can guarantee all of them can I will delete my post :)

Alien Bob 02-25-2013 05:05 AM

My god, you wasted 3 out of your total of 5 posts at LQ to this crap yes/no pissing contest? Move on to meaningful discussions please.

Eric

GazL 02-25-2013 05:27 AM

The correct fix for this "problem" is setting the prompt string in an appropriate place. Of course, bash makes this awkward by not supporting a system wide bashrc, and Pat can be forgiven for deciding to set it in /etc/profile given this fact, but the tcsh/c-shell developers made no such mistake and provide an /etc/csh.cshrc from where the prompt may be set..

Changing the terminal emulator to run a 'login shell' is IMO a case of two wrongs making a right - only with potentially unwanted side effects.

cynwulf 02-25-2013 05:52 AM

konsole was showing a user@hostname with path prompt before upgrading from KDE 4.9.5 to 4.10 and is still showing one now.

Other terminal emulators have always shown the bash-<version> prompt (13.37 was the same). I've never bothered to fix them as I use konsole exclusively.


All times are GMT -5. The time now is 09:58 PM.