LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-24-2012, 02:51 AM   #1
jrhorn424
LQ Newbie
 
Registered: Oct 2011
Location: Virginia
Posts: 20

Rep: Reputation: Disabled
Exclamation Problem with HDMI audio


I've read close to thirty threads through Google on this problem. At one point, audio was working when played through Amarok, but no sound at all came from my browser. After reading a few dozen threads trying to troubleshoot that problem, I decided to restart the whole process using 'alsaconf', while manually adding my card to the database before configuring.

'lspci -nn | grep Audio':
Code:
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
01:00.1 Audio device [0403]: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series] [1002:aa68]
You'll note that's an onboard chip and a video card with HDMI output. I'd like to avoid blacklist/disabling the onboard chip just to get audio to work, since this is an annoying puzzle on a hobby machine.

'lspci -v':
Code:
### snip ###
[01:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
        Subsystem: ASUSTeK Computer Inc. Device aa68
        Flags: bus master, fast devsel, latency 0, IRQ 40
        Memory at fdffc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [150] Advanced Error Reporting
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
### snip ###
'dmesg | grep HDA':
Code:
[    7.728058] HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    7.808189] HDA Intel 0000:01:00.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[    7.811650] HDA Intel 0000:01:00.1: irq 40 for MSI/MSI-X
[    7.811668] HDA Intel 0000:01:00.1: setting latency timer to 64
'aplay -l':
Code:
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
'cat /etc/modprobe.d/sound.conf # created by alsaconf':
Code:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.24.2 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---
Sometimes piping sound directly to the device works.
Code:
root@polaris:/home/jrhorn424# aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav 
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
But, then opening Amarok cues KDE to tell me it thinks the Generic device (the HDMI device) has been removed. No sound from Amarok when playing music, since it falls back to the onboard sound chip instead of using the strange, disappearing device.

Any ideas?

Code:
# uname -r -p   
2.6.37.6 AMD Six-Core Processor

Last edited by jrhorn424; 01-24-2012 at 02:54 AM.
 
Old 01-25-2012, 12:07 PM   #2
NeoMetal
Member
 
Registered: Aug 2004
Location: MD
Distribution: Slackware
Posts: 105

Rep: Reputation: 19
I managed to get my HDMI audio working (Radeon HD57xx) working from the instructions posted here:
http://crunchbanglinux.org/forums/to...nd-working-in/

Some media players I had to manually go in the settings and tell them what device to use as the default. Browser (I use opera) sound worked immediately after I went through the method in the link. I believe I might have had to take an extra step to get the settings to stick on reboots - If I can remember I'll edit this post with it. Theres no software master vol. for alsa with HDMI audio so you have to use the volume controls in whatever player you are using.
 
1 members found this post helpful.
Old 01-25-2012, 12:31 PM   #3
jrhorn424
LQ Newbie
 
Registered: Oct 2011
Location: Virginia
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
I managed to get my HDMI audio working (Radeon HD57xx) working from the instructions posted here:
http://crunchbanglinux.org/forums/to...nd-working-in/
Thanks, but that didn't help too much. I know about .asoundrc but I shouldn't need one as far as I can tell. I did use the rc file at one point, along with a really weird masking line in my modules.d/sound.conf file, but I didn't get any audio in browser.
 
Old 01-25-2012, 03:33 PM   #4
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 301

Rep: Reputation: 51
Quote:
Originally Posted by jrhorn424 View Post
Thanks, but that didn't help too much. I know about .asoundrc but I shouldn't need one as far as I can tell. I did use the rc file at one point, along with a really weird masking line in my modules.d/sound.conf file, but I didn't get any audio in browser.
How do you tell the browser to use your HDMI card 1 when HDA ATI SB card 0 is set as your default? I cannot see another solution than using a .asoundrc file...

Are you sure that you made a properly .asoundrc file?

Last edited by Bindestreck; 01-25-2012 at 03:35 PM.
 
Old 01-25-2012, 03:43 PM   #5
jrhorn424
LQ Newbie
 
Registered: Oct 2011
Location: Virginia
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
How do you tell the browser to use your HDMI card 1 when HDA ATI SB card 0 is set as your default? I cannot see another solution than using a .asoundrc file...
I used the modprobe.d/sound.conf file to force the HDMI in to card 0. I'll try doing that again later this evening and update the thread if it works.
 
Old 01-25-2012, 03:50 PM   #6
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 301

Rep: Reputation: 51
And how do you do that when the modules for card 0 and card 1 are the same (same name) ?

Try issue:

cat /proc/asound/modules

if the modules show same name you cannot use sound.conf because I do not think it can distinct between modules of same name.

Last edited by Bindestreck; 01-25-2012 at 03:51 PM.
 
Old 01-25-2012, 04:29 PM   #7
jrhorn424
LQ Newbie
 
Registered: Oct 2011
Location: Virginia
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by eXpander_ View Post
And how do you do that when the modules for card 0 and card 1 are the same (same name) ?
That's a good point. I was used something like 'option snd-hda-intel index=1'. To be honest, I tried so many different things on Monday that I might have had that in my sound.conf, which does force the correct card into slot 0 by the way, as well as a system-wide asoundrc. Again, even when everything was working in linux, and even when the HDMI was listed as card 0 in 'aplay -l', I didn't have sound in either Chrome or Firefox.

I'm going to try a handful of solutions later that I stumbled across earlier and post back with an update.
 
Old 01-26-2012, 08:05 PM   #8
jrhorn424
LQ Newbie
 
Registered: Oct 2011
Location: Virginia
Posts: 20

Original Poster
Rep: Reputation: Disabled
eXpander_ was on to something. I reissued alsaconf to get a clean /etc/modprobe.d/sound.conf file, deleted all other sound.conf files (I had a couple backups sitting in there... pretty dumb since every file in that directory gets read...), and deleted .asoundrc and /etc/asound.conf. This is as-close to a typical configuration I could get without reinstalling.

I tried several combinations of the advice I found earlier this week. I noted that adding 'options snd-hda-intel index=1' in /etc/modprobe.d/sound.conf worked to force the second card (card1) into the first slot (card0), but it caused some problems during boot and the device didn't end up being configured correctly, so I kept the clean sound.conf file.

Adding the following to .asoundrc worked, so I moved it over to /etc/asound.conf.
Code:
pcm.!default {
    type hw
    card 1
    device 3
}
The 'device 3' line isn't really necessary. That achieved a bit, allowing Amarok to play correctly. However, 'aplay' didn't work from the command line without specifying a device (plughw:1,3). And, as I feared no sound in firefox or chrome. I tried re-installing the flash plugin, checking permissions, and all the usual stuff to no avail.

Next, I blew away the /etc/asound.conf (though I left modprobe.d/sound.conf intact) and disabled the onboard sound chip in BIOS. When I rebooted, the only device found was the device I wanted to use, and of course it was listed as card0. Still no love with firefox, so I'm pretty confident it isn't the "flash can't use non-default sound cards" bug.

I'm pretty stumped.
 
Old 01-27-2012, 01:28 AM   #9
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 301

Rep: Reputation: 51
How does your clean /etc/modprobe.d/sound.conf look like? What if you ignore sound.conf completely (deleting it) and only using .asoundrc?

What version of ALSA do you have? If you use ALSA 1.0.23, try upgrading to 1.0.24.

Other than that, I have no clue.

Last edited by Bindestreck; 01-27-2012 at 01:29 AM.
 
Old 02-07-2012, 08:00 PM   #10
santibon
LQ Newbie
 
Registered: Feb 2012
Location: Mesa Az
Distribution: Ubuntu 10.4
Posts: 1

Rep: Reputation: Disabled
I am in the same boat...

I have the same exact issue! I have been trying to solve it as well. I was able to listen to the sound via HDMI on my browser. We use the browser to stream most of the TV we watch. I was trying to get the mic to work, and was following this link's instructions:

https://help.ubuntu.com/community/So...otingProcedure

but now, my mic still doesnt work, AND the sound from my browsers are only playing on laptop speakers, however if i play a .wav the sound does come through my TV via the HDMI... it is so odd. Any Suggestions?

Let me know if you would like any of my info, and we can compare.
 
Old 10-27-2012, 12:07 AM   #11
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
Quote:
Originally Posted by NeoMetal View Post
I managed to get my HDMI audio working (Radeon HD57xx) working from the instructions posted here:
http://crunchbanglinux.org/forums/to...nd-working-in/

Some media players I had to manually go in the settings and tell them what device to use as the default. Browser (I use opera) sound worked immediately after I went through the method in the link. I believe I might have had to take an extra step to get the settings to stick on reboots - If I can remember I'll edit this post with it. Theres no software master vol. for alsa with HDMI audio so you have to use the volume controls in whatever player you are using.
This is an old thread, but I have been searching forever, it never occured to me that VLC would have it's own setting for the device. Thank you so much.
 
  


Reply

Tags
alsa, alsaconf, audio, hdmi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HDMI audio on puppy rojalq Puppy 6 05-29-2012 07:13 AM
[SOLVED] no HDMI audio in Linux dimm0k Linux - Hardware 34 02-21-2012 08:30 PM
HDMI Audio doesn't work - Debian Squeeze (Intel HDMI) felipefv Linux - Hardware 8 02-06-2012 09:47 AM
HDMI Audio with 12.2 Woodsman Slackware 27 09-04-2009 10:53 PM
Audio through HDMI Cable? Jeff91 Linux - Hardware 7 06-26-2009 09:44 AM


All times are GMT -5. The time now is 09:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration