LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-20-2012, 03:44 PM   #1
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
Problem with elilo and uefi on Asus rampage 4


I am building a new machine and I'm not exactly sure what is happening. I followed ruario's how-to on docs.slackware for elilo using a USB stick. Everything works and it installs. The problem I'm having is that the system partition on the hard drive doesn't get picked up as uefi. The USB stick does and boots perfectly. I've even repartitioned and mimicked the exact layout of the USB stick on the hard drive and the machine still isn't seen as uefi ready. I'm stumped and not sure what to do here?
 
Old 10-20-2012, 06:35 PM   #2
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Rep: Reputation: Disabled
Is the hard drive with Slackware formatted with a GUID Partition Table (GPT) or MBR partition table?
 
Old 10-20-2012, 06:43 PM   #3
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
I used gdisk. The system partition is type ef00 formatted fat. It contains elilo, elilo.conf, the huge kernel. The USB stick I used to do the install is set up the same way, but also has the initrd from the installer. Like I said I also tried to set it up just like the install stick. The USB stick is seen as uefi, but nothing wil get the HD to be seen that way?
 
Old 10-20-2012, 09:47 PM   #4
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
Well I'm pretty confused at this point. Somehow, after 93749237423 attempts to get anything other than a USB stick to boot, I have GPT partitioned disk, that the system doesn't see as UEFI, and LILO somehow managed to install to the MBR after God only knows how many failed attempts. I have no idea what exactly happened here. It booted, but I would really like to know what's going on here...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lilo x elilo x grup2 x UEFI afreitascs Slackware 5 09-09-2012 11:55 AM
Help Creating UEFI A MENU For My Bootable (BIOS/UEFI) CDROM ssenuta Linux - Hardware 0 08-27-2012 10:11 PM
UEFI PXE server elilo.conf configuration miszum Linux - Networking 2 08-05-2011 12:31 PM
No audio on Asus Rampage with Supreme FX II card jiffypop Linux - Hardware 1 03-05-2011 02:32 AM
Does ASUS RAMPAGE FORMULA (LGA 775 Intel X48) Motherboard Run Linux Well? xp_newbie Linux - Hardware 0 06-06-2008 07:07 PM


All times are GMT -5. The time now is 08:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration