LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem with elilo and uefi on Asus rampage 4 (http://www.linuxquestions.org/questions/slackware-14/problem-with-elilo-and-uefi-on-asus-rampage-4-a-4175433264/)

damgar 10-20-2012 02:44 PM

Problem with elilo and uefi on Asus rampage 4
 
I am building a new machine and I'm not exactly sure what is happening. I followed ruario's how-to on docs.slackware for elilo using a USB stick. Everything works and it installs. The problem I'm having is that the system partition on the hard drive doesn't get picked up as uefi. The USB stick does and boots perfectly. I've even repartitioned and mimicked the exact layout of the USB stick on the hard drive and the machine still isn't seen as uefi ready. I'm stumped and not sure what to do here?

TommyC7 10-20-2012 05:35 PM

Is the hard drive with Slackware formatted with a GUID Partition Table (GPT) or MBR partition table?

damgar 10-20-2012 05:43 PM

I used gdisk. The system partition is type ef00 formatted fat. It contains elilo, elilo.conf, the huge kernel. The USB stick I used to do the install is set up the same way, but also has the initrd from the installer. Like I said I also tried to set it up just like the install stick. The USB stick is seen as uefi, but nothing wil get the HD to be seen that way?

damgar 10-20-2012 08:47 PM

Well I'm pretty confused at this point. Somehow, after 93749237423 attempts to get anything other than a USB stick to boot, I have GPT partitioned disk, that the system doesn't see as UEFI, and LILO somehow managed to install to the MBR after God only knows how many failed attempts. I have no idea what exactly happened here. It booted, but I would really like to know what's going on here...


All times are GMT -5. The time now is 03:38 PM.