LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem With Display Screen Frequency (Hz) (http://www.linuxquestions.org/questions/slackware-14/problem-with-display-screen-frequency-hz-272853/)

Xavius 01-02-2005 04:56 AM

problem with the Display Screen Frequency (Hz)
 
Using Slackware 10.0 in the
Desktop Settings => Display
In the Screen panel, I could choose the framerate beetween 60 or 85 Hz.
Using the 85 value no problem. So it was my choice.

Now I'm using Slackware Current and in the Screen panel I could choose the framerate beetween 60 or 87 Hz.
But using the 87 value the screen is messed up. Seems this value is too high for my videocard/monitor.

60 Hz is too low, and after some time in front of monitor the difference (eyes tireness) is a problem.

The problem is there is NO 85 value. I can choose only beetween 60 or 87......

- How can I solve this? I want only use 85 as Hz option....... it was there in Slack 10 so I don't understand where is gone :rolleyes:

- An X.org downgrade to Slackware 10 version (if there are different version in 10 and Current) can solve this?

xushi 01-02-2005 05:03 AM

Out of curiosity, what brand/model and screen size is your monitor?

Xavius 01-02-2005 05:17 AM

my monitor is a Packard Bell one, 17 inchs. I think the model is 1720 or A1720 but I'm not sure about this.

btw monitor, videocard and drivers were the same with Slackware 10, so I cannot understans why there isn't the 85 value.........

and if teorically my system can support 87 Hz, how can I use 85 Hz instead?

P.S. trying and mumbling (= thinking and thinking... a lot!) I have done some test with some Linux Live distro..... Knoppix, Gnoppix and Slax. All have and use the 85 Hz value and there are NO problems........

Xavius 01-02-2005 07:07 AM

how can I "freely" change the screen refresh frequency?
 
Using the menu, I can choose the display refresh (Hz) only beetween 60 Hz or 87 Hz

60 Hz is too low but 87 seems too high for my hardware.

Usually, with other distro, I can choose the 85 value, that works ok.

How can I set the refresh frequency to my favourite value?
there should be something editing files, in the menu or similar, but I don't know

egag 01-02-2005 07:28 AM

well...just boot the Slax-cd, remount a partition as r/w, and copy the xorg.conf-file
to the hd to replace the conf-file you used.

or just edit the one you've got with the slax-file as example.

egag

JunctaJuvant 01-02-2005 07:31 AM

What menu? What distro? Being specific helps.
In any case, you should be able to edit that in the appropriate section of /etc/X11/xorg.conf (or whatever smells like an X configuration file on your system).

Xavius 01-02-2005 07:32 AM

Do you think it's only a configuration problem?

not some issue with X.org or something else..... I hope so. I will try and post here the results.

vharishankar 01-02-2005 08:04 AM

You'll have to manually edit the XF86config file to include this frequency you desire also in that section "Monitor"

If that doesn't work run xf86config and try forcing the refresh setting to 85 Hz. Although most modern monitors come with in-built protection, so if the frequency is bad then you can restore the old setting, be careful to be sure that you monitor supports 85 Hz before you try this. You never know.

Xavius 01-02-2005 08:17 AM

I'm using Slackware Current. And in my first post i war referring to KDE Desktop Preferences menu.

In Windows, Slackware 10 and other Linux distro there was the 85 value in the preferences, so I think I can use this value in Slackware Current too, if I know how add and choose it.

vharishankar 01-02-2005 08:21 AM

Run xf86config or edit the XF86Config-4 or XF86Config file manually.

It can be found in
Code:

/etc/X11/
folder.

slackie1000 01-02-2005 08:29 AM

Quote:

Originally posted by Harishankar
Run xf86config or edit the XF86Config-4 or XF86Config file manually.

It can be found in
Code:

/etc/X11/
folder.

hi there,

just to clarify, slackware current uses Xorg.
he should look for xorgsetup and xorg.conf

regards

slackie1000


[edit] ok, i saw now. this is a kind of double post. the words are not same but the content is quite similar. copy in slackware. this thread will be reported.

vharishankar 01-02-2005 08:31 AM

EDIT:

Sorry. I didn't know about Xorg in Slackware. I use Debian :)

JunctaJuvant 01-02-2005 08:35 AM

Personally, I think manually editing xorg.conf is the easiest option. I'd edit the section as Harishankar posted and also see "man xorg.conf" for an overview of al the sections you can edit.
Hope that helps.

Xavius 01-02-2005 09:05 AM

in the xorg.conf file the default string is "VertRefresh 40-90"

changing this to "VertRefresh 40-85" is not good because the Desktop Preferences, in KDE, show only 60 for Hz........

so I changed it in ""VertRefresh 85" to force the system to use 85 Hz..........
the result is that system use 85 Hz but the resolution is 640x480....... and cannot be adjusted (I can change it to lower resolutions like 400x300 but not to highers)

What's going on?

maybe the system doesn't know my monitor.... how can I setup it correctly? whats strings should I add/change?

NOTE for LinuxQuestions Mod: I thinked wich my post in Slackwware subsection was in some way... too complicated.... I will thinking a lot os possibilities and my post was a bit confusing..... so I rewroted it in a simpler way in the General section If I have broken some forum rule I'm sorry, I will write in the post in Slackware section telling is not necessary to reply to that post..... or, mods, you can block/remove that post I thinked wich my post in Slackwware subsection was in some way... too complicated.... I will thinking a lot os possibilities and my post was a bit confusing..... so I rewroted it in a simpler way in the General section

XavierP 01-02-2005 09:16 AM

Xavius - I have merged your two extremely similar threads together.


All times are GMT -5. The time now is 09:20 AM.