LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-03-2013, 06:04 AM   #1
Kangatux
LQ Newbie
 
Registered: May 2013
Posts: 8

Rep: Reputation: Disabled
Problem with choosing sound device


I've now installed Slackware64 14 on my Sony Vaio laptop. I have three sound cards (or what are recognised as sound cards anyway): internal, HDMI and external USB speakers.

The problem is that the sound is not directed into my external USB speakers in most cases, but instead goes through the in-built ones in my laptop. I've tried rectifying this in KDE system settings, by setting the USB as the preferred driver in phonon, but it still doesn't work - chrome, opera, mplayer and others default to the inbuilt speakers.

I know the speakers work fine, since audacious directs sound through them nicely.
 
Old 05-03-2013, 06:46 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Try:
http://docs.slackware.com/howtos:har...s_on_slackware
Or:
http://www.linuxquestions.org/questi...3/#post4836458
 
Old 05-03-2013, 11:54 AM   #3
Kangatux
LQ Newbie
 
Registered: May 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
I did both of those, but now that I rebooted my system the USB sound card isn't loaded at all by ALSA. Using "lsmod | grep snd" I can see it's loaded into the system anyway...
 
Old 05-03-2013, 12:34 PM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Try doing just the second recommendation then and undo the first.
 
Old 05-12-2013, 04:18 AM   #5
Kangatux
LQ Newbie
 
Registered: May 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by H_TeXMeX_H View Post
Try doing just the second recommendation then and undo the first.
Okay, just doing the second made alsa not load the usb sound card at all. And I think the problem with the first method is that the usb card is assigned to a different hw ?,0 value each time I start the system. Can that be fixed?
 
Old 05-12-2013, 04:48 AM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Can you post the output of
Code:
cat /proc/asound/modules
 
Old 05-12-2013, 05:44 AM   #7
Kangatux
LQ Newbie
 
Registered: May 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by H_TeXMeX_H View Post
Can you post the output of
Code:
cat /proc/asound/modules
bash-4.2$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_audio
 
Old 05-12-2013, 06:05 AM   #8
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
So have you tried putting this in '/lib/modprobe.d/sound.conf'

Code:
options snd_usb_audio index=0
options snd_hda_intel index=1
And then run '/etc/rc.d/rc.alsa' or reboot.
 
Old 05-12-2013, 06:17 AM   #9
Kangatux
LQ Newbie
 
Registered: May 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by H_TeXMeX_H View Post
So have you tried putting this in '/lib/modprobe.d/sound.conf'

Code:
options snd_usb_audio index=0
options snd_hda_intel index=1
And then run '/etc/rc.d/rc.alsa' or reboot.
Well, I put:

Code:
options snd_usb_audio index=0
options snd_hda_intel index=1
options snd_hda_intel index=2
And then I rebooted, which led to the usb card not being loaded at all by alsa.
 
Old 05-12-2013, 06:42 AM   #10
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I guess the next thing I would try is blacklisting 'snd_hda_intel'.
 
Old 05-21-2013, 04:29 PM   #11
Kangatux
LQ Newbie
 
Registered: May 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
Well, it seems the problem is finally solved! I managed to get the usb speakers loaded as card 2 every time by not starting them until after the system has loaded; seeing as they now are permanently loaded as hw 2,0, I put the following into ~/.asoundrc:

Code:
   pcm.!default {
        type hw
        card 2
        device 0
   }
   ctl.!default {
        type hw
        card 2
        device 0
   }
Thanks for all the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Writing Linux driver - choosing a device mjm Programming 2 05-03-2011 04:35 AM
sound device problem warun Slackware 1 10-16-2007 11:12 AM
sound device problem munna_dude Linux - Networking 4 06-23-2007 12:32 AM
problem with sound device in skype nass Slackware 2 01-13-2007 04:45 PM
sound device problem!!! prozac Linux - Software 3 11-30-2005 08:03 AM


All times are GMT -5. The time now is 02:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration