LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem with choosing sound device (http://www.linuxquestions.org/questions/slackware-14/problem-with-choosing-sound-device-4175460551/)

Kangatux 05-03-2013 06:04 AM

Problem with choosing sound device
 
I've now installed Slackware64 14 on my Sony Vaio laptop. I have three sound cards (or what are recognised as sound cards anyway): internal, HDMI and external USB speakers.

The problem is that the sound is not directed into my external USB speakers in most cases, but instead goes through the in-built ones in my laptop. I've tried rectifying this in KDE system settings, by setting the USB as the preferred driver in phonon, but it still doesn't work - chrome, opera, mplayer and others default to the inbuilt speakers.

I know the speakers work fine, since audacious directs sound through them nicely.

H_TeXMeX_H 05-03-2013 06:46 AM

Try:
http://docs.slackware.com/howtos:har...s_on_slackware
Or:
http://www.linuxquestions.org/questi...3/#post4836458

Kangatux 05-03-2013 11:54 AM

I did both of those, but now that I rebooted my system the USB sound card isn't loaded at all by ALSA. Using "lsmod | grep snd" I can see it's loaded into the system anyway...

H_TeXMeX_H 05-03-2013 12:34 PM

Try doing just the second recommendation then and undo the first.

Kangatux 05-12-2013 04:18 AM

Quote:

Originally Posted by H_TeXMeX_H (Post 4944269)
Try doing just the second recommendation then and undo the first.

Okay, just doing the second made alsa not load the usb sound card at all. And I think the problem with the first method is that the usb card is assigned to a different hw ?,0 value each time I start the system. Can that be fixed?

H_TeXMeX_H 05-12-2013 04:48 AM

Can you post the output of
Code:

cat /proc/asound/modules

Kangatux 05-12-2013 05:44 AM

Quote:

Originally Posted by H_TeXMeX_H (Post 4949424)
Can you post the output of
Code:

cat /proc/asound/modules

bash-4.2$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_audio

H_TeXMeX_H 05-12-2013 06:05 AM

So have you tried putting this in '/lib/modprobe.d/sound.conf'

Code:

options snd_usb_audio index=0
options snd_hda_intel index=1

And then run '/etc/rc.d/rc.alsa' or reboot.

Kangatux 05-12-2013 06:17 AM

Quote:

Originally Posted by H_TeXMeX_H (Post 4949448)
So have you tried putting this in '/lib/modprobe.d/sound.conf'

Code:

options snd_usb_audio index=0
options snd_hda_intel index=1

And then run '/etc/rc.d/rc.alsa' or reboot.

Well, I put:

Code:

options snd_usb_audio index=0
options snd_hda_intel index=1
options snd_hda_intel index=2

And then I rebooted, which led to the usb card not being loaded at all by alsa.

H_TeXMeX_H 05-12-2013 06:42 AM

I guess the next thing I would try is blacklisting 'snd_hda_intel'.

Kangatux 05-21-2013 04:29 PM

Well, it seems the problem is finally solved! I managed to get the usb speakers loaded as card 2 every time by not starting them until after the system has loaded; seeing as they now are permanently loaded as hw 2,0, I put the following into ~/.asoundrc:

Code:

  pcm.!default {
        type hw
        card 2
        device 0
  }
  ctl.!default {
        type hw
        card 2
        device 0
  }

Thanks for all the help :)


All times are GMT -5. The time now is 07:28 PM.