LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-07-2009, 08:09 PM   #1
Geraldsmod
Member
 
Registered: Sep 2009
Posts: 46

Rep: Reputation: 15
Problem with audio after removing speakers.


Well, I was using my computer 1 night and the sound settings worked perfectly.
Then my speakers decided to go off at FULL BLAST in the middle of the night when the computer was OFF. ...woke my whole family up...
So after I was done being scared shitless, I ripped the Surge Protector out of the wall and my computer was unplugged for the rest of the night.

Next morning, I got rid of the demon speakers and unpluged them from everything.

This is where the problem occurred.

When I had the speakers in, I could see the following output devices in System Settings -> Multimedia:
Logitech Premium Stereo USB headset 350
HDA Intel (ALC888 Analog)
(There are more but I don't think they're important)


Now, when I first log in, the list of output devices are:
Audio Output:
Esound (ESD)
ALSA default output
OSS default output
Audio Capture:
(Nothing at all)


Then if I run Amorak, a message pops up saying:
Removed Sound Devices
KDE detected that 1 or more internal sound devices were removed
This is the list of devices KDE thinks can be removed:
Output: HDA ATI HDMI, ATI HDMI (HDMI Audio Output)

Yes No Manage Devices

After I click manage devices, I see that all of my headset information comes back. Now Amorak will play the audio through the headset (Like I want it to) but when I try just about any other program (Firefox), audio does not work.

How can I fix it so the headset always stays in the list like before?

Last edited by Geraldsmod; 09-07-2009 at 09:50 PM.
 
Old 09-07-2009, 09:51 PM   #2
Geraldsmod
Member
 
Registered: Sep 2009
Posts: 46

Original Poster
Rep: Reputation: 15
This is a really annoying problem.
Can anybody help me?
 
Old 09-08-2009, 03:08 PM   #3
Geraldsmod
Member
 
Registered: Sep 2009
Posts: 46

Original Poster
Rep: Reputation: 15
bump. Anybody??
 
Old 09-08-2009, 03:15 PM   #4
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
I suspect people are too scared to help, after all you seem to have a computer that is possessed. I would like to point out that it is impossible for a computer to turn itself on and carry out an independent action. You must of had it on standby, or wake on-lan or something. However that is besides the point. try running the old alsaconfig, alsamixer, alsactl store as root and see if that exorcises your deamon.

samac
 
Old 09-08-2009, 03:16 PM   #5
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
I gotta ask: What was blasting out of the speakers while the machine was OFF?? Hopefully not something like a backwards Ozzy Oz recording

Anyhow, I'd be looking at the ALSAmixer settings, especially of your motherboard has automatic jack sensing. The automatic jack sensing might be acting up, and/or not working properly depending on the exact level of support for your hardware by the ALSA driver and other ALSA software installed on the machine.

Maybe look at ALSAMIXER, play with the settings, and see if you can get some semblance of normalcy that way. Also, please tell us what distro you're running, and which version of the ALSA packages, AND what motherboard you're running.

Thanks,
Sasha
 
Old 09-08-2009, 04:34 PM   #6
Geraldsmod
Member
 
Registered: Sep 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Well I found out today that the speakers power surged and made them go off. It was like a solid tone or note that came out of it.

Anyway I am running Slackware 13 32 bit with a GA-EP43-DS3l mobo
How can I find alsa version?
 
Old 09-08-2009, 04:48 PM   #7
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,388
Blog Entries: 3

Rep: Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479
Hi,

Welcome to LQ & Slackware!

Quote:
Originally Posted by Geraldsmod View Post
Well I found out today that the speakers power surged and made them go off. It was like a solid tone or note that came out of it.

Anyway I am running Slackware 13 32 bit with a GA-EP43-DS3l mobo
How can I find alsa version?
You just need to run as root the 'alsaconf' to detect your card. Then run 'alsamixer' to setup the sound. After that run 'alsactl store'. You can 'man commands' to get a bettter understanding.

You should now be able to use your sound system. You probably aready have the user groups setup (users floppy audio video cdrom plugdev power netdev) for your user(s).
 
Old 09-08-2009, 07:32 PM   #8
Geraldsmod
Member
 
Registered: Sep 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks a ton man.
Now my sound works in firefox too!
 
  


Reply

Tags
audio, error, remove, slackware, sound, speaker


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Forward Audio to Remote Speakers digerati Linux - Software 3 03-04-2010 07:03 PM
[SOLVED] Capturing digital audio on the way to my speakers josephj Linux - Desktop 4 11-24-2008 04:35 PM
USB Headphones & OnBoard Audio/Speakers MIRV Linux - Hardware 0 02-27-2008 04:25 AM
Select speakers or headset for audio output? tcamp Linux - Hardware 3 01-10-2006 01:11 PM
MDK 10: NForce1 audio: getting rear speakers to work lukeas Linux - Hardware 2 11-03-2004 03:14 PM


All times are GMT -5. The time now is 06:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration