LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-07-2008, 01:02 AM   #1
josefig
LQ Newbie
 
Registered: Feb 2008
Location: Mexico
Distribution: Slackware,Ubuntu, Fedora
Posts: 6

Rep: Reputation: 0
Exclamation Problem with 82801G Intel CH7 Audio (ALSA)


Hello everybody,

My name is jose from mexico and I'm a kind of newbie, and i just installed slackware 12. I configured the X's server thanks to a guide and i also configured my network and somethings to my work (designer and programmer)

But when I was trying to configure my audio I had a problem with, I have an Integred Audio (82801G Intel CH7 High Definition Audio) the alsaconf detected with a Sigmatel driver (or something like that). I ran the audacious and it shows me like it was playing my mp3 files but when I turn the volume up of my speakers these didn't work properly I mean they didn't do anything not even a simple beep! or something.

I got a guide from a guy explaining the "solution" but in Ubuntu and I had to recompile the alsa with a driver but nothing happened and now I dont even detect my audio card with alsaconf...
I downloaded the last version of the alsa-driver, alsa-utils, alsa-tools.

Isn't it ironic? :S

Please if someone can help me.. please do it, step by step :P 'cause i don't know much 'bout it.

=)

Thank you.
 
Old 02-07-2008, 03:38 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Unhappy problem with 8201g intel ch7 audio alsa

I have the same problem with this sound card in suse 10.3
I try every possible solution but it still do not work
Suse 10.3 knew it ich7 and use snd-intel as driver
kmix is full open but still no sound

so I wiil follow you,re problem to
If I find a solution I will let you know

all the best
 
Old 02-07-2008, 09:30 AM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Can you post the output of 'lsmod' and '/sbin/lspci -vv'.

Also, I know you probably already did this but check 'alsamixer' and make sure the volume is not muted, just to be extra sure.
 
Old 02-11-2008, 03:08 AM   #4
josefig
LQ Newbie
 
Registered: Feb 2008
Location: Mexico
Distribution: Slackware,Ubuntu, Fedora
Posts: 6

Original Poster
Rep: Reputation: 0
Cool Solution! How to Configure 82801G Intel Audio

Hello again...

You know, special thanks to a guy in freenode who helped me with this problem, nick 'el_choya_II' a real guru.

Well first step:
I unistall all packages about alsa, alsa-utils, alsa-oss and alsa-lib.

Second step:
Reinstall all packages (I recommend you that install all packages with your manager i.e. apt-get, slapt-get, etc)

Third Step: (as root)
# cd /usr/src/linux
# su
# make xconfig
And you'll see a graphic tree of the kernel configuration, you have to go to Sound -> Advanced Linux Sound Architecture and you have to see if it's marked with a point or a (*) like that.

Fourth Step:
Now we have to go to PCI Devices -> Intel HD Audio, we have to see if Intel HD Audio is as module a dot on xconfig and on menuconfig is M.

Fifth Step:
Now try as root:
# modprobe snd
# modprobe snd-hda-intel

Sixth Step:
If everything is ok without error up to this moment then we have to add those lines in /etc/rc.d/rc.modules and save the changes with pico or vi

Seventh Step:
Then, now ...
# alsaconf
(remember.. install alsa-utils hehe 'cause you'll need it to do this).
and:
# alsamixer

and voilá! you'll get audio.. try with audacious or with amp..

thank you I did that and it worked for me
 
Old 02-11-2008, 05:52 AM   #5
evilDagmar
Member
 
Registered: Mar 2005
Location: Right behind you.
Distribution: NBG, then randomed.
Posts: 480

Rep: Reputation: 31
So, in other words, the solution is the same for all the other Intel HDA sound problems (whose number is legion): Upgrade to a newer kernel which contains newer versions of the ALSA drivers.
 
Old 02-11-2008, 10:42 AM   #6
dreyfuss
Member
 
Registered: Jun 2007
Location: Italy
Distribution: Slackware current
Posts: 39

Rep: Reputation: 15
I had your same problem and i solved it by deleting the last row of /etc/modprobe.d/sound and adding this one:
Code:
options snd-hda-intel position_fix=1 model=3stack
 
Old 02-12-2008, 10:20 PM   #7
josefig
LQ Newbie
 
Registered: Feb 2008
Location: Mexico
Distribution: Slackware,Ubuntu, Fedora
Posts: 6

Original Poster
Rep: Reputation: 0
Unhappy new problem

hehe now i have a new problem, when i turn on the computer i have to type alsaconf and alsamixer again, why?
 
Old 02-13-2008, 04:17 AM   #8
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Because you forgot to run 'alsactl store' as root to store the volume levels and other settings it generated.
 
Old 02-13-2008, 06:27 AM   #9
dreyfuss
Member
 
Registered: Jun 2007
Location: Italy
Distribution: Slackware current
Posts: 39

Rep: Reputation: 15
Quote:
Originally Posted by josefig View Post
hehe now i have a new problem, when i turn on the computer i have to type alsaconf and alsamixer again, why?
Add to your /etc/rc.d/rc.modules this row:
Code:
/sbin/modprobe snd-hda-intel position_fix=1 model=3stack
 
Old 09-12-2009, 01:28 AM   #10
turdbutton
LQ Newbie
 
Registered: Sep 2009
Posts: 1

Rep: Reputation: 0
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
no sound :-/
 
  


Reply

Tags
audio, intel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Corporation 82801G (ICH7 Family) Audio device - No mic odiseo77 Linux - Hardware 1 05-14-2009 06:47 AM
Intel 82801G HD Audio - Constant High-pitched buzz person132 Linux - Hardware 3 07-17-2007 02:04 AM
(gentoo) onboard intel 82801G audio - no device Argent Linux - Hardware 4 07-08-2007 01:44 PM
Sound card not detected - Intel 82801G, ALSA 1.0.14 as2100 Linux - Hardware 5 06-11-2007 10:21 PM
Alsa v1.0.14rc2 Not working with Intel 82801G on Redhat enterprise 4 RHEL4 utee Linux - General 3 02-28-2007 01:28 PM


All times are GMT -5. The time now is 03:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration