LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-04-2014, 07:11 PM   #1
insectiod
Member
 
Registered: Feb 2013
Posts: 31

Rep: Reputation: Disabled
Problem running qemu on slackware 14.1 (32bit)


Hi

I installed qemu from Slackbuilds without problems. As far as I can tell I have hardware support, and the necessary kernel modules:

Code:
>>>sudo lsmod | grep kvm
Password:
kvm_intel             119658  0
kvm                   311379  1 kvm_intel

>>>cat /proc/cpuinfo | grep vmx
shows vmx in flags
I follow the instructions here.

Code:
>>>qemu-system-i386 linux-0.2.img
qemu window starts, showing nothing. top shows qemu process running consuming less than 10% cpu.

Code:
>>>qemu-img create -f qcow2 slack.img 10G
Formatting 'slack.img', fmt=qcow2 size=10737418240 encryption=off cluster_size=65536 lazy_refcounts=off
>>>qemu-system-i386 -m 256 -hda slack.img -cdrom ../Downloads/slackware-14.1-iso/slackware-14.1-install-dvd.iso -boot d
Same thing as above, black screen.

Code:
>>>qemu-system-i386 --bios /usr/share/qemu/bios.bin -m 256 -hda slack.img -cdrom ../Downloads/slackware-14.1-iso/slackware-14.1-install-dvd.iso -boot d
Trying with another bios. This boots after several seconds but then hangs after displaying a message about No volume groups found. At this point I'm not sure if qemu hangs or if it's just really slow. So I try to explicitly enable kvm:

Code:
qemu-system-i386 --enable-kvm --bios /usr/share/qemu/bios.bin -m 256 -hda slack.img -cdrom ../Downloads/slackware-14.1-iso/slackware-14.1-install-dvd.iso -boot d
This also hangs immediately with a black screen.

Any tips on how to get qemu with kvm up and running? I would prefer to get it up and running with just qemu to start with, because trying to use libvirt gave me even more problems, and I think it's easier to troubleshoot with fewer programs involved.

Edit:
The version from slackbuilds i installed is 1.6.1.
I also tried to compile the latest version from git, 1.7.50. This also installed fine but gave me the same problems.

Last edited by insectiod; 01-04-2014 at 07:18 PM.
 
Old 01-04-2014, 07:44 PM   #2
hemp4fuel
Member
 
Registered: Jun 2003
Location: Topeka, KS
Distribution: Slackware
Posts: 192

Rep: Reputation: 45
I had the same experience so I went back to using the qemu-kvm that alienbob has in his repo:

http://taper.alienbase.nl/mirrors/pe...ilds/qemu-kvm/

It is an older version, but works perfectly for me.
 
1 members found this post helpful.
Old 01-04-2014, 07:51 PM   #3
insectiod
Member
 
Registered: Feb 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Interesting, I'll try that. But if anyone has got the new qemu only version working please share how.
 
Old 01-04-2014, 08:51 PM   #4
insectiod
Member
 
Registered: Feb 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Unfortunately the build script you linked doesn't compile for me on 14.1. What version of slackware are you running. The compile error is shown below. I installed vde2 version 2.3.2 from slackbuilds to satisfy the vde requirement.
Code:
 LINK  vscclient
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: qemu-timer.o: undefined reference to symbol 'timer_settime@@GLIBC_2.2'
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: note: 'timer_settime@@GLIBC_2.2' is defined in DSO /lib/librt.so.1 so try adding it to the linker command line
/lib/librt.so.1: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [vscclient] Error 1
  LINK  vscclient
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: qemu-timer.o: undefined reference to symbol 'timer_settime@@GLIBC_2.2'
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: note: 'timer_settime@@GLIBC_2.2' is defined in DSO /lib/librt.so.1 so try adding it to the linker command line
/lib/librt.so.1: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [vscclient] Error 1
install: cannot create regular file '/tmp/build/package-qemu-kvm/usr/bin/kvm_stat': No such file or directory
./qemu-kvm.SlackBuild FAILED at line 197
 
Old 01-04-2014, 09:10 PM   #5
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.15.5
Posts: 1,535
Blog Entries: 12

Rep: Reputation: 172Reputation: 172
Hmm, I modified the Slackbuild.org file for qemu 1.60 to install 1.7.50 and it works.
 
1 members found this post helpful.
Old 01-04-2014, 09:13 PM   #6
hemp4fuel
Member
 
Registered: Jun 2003
Location: Topeka, KS
Distribution: Slackware
Posts: 192

Rep: Reputation: 45
Quote:
Originally Posted by insectiod View Post
Unfortunately the build script you linked doesn't compile for me on 14.1. What version of slackware are you running. The compile error is shown below. I installed vde2 version 2.3.2 from slackbuilds to satisfy the vde requirement.
I just installed his premade packages in 14.1.
 
1 members found this post helpful.
Old 01-04-2014, 09:34 PM   #7
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,555

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
Try update your cairo package using the one in current
It worked here on my machine
 
1 members found this post helpful.
Old 01-05-2014, 09:05 AM   #8
insectiod
Member
 
Registered: Feb 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Thanks! Installing cairo from current fixed the problem. Just out of curiosity, how did you figure this out? I would like to become better at fixing these kind of problems myself.

If anyone else has similar problems, here are slightly more detailed steps.
Install cairo 1.12.16 from current.
Use qemu from slackbuilds but modify version to 1.7.0
Download qemu-1.7.0.tar.bz from here

Edit:
1.7.50 from git also works with newer cairo.

Last edited by insectiod; 01-05-2014 at 09:09 AM.
 
Old 01-05-2014, 09:51 AM   #9
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
using 1.7.0 is not mandatory: it's the cairo upgrade (it has been rebuilt omitting some options that broke qemu) that matters.
 
Old 01-05-2014, 10:16 AM   #10
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,555

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
Quote:
Originally Posted by insectiod View Post
Thanks! Installing cairo from current fixed the problem. Just out of curiosity, how did you figure this out? I would like to become better at fixing these kind of problems myself.
It's already discussed here
 
Old 08-04-2014, 12:10 PM   #11
d.j.peters
LQ Newbie
 
Registered: Jul 2004
Location: germany nrw essen
Distribution: Slackware 14.1 x86
Posts: 8

Rep: Reputation: 0
qemu Version 2.0.0

I installed cairo-1.12.16-i486-1.txz from from http://ftp.gwdg.de/linux/slackware/s....16-i486-1.txz
if I run ~/qemu# TARGETS=all ./qemu.SlackBuild
all parts compiled but on last step the linking stage I get:
Code:
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_glyph_cache_remove'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_glyph_cache_freeze'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_glyph_cache_thaw'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_composite_glyphs'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_glyph_cache_lookup'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_glyph_get_mask_format'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_glyph_cache_insert'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_glyph_cache_create'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_add_triangles'
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../libcairo.so: undefined reference to `pixman_composite_glyphs_no_mask'
Is the libcario-1.12.16-486 to old or is the libcario dev package needed ?

I got qemu.SlackBuild from here: http://slackbuilds.org/repository/14.1/system/qemu/

Thank you

DJ

edit: same problem if I try qemu 1.7.2

Last edited by d.j.peters; 08-04-2014 at 01:09 PM.
 
Old 08-04-2014, 12:56 PM   #12
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
Code:
/usr/lib/gcc/i486-slackware-linux/4.5.2
which version of Slackware are you running?

the topic was about slackware-14.1, and the fixed cairo is now in /patches of that version...

Last edited by ponce; 08-04-2014 at 01:05 PM.
 
Old 08-06-2014, 04:06 AM   #13
d.j.peters
LQ Newbie
 
Registered: Jul 2004
Location: germany nrw essen
Distribution: Slackware 14.1 x86
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by ponce View Post
which version of Slackware are you running?
Slackware 14.1 (x86)
Quote:
Originally Posted by ponce View Post
the fixed cairo is now in /patches of that version...
thank you ponce
I will try it.

DJ
 
Old 08-06-2014, 04:12 AM   #14
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
Quote:
Originally Posted by d.j.peters View Post
Slackware 14.1 (x86)
that's really strange, because slackware-14.1 doesn't have gcc-4.5.2...
 
Old 08-07-2014, 05:31 AM   #15
d.j.peters
LQ Newbie
 
Registered: Jul 2004
Location: germany nrw essen
Distribution: Slackware 14.1 x86
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by ponce View Post
that's really strange, because slackware-14.1 doesn't have gcc-4.5.2...
witch version do you would accept for 14.1 ?

DJ

Last edited by d.j.peters; 08-07-2014 at 06:38 AM.
 
  


Reply

Tags
kvm, qemu, slackware 14.1


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 13.37 Running from USB (Done with qemu) ljones0 Slackware 8 05-20-2013 10:37 AM
Problems running Slackware/Slackware64 13.0 in Qemu 0.12.1 alkos333 Slackware 14 02-21-2010 01:48 PM
On qemu-kvm, qemu-ifup script not found on Slackware 13 AndrewGaven Linux - Virtualization and Cloud 14 01-29-2010 03:36 AM
installing slack64 13.0 client on qemu winxp 32bit host fails timsoft Slackware 17 11-17-2009 03:22 PM
32bit qemu image on 64bit host? Yalla-One Slackware 14 08-25-2009 05:18 PM


All times are GMT -5. The time now is 07:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration