LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-04-2010, 12:07 PM   #1
kemsiro
Member
 
Registered: Sep 2007
Location: Vietnam
Distribution: Slackware
Posts: 38

Rep: Reputation: 15
problem running hugin 2010.2.0 work with Slack 13.1


Hi friends,

I am getting a problem to run hugin 2010.2.0 in Slackware 13.1.
After I installed all require programs (I hope that), I run hugin, but the error message show that:

"
bash-4.1# hugin
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6).
"

Is there anyone know how to fix this problem?

Thank you for your help.
 
Old 11-04-2010, 10:46 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Did you change the slackbuild?

PRGNAM=hugin
VERSION=2009.4.0
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

There may be a reason that the latest version does not work. Does version 2009.4.0 work?
 
Old 11-05-2010, 12:55 AM   #3
kemsiro
Member
 
Registered: Sep 2007
Location: Vietnam
Distribution: Slackware
Posts: 38

Original Poster
Rep: Reputation: 15
Thank you for your reply,

- At first I download the slackbuild script (currently version 2009.4.0) and change the version to 2010.2.0. But it cannot compile.
- So I go to hugin page, see what is required by it, then install those.
- Next I grap a rpm package of fedora, use the command rpm2tgz to convert it into tgz and then install it.
- I have never try the version 2009.4.0 so I don't know whether it works or not.

Last edited by kemsiro; 11-05-2010 at 12:57 AM.
 
Old 11-05-2010, 08:37 AM   #4
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
You are probably best off using the 2009.4.0 version, but if you need the newer version I would think that you could install it.
First you need to uninstall the version that does not work. Then alter the libpano13 slackbuild to build version 2.9.17 instead of 2.9.14.
Next, build the wxPython, exiftool, enblend-enfuse and autopano-sift-C slackbuilds.
Then you can try to build the new hugin-2010.2.0.
Post any errors in the configure or make steps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problems with Mandriva 2010 Spring running in Parallels Desktop 5 theoscar Linux - Newbie 3 07-26-2010 08:57 AM
Broadcom(airforce one) laptop running slack 12.0 problem GlupFire Linux - Wireless Networking 2 04-20-2008 12:16 PM
boot problem with kernel 2.6.18 on Laptop running Slack 11.0 thethinker Slackware 5 04-12-2007 10:37 AM
Problem trying to get SATA to work on Slack 10.2 brooky9999 Slackware 13 02-05-2007 12:55 PM
Problem running opera in Slack 8.1 Fluke Slackware 1 07-24-2002 09:33 PM


All times are GMT -5. The time now is 11:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration