LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-19-2013, 09:34 AM   #1
rvdboom
Member
 
Registered: Jul 2007
Distribution: Slackware
Posts: 181

Rep: Reputation: 23
Problem on compiling mesa git on Slackware64 Multilib


Hi,
I use a slackware64-current system with the latest AlienBob's multilib packages and everything works fine. I use the multilib mainly to run MS Office through Wine for my work.
I usually compile some stuff myself (x264, ffmpeg, libdrm, mesa, things like that, usually git pulls) without any problem.
However, I seem to have a problem compile mesa git recently, the last time I managed to compile it was the 22/12/2012.
Now it fails with the following messages :


Code:
gmake[2] : on entre dans le répertoire « /usr/src/CVS/mesa/src/gallium/targets »
Making all in dri-r300
gmake[3] : on entre dans le répertoire « /usr/src/CVS/mesa/src/gallium/targets/dri-r300 »
  CXXLD  r300_dri.la
/usr/lib/libexpat.so: could not read symbols: File in wrong format
collect2: error: ld returned 1 exit status
gmake[3]: *** [r300_dri.la] Erreur 1
gmake[3] : on quitte le répertoire « /usr/src/CVS/mesa/src/gallium/targets/dri-r300 »
gmake[2]: *** [all-recursive] Erreur 1
It obviously try to link with the 32bits lib instead of going for the 64bits one in /usr/lib64 but can't find out why. The build use proper ARCH and /usr/lib64 dir for libs, everything else compiles fine on this system and creates proper 64bits files. I suspect something wrong in the current mesa code but I'm not knowledgeable enough to know where to fix it.
I use basically the same build options for configure as the official mesa Slackbuild.
If anyone has a clue where to look for, I'm interested!
 
Old 01-19-2013, 01:31 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,194

Rep: Reputation: Disabled
Try to sneak in a "LDFLAGS=-L/usr/lib64" somewhere appropriate in the SlackBuild script. Slackware's scripts are not written with multilib in mind and sometimes you'll run into this situation where the 32-bit libraries are found first.

Eric
 
Old 01-20-2013, 10:24 AM   #3
rvdboom
Member
 
Registered: Jul 2007
Distribution: Slackware
Posts: 181

Original Poster
Rep: Reputation: 23
Hi, Eric, and thanks for the feedback.
I tried to set the LDFLAGS before configure, before make but to no avail : same problem.
Really weird. My guess is that either there is something weird in mesa's code or my system is a bit flacky.
 
Old 01-22-2013, 01:47 PM   #4
ml4711
Member
 
Registered: Aug 2012
Location: Ryomgård, Danmark
Distribution: Slackware
Posts: 74

Rep: Reputation: 34
Just hide the "/usr/lib", during compilation:

Code:
mount --bind /home/ftp /usr/lib
It works very well.

Morten
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Compiling pulseaudio on slackware64 14 with multilib Chelyuk Slackware 7 10-05-2012 01:49 PM
Compiling mesa from git rvdboom Slackware 7 09-01-2010 10:53 AM
[SOLVED] Slackware64 multilib - E17 compiling problem? kukibl Slackware 1 10-08-2009 10:50 AM


All times are GMT -5. The time now is 02:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration