LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   problem installing webcam slackware-current 64 multilib (http://www.linuxquestions.org/questions/slackware-14/problem-installing-webcam-slackware-current-64-multilib-4175442794/)

afreitascs 12-24-2012 09:45 AM

problem installing webcam slackware-current 64 multilib
 
By using kamerka ( SlackBuild ) I get the error:

Code:

base1@base1:~$ kamerka
Kamerka version 0.8.1
    Copyright (C) 2011 Sebastian Krzyszkowiak
    Kamerka comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it
    under certain conditions; type `./kamerka --license' for details.
kamerka(4088)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
libv4l2: error dequeuing buf: Resource temporarily unavailable
libv4l2: error dequeuing buf: Resource temporarily unavailable
libv4l2: error dequeuing buf: Resource temporarily unavailable
..........
..........
..........indefinitely

and I don't see any picture.

My webcam uses technology aveo

$ lsusb

Quote:

base1@base1:~$ lsusb
Bus 002 Device 002: ID 1871:0141 Aveo Technology Corp.
Bus 005 Device 002: ID 15d9:0a37 Trust International B.V. Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Could someone help me, please? Thanks

ps: from dmesg

Quote:

[ 1.320254] usb 2-1: New USB device found, idVendor=1871, idProduct=0141
[ 1.321846] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1.323461] usb 2-1: Product: USB2.0 Camera
[ 1.325080] usb 2-1: Manufacturer: AVEO Technology Corp.

[ 7.501725] Linux video capture interface: v2.00
[ 7.558286] uvcvideo: Found UVC 1.00 device USB2.0 Camera (1871:0141)
[ 7.562282] input: USB2.0 Camera as /devices/pci0000:00/0000:00:13.2/usb2/2-1/2-1:1.0/input/input8
[ 7.565103] usbcore: registered new interface driver uvcvideo
[ 7.567895] USB Video Class driver (1.1.1)
[ 7.905091] 2:3:1: cannot get freq at ep 0x84
[ 7.908738] usbcore: registered new interface driver snd-usb-audio
[ 8.836311] Adding 6796284k swap on /dev/sda2. Priority:-1 extents:1 across:6796284k
[ 8.899812] fuse init (API version 7.20)

slackass 12-24-2012 12:35 PM

I can't get kamerka to work right ether. It will pick up my sec cameras but not the web cam.
WXcam at slackbuilds works perfect.
Vlc also works with all my cameras.

slackass 12-24-2012 12:50 PM

Quote:

Originally Posted by slackass (Post 4856163)
I can't get kamerka to work right ether. It will pick up my sec cameras but not the web cam.
WXcam at slackbuilds works perfect.
Vlc also works with all my cameras.

Scratch that, I got it working by increasing the frame rate.

afreitascs 12-24-2012 10:17 PM

Everything works fine now using WXcam (SlackBuild) or vlc

Thanks slackass


All times are GMT -5. The time now is 06:26 AM.