LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-29-2006, 07:22 AM   #1
ge_penyoe8
LQ Newbie
 
Registered: May 2006
Location: Bandung, Indonesia
Distribution: Slackware 10.1
Posts: 2

Rep: Reputation: 0
Problem in Installing TV Tuner (chipset CX88xx)


I have problem in installing TVTuner in slackware 10.1 (kernel 2.6.13.2 and kde 3.3). My TV tuner chip is conexant cx8800. I have download the driver from dl.bytesex.org but i have a problem when installing the driver. Here is the message i get when i try to "make" the driver...

bash-3.00# make KDIR=/usr/src/linux
make -C /usr/src/linux SUBDIRS=/usr/src/cx88-0.0.4 modules
make[1]: Entering directory `/usr/src/linux-2.6.13.2'
CC [M] /usr/src/cx88-0.0.4/video-buf.o
CC [M] /usr/src/cx88-0.0.4/v4l1-compat.o
CC [M] /usr/src/cx88-0.0.4/v4l2-common.o
CC [M] /usr/src/cx88-0.0.4/btcx-risc.o
CC [M] /usr/src/cx88-0.0.4/cx88-video.o
/usr/src/cx88-0.0.4/cx88-video.c: In function `cx8800_suspend':
/usr/src/cx88-0.0.4/cx88-video.c:2552: error: too many arguments to function `pci_save_state'
/usr/src/cx88-0.0.4/cx88-video.c: In function `cx8800_resume':
/usr/src/cx88-0.0.4/cx88-video.c:2571: error: too many arguments to function `pci_restore_state'
make[2]: *** [/usr/src/cx88-0.0.4/cx88-video.o] Error 1
make[1]: *** [_module_/usr/src/cx88-0.0.4] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.13.2'
make: *** [default] Error 2

Need advice please.....
thanks.....
 
Old 05-29-2006, 07:28 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,390

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
the cx88 drivers have been in the 2.6 kernel for a few years now, you shouldn't need to install the release from 2004. do ou not have the modules under /lib/modules somewhere already?
 
Old 05-29-2006, 11:24 AM   #3
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
If you don't have them, the easiest way is to recompile the kernel, and make the modules. (Many guides on this forum for that)
 
Old 05-30-2006, 08:36 PM   #4
ge_penyoe8
LQ Newbie
 
Registered: May 2006
Location: Bandung, Indonesia
Distribution: Slackware 10.1
Posts: 2

Original Poster
Rep: Reputation: 0
Question

Ups, i didn't see Conexant support in Video for Linux setting he..he...he...
btw, i have recompile my kernel with Conexant support. Then according to tutorial that i get, i add these lines to my /etc/modprobe.conf because the driver didn't automatically detect my TV card (my TV card is PixelView Ultra Pro):

options cx8800 video_nr=0 radio_nr=0
options cx88xx card=27 tuner=44

then i re-modprobe cx8800 module then type dmesg. here's the message i got:

Linux video capture interface: v1.00
cx2388x v4l2 driver version 0.0.5 loaded
PCI: Found IRQ 10 for device 0000:00:0a.0
PCI: Sharing IRQ 10 with 0000:00:10.2
PCI: Sharing IRQ 10 with 0000:00:11.5
cx88[0]: subsystem: 0000:0000, board: PixelView PlayTV Ultra Pro (Stereo) [card=27,insmod option]
TV tuner 44 at 0x1fe, Radio tuner -1 at 0x1fe
tveeprom(cx88xx internal): Huh, no eeprom present (err=-121)?
cx88[0]: registered IR remote control
cx88[0]/0: found at 0000:00:0a.0, rev: 2, irq: 10, latency: 32, mmio: 0xe2000000
: chip found @ 0xc0 (cx88[0])
: All bytes are equal. It is not a TEA5767
tuner 1-0060: type set to 44 (Philips 4 in 1 (ATI TV Wonder Pro/Conexant))
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
cx88[0]/0: registered device radio0

Sorry if too newbie, but how do i know if the driver and my TV card is working? I try to install xawTV-3.95 then when i try to run it, all i get only blank blue screen. I have no idea how to configure it....
 
  


Reply

Tags
conexant, tuner, tv


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TV Tuner With Conexant cx88xx Chipset Richard Craneum Linux - Hardware 1 04-01-2006 09:32 AM
Problem in installing Linux Fedora core 4 in intel 915 GV chipset bhaskarjha17 Linux - Newbie 1 01-29-2006 06:59 AM
problem installing intel chipset drivers matrixon Linux - Software 1 06-28-2005 11:48 AM
Installing TV Tuner card in Redhat khandu Linux - Software 3 08-09-2004 11:02 AM
Trouble installing TV Tuner Card madman_rocks Linux - Hardware 7 02-03-2003 09:18 AM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration