LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-01-2008, 06:02 AM   #1
neu2linux
Member
 
Registered: Mar 2007
Location: Albuquerque, NM
Distribution: Debian, Slackware, Ubuntu
Posts: 46

Rep: Reputation: 15
problem connecting to wifi


I have just finished installing 12.1 and madwifi. I am having a bit of a problem connecting to my home network via ath0. The connection uses a 128 bit WEP key. I have no problem connecting to my work network which uses 64 WEP. This is my first run with Slackware and have no idea where to go from here.


here is my iwconfig output:


no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"GETYOUROWN" Nickname:""
Mode:Managed Frequency:2.437 GHz Access Point: 00:0F:66:63:2C:FE
Bit Rate:36 Mb/s Tx-Power:16 dBm Sensitivity=1/1
Retryff RTS thrff Fragment thrff
Encryption key:****-****-****-****-****-****-** Security mode:restricted
Power Managementff
Link Quality=66/70 Signal level=-30 dBm Noise level=-96 dBm
Rx invalid nwid:65777 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Any input would be appreciated.
Thanks
-Eric
 
Old 10-01-2008, 08:33 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Configuring your network in Slackware should answer your questions.

If that doesn't help you solve it, post back what you did ...
 
Old 10-09-2008, 01:08 PM   #3
neu2linux
Member
 
Registered: Mar 2007
Location: Albuquerque, NM
Distribution: Debian, Slackware, Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 15
I followed the how-to, but it still refuses to go to the internet.

I found out that it is connecting to the router. When I type in the routers IP, it asks for the username and password used for changing the settings. It just wont allow me to access the internet. I have tried pinging various sites with no luck. Could there be security restrictions in Slackware that are causing this? This laptop dual-boots with Vista which connects fine.
 
Old 10-09-2008, 01:49 PM   #4
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 211

Rep: Reputation: 41
Have a look here...

https://www.linuxquestions.org/quest...-slack-674997/
 
Old 10-09-2008, 05:54 PM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally Posted by neu2linux View Post
I followed the how-to, but it still refuses to go to the internet.

I found out that it is connecting to the router. When I type in the routers IP, it asks for the username and password used for changing the settings. It just wont allow me to access the internet. I have tried pinging various sites with no luck. Could there be security restrictions in Slackware that are causing this? This laptop dual-boots with Vista which connects fine.
Please give the output of "cat /etc/resolv.conf"
 
Old 10-09-2008, 06:06 PM   #6
johnson_steve
Senior Member
 
Registered: Apr 2005
Location: BrewCity, USA (Milwaukee, WI)
Distribution: Xubuntu 9.10, Gentoo 2.6.27 (AMD64), Darwin 9.0.0 (arm)
Posts: 1,152

Rep: Reputation: 46
Quote:
Originally Posted by Bruce Hill View Post
Please give the output of "cat /etc/resolv.conf"
this is probably the problem are you using dhcp or manual ip addresses? can you for instance: ping google form another computer, write down the ip address and then ping that from your laptop? like:
Code:
ping 72.14.205.104
 
Old 10-10-2008, 06:04 PM   #7
neu2linux
Member
 
Registered: Mar 2007
Location: Albuquerque, NM
Distribution: Debian, Slackware, Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 15
Output from cat /etc/resolv.conf returns

Code:
search darco.local
nameserver 192.168.2.100
darco.local is the Win network that I connect to at work.

And I am using DHCP.
 
Old 10-10-2008, 06:17 PM   #8
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 211

Rep: Reputation: 41
Is the IP address of your router 192.168.2.100?? Because they typically will end in a *.*.*.1

If it does end in that try adding a route

Code:
route add default gw 192.168.2.100
 
Old 10-10-2008, 07:47 PM   #9
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Please add the following lines to the top of your /etc/resolv.conf:
Code:
nameserver 4.2.2.1
nameserver 4.2.2.2
nameserver 4.2.2.3
nameserver 4.2.2.4
and try again. Those Verizon servers have worked for me for more
than a decade.
 
Old 10-11-2008, 01:35 AM   #10
neu2linux
Member
 
Registered: Mar 2007
Location: Albuquerque, NM
Distribution: Debian, Slackware, Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Bruce Hill View Post
Please add the following lines to the top of your /etc/resolv.conf:
Code:
nameserver 4.2.2.1
nameserver 4.2.2.2
nameserver 4.2.2.3
nameserver 4.2.2.4
and try again. Those Verizon servers have worked for me for more
than a decade.
that did it. thank you, though I don't quite understand it. none the less it is working great.
 
Old 10-11-2008, 05:41 AM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
That tells us the previous nameserver(s) you used are not working.

Read "man resolv.conf" to get more of an idea what it's doing. My
guess would be that darco.local is not running a name server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Connecting wifi through Dlink card? devil_suse Linux - Wireless Networking 6 10-05-2008 06:28 AM
WIFI Connecting via Commandline SlipDigby Linux - Wireless Networking 5 09-23-2008 02:57 AM
Connecting to wifi birddseedd Linux - Wireless Networking 2 02-13-2007 10:45 AM
wifi connecting Nostur Linux - Wireless Networking 3 09-08-2006 01:12 PM
Connecting to WiFi fails Ubuntu 3 10-07-2005 01:25 PM


All times are GMT -5. The time now is 05:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration